[Xorg] MESA with libglvnd support

mesa
xorg-stack
libglvnd

#1

Hi Community,

We will adjust to mesa with libglvnd support. Therefore some packages get modified, incl. mhwd, bumblebee and other packages related to libgl. We have also to check if catalyst will work still or if we have to drop it. More about it here, here and here.

Please read the whole thread, if you have issues with your graphic drivers. Most of the issues we had tracked here. If nothing helps you can always reinstall Manjaro with our current release. All the needed mesa-libglvnd updates are included.


[Stable Update] 2017-04-02 - Mesa-Stack, Kernels, Plasma, Firefox
Steam not starting
[Unstable Update] 2017-03-18 - Firefox, Virtualbox, Haskell, Python, Kernels
[Unstable Update] 2017-03-12 - Mesa, Python, Haskell, Vulkan, Imagemagick
Problem: libGL error: No matching fbConfigs or visuals found
[Testing Update] 2017-03-22 - Elogind, Plasma, Deepin, Manjaro-Architect
Optimus-Support
So I have an update issue
Why do Manjaro Stable updates break the system? Is it bad testing?
[Unstable Update] 2017-03-12 - Mesa, Python, Haskell, Vulkan, Imagemagick
[Testing Update] 2017-03-25 - Calamares, Pamac, Deepin, Palemoon
[Testing Update] 2017-03-27 - Kernels, Manjaro Tools, Grub, ISO-Profiles
[Stable Update] 2017-04-02 - Mesa-Stack, Kernels, Plasma, Firefox
Help me find a solution to get my system or at least my data back
AMDGPU improvements for Manjaro OUTDATED
Trouble updating after fresh install
#2

Will it be fixed before it reaches Testing?


#3

Na, I will break all branches and take a half year vacation …


#4

LOL :smile:


#5

I confirm the problem. I can’t update my system today because:

 : Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: mesa and mhwd are in conflict (mesa-libgl). Remove mhwd? [y/N] 


#6

Bumblebee is already fixed for this here:

and released here:

EDIT
ONE MORE pull ready for merge from today:

This Pull adopt small changes in build section based on upstream https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/bumblebee&id=504c7d275b44eb5bc484f5ef28842bfddeb9d596

@oberon @Ste74 @philm please apply.


Problem updating 17.1 Dev Edition, mhwd, lib32-glu lib32-libgl conflict
#7
:: Processing package changes...
(1/1) upgrading manjaro-system                                                           [----------------------------------------------------] 100%
==> Removing depreciated /usr/lib/libEGL.so.1.0.0 symlink ...
==> Removing depreciated /usr/lib/libEGL.so.1 symlink ...
==> Removing depreciated /usr/lib/libEGL.so symlink ...
==> Removing depreciated /usr/lib/libGL.so.1.2.0 symlink ...
==> Removing depreciated /usr/lib/libGL.so.1 symlink ...
==> Removing depreciated /usr/lib/libGL.so symlink ...
==> Removing depreciated /usr/lib/libGLESv1_CM.so.1.1.0 symlink ...
==> Removing depreciated /usr/lib/libGLESv1_CM.so.1 symlink ...
==> Removing depreciated /usr/lib/libGLESv1_CM.so symlink ...
==> Removing depreciated /usr/lib/libGLESv2.so.2.0.0 symlink ...
==> Removing depreciated /usr/lib/libGLESv2.so.2 symlink ...
==> Removing depreciated /usr/lib/libGLESv2.so symlink ...
==> Removing depreciated /usr/lib32/libEGL.so.1.0.0 symlink ...
==> Removing depreciated /usr/lib32/libEGL.so.1 symlink ...
==> Removing depreciated /usr/lib32/libEGL.so symlink ...
==> Removing depreciated /usr/lib32/libGL.so.1.2.0 symlink ...
==> Removing depreciated /usr/lib32/libGL.so.1 symlink ...
==> Removing depreciated /usr/lib32/libGL.so symlink ...
==> Removing depreciated /usr/lib32/libGLESv1_CM.so.1.1.0 symlink ...
==> Removing depreciated /usr/lib32/libGLESv1_CM.so.1 symlink ...
==> Removing depreciated /usr/lib32/libGLESv1_CM.so symlink ...
==> Removing depreciated /usr/lib32/libGLESv2.so.2.0.0 symlink ...
==> Removing depreciated /usr/lib32/libGLESv2.so.2 symlink ...
==> Removing depreciated /usr/lib32/libGLESv2.so symlink ...

:: Starting full system upgrade...
warning: powerline-fonts-git: ignoring package upgrade (r100.a44abd0-3 => 20151211.a44abd0-1)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: lib32-cairo: installing mhwd (0.6.0rc1-2) breaks dependency 'lib32-libgl'
:: lib32-glu: installing mhwd (0.6.0rc1-2) breaks dependency 'lib32-libgl'
:: lib32-libva: installing mhwd (0.6.0rc1-2) breaks dependency 'lib32-libgl'
:: lib32-pango: installing mhwd (0.6.0rc1-2) breaks dependency 'lib32-libgl'
:: steam-manjaro: installing mhwd (0.6.0rc1-2) breaks dependency 'lib32-libgl'

This is what I get - how to proceed? Intel graphics only.


#8

resolving dependencies…
looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: lib32-primus: installing mhwd (0.6.0rc1-2) breaks dependency ‘lib32-mesa-libgl’

[fademind@manjaro ~]$ yaourt -Sy
:: Synchronizing package databases...
 core                                        138,0 KiB   476K/s 00:00 [######################################] 100%
 extra is up to date
 community is up to date
 multilib is up to date
[fademind@manjaro ~]$ yaourt -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
error: failed to prepare transaction (could not satisfy dependencies)
:: Some packages should be upgraded first...
resolving dependencies...
looking for conflicting packages...

Packages (1) manjaro-system-20170312-2

Total Download Size:   0,02 MiB
Total Installed Size:  0,00 MiB
Net Upgrade Size:      0,00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 manjaro-system-20170312-2-any                19,0 KiB   302K/s 00:00 [######################################] 100%
(1/1) checking keys in keyring                                        [######################################] 100%
(1/1) checking package integrity                                      [######################################] 100%
(1/1) loading package files                                           [######################################] 100%
(1/1) checking for file conflicts                                     [######################################] 100%
(1/1) checking available disk space                                   [######################################] 100%
:: Processing package changes...
(1/1) upgrading manjaro-system                                        [######################################] 100%
==> Removing depreciated /usr/lib/libEGL.so.1.0.0 symlink ...
==> Removing depreciated /usr/lib/libEGL.so.1 symlink ...
==> Removing depreciated /usr/lib/libEGL.so symlink ...
==> Removing depreciated /usr/lib/libGL.so.1.2.0 symlink ...
==> Removing depreciated /usr/lib/libGL.so.1 symlink ...
==> Removing depreciated /usr/lib/libGL.so symlink ...
==> Removing depreciated /usr/lib/libGLESv1_CM.so.1.1.0 symlink ...
==> Removing depreciated /usr/lib/libGLESv1_CM.so.1 symlink ...
==> Removing depreciated /usr/lib/libGLESv1_CM.so symlink ...
==> Removing depreciated /usr/lib/libGLESv2.so.2.0.0 symlink ...
==> Removing depreciated /usr/lib/libGLESv2.so.2 symlink ...
==> Removing depreciated /usr/lib/libGLESv2.so symlink ...
==> Removing depreciated /usr/lib32/libEGL.so.1.0.0 symlink ...
==> Removing depreciated /usr/lib32/libEGL.so.1 symlink ...
==> Removing depreciated /usr/lib32/libEGL.so symlink ...
==> Removing depreciated /usr/lib32/libGL.so.1.2.0 symlink ...
==> Removing depreciated /usr/lib32/libGL.so.1 symlink ...
==> Removing depreciated /usr/lib32/libGL.so symlink ...
==> Removing depreciated /usr/lib32/libGLESv1_CM.so.1.1.0 symlink ...
==> Removing depreciated /usr/lib32/libGLESv1_CM.so.1 symlink ...
==> Removing depreciated /usr/lib32/libGLESv1_CM.so symlink ...
==> Removing depreciated /usr/lib32/libGLESv2.so.2.0.0 symlink ...
==> Removing depreciated /usr/lib32/libGLESv2.so.2 symlink ...
==> Removing depreciated /usr/lib32/libGLESv2.so symlink ...

:: Starting full system upgrade...
warning: dropbox: local (21.4.25-1) is newer than community (19.4.13-1)
warning: libsystemd: local (233-1) is newer than core (232-8)
warning: systemd: local (233-1) is newer than core (232-8)
warning: systemd-sysvcompat: local (233-1) is newer than core (232-8)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: lib32-primus: installing mhwd (0.6.0rc1-2) breaks dependency 'lib32-mesa-libgl'
[fademind@manjaro ~]$ 

After removing lib32-primus update is available.

[fademind@manjaro ~]$ yaourt -R lib32-primus
checking dependencies...
:: bumblebee optionally requires lib32-primus: faster back-end for optirun

Packages (1) lib32-primus-20151110-3

Total Removed Size:  0,25 MiB

:: Do you want to remove these packages? [Y/n] 
:: Processing package changes...
(1/1) removing lib32-primus                                           [######################################] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
[fademind@manjaro ~]$ yaourt -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date

==> Package upgrade only (new release):
extra/libva                             1.7.3-1              1 -> 2
extra/libva-intel-driver                1.7.3-1              1 -> 2
extra/libva-mesa-driver                 17.0.1-1             1 -> 2
extra/mesa                              17.0.1-1             1 -> 2
extra/mesa-vdpau                        17.0.1-1             1 -> 2
extra/opencl-mesa                       17.0.1-1             1 -> 2
extra/vulkan-intel                      17.0.1-1             1 -> 2
extra/vulkan-radeon                     17.0.1-1             1 -> 2
community/primus                        20151110-6           6 -> 7
multilib/lib32-mesa-vdpau               17.0.1-1             1 -> 2
multilib/lib32-vulkan-intel             17.0.1-1             1 -> 2
multilib/lib32-vulkan-radeon            17.0.1-1             1 -> 2

==> Software upgrade (new version) :
core/mhwd                               0.5.9-3              -> 0.6.0rc1-2
core/mhwd-db                            0.5.9-4              -> 0.6.0rc1-1
extra/harfbuzz                          1.4.4-1              -> 1.4.5-1
extra/harfbuzz-icu                      1.4.4-1              -> 1.4.5-1
extra/imagemagick                       6.9.7.10-1           -> 6.9.8.0-1
extra/libglvnd                          0.1.1.20161028-1     -> 0.2.999+g4ba53457-1
extra/libmatroska                       1.4.5-1              -> 1.4.7-1
extra/libxslt                           1.1.29+23+geb1030d-1 -> 1.1.29+41+gdf5330d1-1
extra/noto-fonts-emoji                  20161020-1           -> 20170310-1
extra/python-setuptools                 1:34.3.1-1           -> 1:34.3.2-1
extra/python2-setuptools                1:34.3.1-1           -> 1:34.3.2-1
multilib/lib32-dbus                     1.10.14-1            -> 1.10.16-1
multilib/lib32-e2fsprogs                1.43.3-1             -> 1.43.4-1
multilib/lib32-libglvnd                 0.1.1.20161028-1.1   -> 0.2.999+g4ba53457-1
multilib/lib32-libgudev                 230-2                -> 231-1
multilib/lib32-libnm-glib               1.6.0-1              -> 1.6.2-1
multilib/lib32-libtasn1                 4.9-1                -> 4.10-1
multilib/lib32-sqlite                   3.16.2-1             -> 3.17.0-1
multilib/lib32-vulkan-icd-loader        1.0.39.0-1           -> 1.0.42.0-1
multilib/lib32-vulkan-validation-layers 1.0.39.0-1           -> 1.0.42.0-1
multilib/lib32-wayland                  1.12.0-1             -> 1.13.0-1

==> Continue upgrade ? [Y/n]
==> [V]iew package detail   [M]anually select packages
==> --------------------------------------------------
==> 
:: Starting full system upgrade...
warning: dropbox: local (21.4.25-1) is newer than community (19.4.13-1)
warning: libsystemd: local (233-1) is newer than core (232-8)
warning: systemd: local (233-1) is newer than core (232-8)
warning: systemd-sysvcompat: local (233-1) is newer than core (232-8)
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: mesa will be installed before its libglvnd dependency

Packages (33) harfbuzz-1.4.5-1  harfbuzz-icu-1.4.5-1  imagemagick-6.9.8.0-1  lib32-dbus-1.10.16-1
              lib32-e2fsprogs-1.43.4-1  lib32-libglvnd-0.2.999+g4ba53457-1  lib32-libgudev-231-1
              lib32-libnm-glib-1.6.2-1  lib32-libtasn1-4.10-1  lib32-mesa-vdpau-17.0.1-2  lib32-sqlite-3.17.0-1
              lib32-vulkan-icd-loader-1.0.42.0-1  lib32-vulkan-intel-17.0.1-2  lib32-vulkan-radeon-17.0.1-2
              lib32-vulkan-validation-layers-1.0.42.0-1  lib32-wayland-1.13.0-1  libglvnd-0.2.999+g4ba53457-1
              libmatroska-1.4.7-1  libva-1.7.3-2  libva-intel-driver-1.7.3-2  libva-mesa-driver-17.0.1-2
              libxslt-1.1.29+41+gdf5330d1-1  mesa-17.0.1-2  mesa-vdpau-17.0.1-2  mhwd-0.6.0rc1-2
              mhwd-db-0.6.0rc1-1  noto-fonts-emoji-20170310-1  opencl-mesa-17.0.1-2  primus-20151110-7
              python-setuptools-1:34.3.2-1  python2-setuptools-1:34.3.2-1  vulkan-intel-17.0.1-2
              vulkan-radeon-17.0.1-2

Total Download Size:    32,74 MiB
Total Installed Size:  160,16 MiB
Net Upgrade Size:       15,59 MiB

I am after reboot. Seems 64 bit works like expected.
32-bit subsystem does not work sometimes:

[fademind@manjaro ~]$ optirun glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 630M/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 375.39
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.5.0 NVIDIA 375.39
OpenGL shading language version string: 4.50 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
[fademind@manjaro ~]$ optirun glxinfo32 | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 630M/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 375.39
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  3 (X_GetWindowAttributes)
  Resource id in failed request:  0x4c00002
  Serial number of failed request:  7
  Current serial number in output stream:  8
[fademind@manjaro ~]$ 

32-bit

[fademind@manjaro ~]$ optirun glxinfo32 | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 630M/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 375.39
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  3 (X_GetWindowAttributes)
  Resource id in failed request:  0x4c00002
  Serial number of failed request:  7
  Current serial number in output stream:  8

#9

I had to remove a whole slew of stuff:

lib32-cairo lib32-glu lib32-libva lib32-pango steam-manjaro lib32-glew lib32-gtk2 lib32-libva-intel-driver wine darkmod lib32-gtk-engines lib32-mesa-demos xojo

/reinstalling them now, hopefully darkmod remembers its files downloaded :slight_smile:


#10

I fixed it with these commands - your mileage may vary

~ >>> history | grep pacman
  500  sudo pacman -Rns steam-manjaro
  503  sudo pacman -Syu mhwd --force
  504  sudo pacman -Rns lib32-glu
  505  sudo pacman -Rns lib32-glu lib32-glew
  506  sudo pacman -Rns lib32-glu lib32-glew lib32-mesa-demos
  507  sudo pacman -Syu
  508  sudo pacman -Syu --force
  515  sudo pacman -Syyu


#11

Whole 32bit is break:

[fademind@manjaro ~]$ glxinfo32 | grep OpenGL
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  38
  Current serial number in output stream:  39
[fademind@manjaro ~]$ 

Here we go:

upgraded manjaro-system (20170305-1 -> 20170312-2)
Removing depreciated /usr/lib/libEGL.so.1.0.0 symlink ...
Removing depreciated /usr/lib/libEGL.so.1 symlink ...
Removing depreciated /usr/lib/libEGL.so symlink ...
Removing depreciated /usr/lib/libGL.so.1.2.0 symlink ...
Removing depreciated /usr/lib/libGL.so.1 symlink ...
Removing depreciated /usr/lib/libGL.so symlink ...
Removing depreciated /usr/lib/libGLESv1_CM.so.1.1.0 symlink ...
Removing depreciated /usr/lib/libGLESv1_CM.so.1 symlink ...
Removing depreciated /usr/lib/libGLESv1_CM.so symlink ...
Removing depreciated /usr/lib/libGLESv2.so.2.0.0 symlink ...
Removing depreciated /usr/lib/libGLESv2.so.2 symlink ...
Removing depreciated /usr/lib/libGLESv2.so symlink ...
Removing depreciated /usr/lib32/libEGL.so.1.0.0 symlink ...
Removing depreciated /usr/lib32/libEGL.so.1 symlink ...
Removing depreciated /usr/lib32/libEGL.so symlink ...
Removing depreciated /usr/lib32/libGL.so.1.2.0 symlink ...
Removing depreciated /usr/lib32/libGL.so.1 symlink ...
Removing depreciated /usr/lib32/libGL.so symlink ...
Removing depreciated /usr/lib32/libGLESv1_CM.so.1.1.0 symlink ...
Removing depreciated /usr/lib32/libGLESv1_CM.so.1 symlink ...
Removing depreciated /usr/lib32/libGLESv1_CM.so symlink ...
Removing depreciated /usr/lib32/libGLESv2.so.2.0.0 symlink ...
Removing depreciated /usr/lib32/libGLESv2.so.2 symlink ...
Removing depreciated /usr/lib32/libGLESv2.so symlink ...

BUT files exists:

[fademind@manjaro ~]$ locate libEGL.so.1.0.0
/usr/lib/libEGL.so.1.0.0
/usr/lib32/libEGL.so.1.0.0
/usr/lib32/mesa/libEGL.so.1.0.0
[fademind@manjaro ~]$ locate libEGL.so.1
/usr/lib/libEGL.so.1
/usr/lib/libEGL.so.1.0.0
/usr/lib32/libEGL.so.1
/usr/lib32/libEGL.so.1.0.0
/usr/lib32/mesa/libEGL.so.1
/usr/lib32/mesa/libEGL.so.1.0.0
[fademind@manjaro ~]$ locate libGL.so.1.2.0
/usr/lib32/mesa/libGL.so.1.2.0

#12

I’m still working on it. This was a warning not to update unstable right now. Have fun breaking your systems. Seems I go for a vacation anyway …


#13

@philm


#14

@FadeMind got any screen wipes? I’ve done it again, missed my touchpad thank god (after last time!!!).

More seriously I need to read the forum, then make coffee, then update.

Not update, go for a cigarette, whilst the coffee machine heats up, then come back…

I haven’t rebooted (yet), still reinstalling darkmod


#15

No problems with mesa update on an Intel system. The update of manjaro-system 20170305-1 -> 20170312-2 seems to have fixed it

[2017-03-12 10:52] [ALPM] upgraded manjaro-system (20170305-1 -> 20170312-2)
[2017-03-12 10:52] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m Removing depreciated /usr/lib/libEGL.so.1.0.0 symlink ...e[1;0m
[2017-03-12 10:52] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m Removing depreciated /usr/lib/libEGL.so.1 symlink ...e[1;0m
[2017-03-12 10:52] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m Removing depreciated /usr/lib/libEGL.so symlink ...e[1;0m
[2017-03-12 10:52] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m Removing depreciated /usr/lib/libGL.so.1.2.0 symlink ...e[1;0m
[2017-03-12 10:52] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m Removing depreciated /usr/lib/libGL.so.1 symlink ...e[1;0m
[2017-03-12 10:52] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m Removing depreciated /usr/lib/libGL.so symlink ...e[1;0m
[2017-03-12 10:52] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m Removing depreciated /usr/lib/libGLESv1_CM.so.1.1.0 symlink ...e[1;0m
[2017-03-12 10:52] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m Removing depreciated /usr/lib/libGLESv1_CM.so.1 symlink ...e[1;0m
[2017-03-12 10:52] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m Removing depreciated /usr/lib/libGLESv1_CM.so symlink ...e[1;0m
[2017-03-12 10:52] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m Removing depreciated /usr/lib/libGLESv2.so.2.0.0 symlink ...e[1;0m
[2017-03-12 10:52] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m Removing depreciated /usr/lib/libGLESv2.so.2 symlink ...e[1;0m
[2017-03-12 10:52] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m Removing depreciated /usr/lib/libGLESv2.so symlink ...e[1;0m
[2017-03-12 10:52] [ALPM] transaction completed
[2017-03-12 10:56] [ALPM] transaction started
[2017-03-12 10:56] [ALPM] upgraded harfbuzz (1.4.4-1 -> 1.4.5-1)
[2017-03-12 10:56] [ALPM] upgraded harfbuzz-icu (1.4.4-1 -> 1.4.5-1)
[2017-03-12 10:56] [ALPM] upgraded imagemagick (6.9.7.10-1 -> 6.9.8.0-1)
[2017-03-12 10:56] [ALPM] upgraded mesa (17.0.1-1 -> 17.0.1-2)
[2017-03-12 10:56] [ALPM] installed libglvnd (0.2.999+g4ba53457-1)
[2017-03-12 10:56] [ALPM] upgraded libva (1.7.3-1 -> 1.7.3-2)
[2017-03-12 10:56] [ALPM] upgraded libxslt (1.1.29+23+geb1030d-1 -> 1.1.29+41+gdf5330d1-1)
[2017-03-12 10:56] [ALPM] upgraded manjaro-architect-launcher (0.8.0-1 -> 0.8.0-2)
[2017-03-12 10:56] [ALPM] upgraded mhwd-db (0.5.9-4 -> 0.6.0rc1-1)
[2017-03-12 10:56] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m Updating Config: '/var/lib/mhwd/local/pci/video-intel'e[1;0m
[2017-03-12 10:56] [ALPM] upgraded mhwd (0.5.9-3 -> 0.6.0rc1-2)
[2017-03-12 10:56] [ALPM] upgraded manjaro-architect (0.8.0-1 -> 0.8.0-2)
[2017-03-12 10:56] [ALPM] upgraded python-setuptools (1:34.3.1-1 -> 1:34.3.2-1)
[2017-03-12 10:56] [ALPM] transaction completed
[2017-03-12 10:56] [ALPM] running '98-linux49.hook'...
[2017-03-12 10:56] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux49.preset: 'default'
[2017-03-12 10:56] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.9-x86_64.img
[2017-03-12 10:56] [ALPM-SCRIPTLET] ==> Starting build: 4.9.13-1-MANJARO
[2017-03-12 10:56] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-03-12 10:56] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-03-12 10:56] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2017-03-12 10:56] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-03-12 10:56] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-03-12 10:56] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-03-12 10:56] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-03-12 10:56] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-03-12 10:56] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.9-x86_64.img
[2017-03-12 10:56] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-03-12 10:56] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux49.preset: 'fallback'
[2017-03-12 10:56] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.9-x86_64-fallback.img -S autodetect
[2017-03-12 10:56] [ALPM-SCRIPTLET] ==> Starting build: 4.9.13-1-MANJARO
[2017-03-12 10:56] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-03-12 10:56] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-03-12 10:56] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-03-12 10:56] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-03-12 10:56] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-03-12 10:56] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-03-12 10:56] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-03-12 10:56] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.9-x86_64-fallback.img
[2017-03-12 10:56] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-03-12 10:56] [ALPM] running 'gtk-update-icon-cache.hook'...
[2017-03-12 10:56] [ALPM] running 'systemd-update.hook'...
[2017-03-12 10:56] [ALPM] running 'update-desktop-database.hook'...
[2017-03-11 20:38] [PACMAN] synchronizing package lists

#16

@xircon: why did you removed some packages you never had to remove if you would have waited for my green light?

@all: Following packages need to be installed to get the new mesa-stack running. Please update me if some still fails and why.

:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                      manjaro-system           20170305-1           20170312-2
                                mhwd              0.5.9-3           0.6.0rc1-2
                             mhwd-db              0.5.9-4           0.6.0rc1-1

:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                      manjaro-system           20170305-1           20170312-2
                                mhwd              0.5.9-3           0.6.0rc1-2
                             mhwd-db              0.5.9-4           0.6.0rc1-1

:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                      catalyst-utils      1:15.201.1151-5      1:15.201.1151-6
                  nvidia-304xx-utils          1:304.134-3          1:304.134-4
                  nvidia-340xx-utils            340.101-3            340.101-4
                        nvidia-utils           1:375.39-3           1:375.39-4
                           bumblebee                    -             3.2.1-18

:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                            libglvnd     0.1.1.20161028-1  0.2.999+g4ba53457-1
                               libva              1.7.3-1              1.7.3-2
                  libva-intel-driver              1.7.3-1              1.7.3-2
                   libva-mesa-driver             17.0.1-1             17.0.1-2
                                mesa             17.0.1-1             17.0.1-2
                          mesa-vdpau             17.0.1-1             17.0.1-2
                         opencl-mesa             17.0.1-1             17.0.1-2
                        vulkan-intel             17.0.1-1             17.0.1-2
                       vulkan-radeon             17.0.1-1             17.0.1-2

:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                      catalyst-utils      1:15.201.1151-5      1:15.201.1151-6
                  nvidia-304xx-utils          1:304.134-3          1:304.134-4
                  nvidia-340xx-utils            340.101-3            340.101-4
                        nvidia-utils           1:375.39-3           1:375.39-4
                           bumblebee                    -             3.2.1-18

:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                            libglvnd     0.1.1.20161028-1  0.2.999+g4ba53457-1
                               libva              1.7.3-1              1.7.3-2
                  libva-intel-driver              1.7.3-1              1.7.3-2
                   libva-mesa-driver             17.0.1-1             17.0.1-2
                                mesa             17.0.1-1             17.0.1-2
                          mesa-vdpau             17.0.1-1             17.0.1-2
                         opencl-mesa             17.0.1-1             17.0.1-2
                        vulkan-intel             17.0.1-1             17.0.1-2
                       vulkan-radeon             17.0.1-1             17.0.1-2

:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                lib32-catalyst-utils      1:15.201.1151-1      1:15.201.1151-2
                          lib32-mesa             17.0.1-1                    -
            lib32-nvidia-304xx-utils          1:304.134-1          1:304.134-2
            lib32-nvidia-340xx-utils            340.101-1            340.101-2
                  lib32-nvidia-utils           1:375.39-1           1:375.39-2


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                      lib32-libglvnd   0.1.1.20161028-1.1  0.2.999+g4ba53457-1
                      lib32-libgudev                230-2                231-1
                    lib32-mesa-vdpau             17.0.1-1             17.0.1-2
                          lib32-mesa                    -             17.0.1-2

#17

32bit multi-arch mesa stack is still broken

resolving dependencies…
warning: cannot resolve “lib32-opengl-driver”, a dependency of "lib32-libglvnd"
warning: cannot resolve “lib32-libgl”, a dependency of "lib32-glu"
warning: cannot resolve “lib32-glu”, a dependency of "lib32-glew"
warning: cannot resolve “lib32-glew”, a dependency of "lib32-mesa-demos"
warning: cannot resolve “lib32-opengl-driver”, a dependency of "lib32-libglvnd"
warning: cannot resolve “lib32-libgl”, a dependency of "lib32-glu"
warning: cannot resolve “lib32-opengl-driver”, a dependency of "lib32-libglvnd"
warning: cannot resolve “lib32-libgl”, a dependency of "lib32-glu"
warning: cannot resolve “lib32-glu”, a dependency of “lib32-glew”
:: The following packages cannot be upgraded due to unresolvable dependencies:
lib32-mesa-demos lib32-glu lib32-glew


#18

optirun glxinfo32 | grep OpenGL
call iGPU (intel) :

[fademind@manjaro ~]$ optirun glxinfo32 | grep OpenGL
ERROR: ld.so: object ‘libdlfaker.so’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object ‘libvglfaker.so’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel® Ivybridge Mobile x86/MMX/SSE2
OpenGL core profile version string: 3.3 (Core Profile) Mesa 17.0.1
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 17.0.1
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 17.0.1
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
[fademind@manjaro ~]$

Should be:

[fademind@manjaro ~]$ optirun glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 630M/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 375.39
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.5.0 NVIDIA 375.39
OpenGL shading language version string: 4.50 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
[fademind@manjaro ~]$

:scream:

@philm

NOTE: primusrun and optirun works as expected (64bit)

LISTINGS:

[fademind@manjaro ~]$ pacman -Ql nvidia-utils 
nvidia-utils /usr/
nvidia-utils /usr/bin/
nvidia-utils /usr/bin/nvidia-bug-report.sh
nvidia-utils /usr/bin/nvidia-cuda-mps-control
nvidia-utils /usr/bin/nvidia-cuda-mps-server
nvidia-utils /usr/bin/nvidia-debugdump
nvidia-utils /usr/bin/nvidia-modprobe
nvidia-utils /usr/bin/nvidia-persistenced
nvidia-utils /usr/bin/nvidia-settings
nvidia-utils /usr/bin/nvidia-smi
nvidia-utils /usr/bin/nvidia-xconfig
nvidia-utils /usr/lib/
nvidia-utils /usr/lib/libEGL_nvidia.so
nvidia-utils /usr/lib/libEGL_nvidia.so.0
nvidia-utils /usr/lib/libEGL_nvidia.so.375.39
nvidia-utils /usr/lib/libGLESv1_CM_nvidia.so
nvidia-utils /usr/lib/libGLESv1_CM_nvidia.so.1
nvidia-utils /usr/lib/libGLESv1_CM_nvidia.so.375.39
nvidia-utils /usr/lib/libGLESv2_nvidia.so
nvidia-utils /usr/lib/libGLESv2_nvidia.so.2
nvidia-utils /usr/lib/libGLESv2_nvidia.so.375.39
nvidia-utils /usr/lib/libGLX_indirect.so.0
nvidia-utils /usr/lib/libGLX_nvidia.so
nvidia-utils /usr/lib/libGLX_nvidia.so.0
nvidia-utils /usr/lib/libGLX_nvidia.so.375.39
nvidia-utils /usr/lib/libcuda.so
nvidia-utils /usr/lib/libcuda.so.1
nvidia-utils /usr/lib/libcuda.so.375.39
nvidia-utils /usr/lib/libnvcuvid.so
nvidia-utils /usr/lib/libnvcuvid.so.1
nvidia-utils /usr/lib/libnvcuvid.so.375.39
nvidia-utils /usr/lib/libnvidia-cfg.so
nvidia-utils /usr/lib/libnvidia-cfg.so.1
nvidia-utils /usr/lib/libnvidia-cfg.so.375.39
nvidia-utils /usr/lib/libnvidia-egl-wayland.so
nvidia-utils /usr/lib/libnvidia-egl-wayland.so.0
nvidia-utils /usr/lib/libnvidia-egl-wayland.so.375.39
nvidia-utils /usr/lib/libnvidia-eglcore.so
nvidia-utils /usr/lib/libnvidia-eglcore.so.375.39
nvidia-utils /usr/lib/libnvidia-encode.so
nvidia-utils /usr/lib/libnvidia-encode.so.1
nvidia-utils /usr/lib/libnvidia-encode.so.375.39
nvidia-utils /usr/lib/libnvidia-fatbinaryloader.so
nvidia-utils /usr/lib/libnvidia-fatbinaryloader.so.375.39
nvidia-utils /usr/lib/libnvidia-fbc.so
nvidia-utils /usr/lib/libnvidia-fbc.so.1
nvidia-utils /usr/lib/libnvidia-fbc.so.375.39
nvidia-utils /usr/lib/libnvidia-glcore.so
nvidia-utils /usr/lib/libnvidia-glcore.so.375.39
nvidia-utils /usr/lib/libnvidia-glsi.so
nvidia-utils /usr/lib/libnvidia-glsi.so.375.39
nvidia-utils /usr/lib/libnvidia-gtk2.so
nvidia-utils /usr/lib/libnvidia-gtk2.so.375.39
nvidia-utils /usr/lib/libnvidia-gtk3.so
nvidia-utils /usr/lib/libnvidia-gtk3.so.375.39
nvidia-utils /usr/lib/libnvidia-ifr.so
nvidia-utils /usr/lib/libnvidia-ifr.so.1
nvidia-utils /usr/lib/libnvidia-ifr.so.375.39
nvidia-utils /usr/lib/libnvidia-ml.so
nvidia-utils /usr/lib/libnvidia-ml.so.1
nvidia-utils /usr/lib/libnvidia-ml.so.375.39
nvidia-utils /usr/lib/libnvidia-ptxjitcompiler.so
nvidia-utils /usr/lib/libnvidia-ptxjitcompiler.so.375.39
nvidia-utils /usr/lib/libnvidia-tls.so
nvidia-utils /usr/lib/libnvidia-tls.so.375.39
nvidia-utils /usr/lib/nvidia/
nvidia-utils /usr/lib/nvidia/xorg/
nvidia-utils /usr/lib/nvidia/xorg/libglx.so
nvidia-utils /usr/lib/nvidia/xorg/libglx.so.1
nvidia-utils /usr/lib/nvidia/xorg/libglx.so.375.39
nvidia-utils /usr/lib/systemd/
nvidia-utils /usr/lib/systemd/system/
nvidia-utils /usr/lib/systemd/system/nvidia-persistenced.service
nvidia-utils /usr/lib/tls/
nvidia-utils /usr/lib/tls/libnvidia-tls.so
nvidia-utils /usr/lib/tls/libnvidia-tls.so.375.39
nvidia-utils /usr/lib/vdpau/
nvidia-utils /usr/lib/vdpau/libvdpau_nvidia.so
nvidia-utils /usr/lib/vdpau/libvdpau_nvidia.so.1
nvidia-utils /usr/lib/vdpau/libvdpau_nvidia.so.375.39
nvidia-utils /usr/lib/xorg/
nvidia-utils /usr/lib/xorg/modules/
nvidia-utils /usr/lib/xorg/modules/drivers/
nvidia-utils /usr/lib/xorg/modules/drivers/nvidia_drv.so
nvidia-utils /usr/share/
nvidia-utils /usr/share/X11/
nvidia-utils /usr/share/X11/xorg.conf.d/
nvidia-utils /usr/share/X11/xorg.conf.d/nvidia-drm-outputclass.conf
nvidia-utils /usr/share/applications/
nvidia-utils /usr/share/applications/nvidia-settings.desktop
nvidia-utils /usr/share/doc/
nvidia-utils /usr/share/doc/nvidia-utils
nvidia-utils /usr/share/doc/nvidia/
nvidia-utils /usr/share/doc/nvidia/NVIDIA_Changelog
nvidia-utils /usr/share/doc/nvidia/README
nvidia-utils /usr/share/doc/nvidia/html/
nvidia-utils /usr/share/doc/nvidia/html/acknowledgements.html
nvidia-utils /usr/share/doc/nvidia/html/addressingcapabilities.html
nvidia-utils /usr/share/doc/nvidia/html/addtlresources.html
nvidia-utils /usr/share/doc/nvidia/html/appendices.html
nvidia-utils /usr/share/doc/nvidia/html/audiosupport.html
nvidia-utils /usr/share/doc/nvidia/html/commonproblems.html
nvidia-utils /usr/share/doc/nvidia/html/configlaptop.html
nvidia-utils /usr/share/doc/nvidia/html/configmultxscreens.html
nvidia-utils /usr/share/doc/nvidia/html/configtwinview.html
nvidia-utils /usr/share/doc/nvidia/html/depth30.html
nvidia-utils /usr/share/doc/nvidia/html/displaydevicenames.html
nvidia-utils /usr/share/doc/nvidia/html/dma_issues.html
nvidia-utils /usr/share/doc/nvidia/html/dpi.html
nvidia-utils /usr/share/doc/nvidia/html/editxconfig.html
nvidia-utils /usr/share/doc/nvidia/html/faq.html
nvidia-utils /usr/share/doc/nvidia/html/flippingubb.html
nvidia-utils /usr/share/doc/nvidia/html/framelock.html
nvidia-utils /usr/share/doc/nvidia/html/glxsupport.html
nvidia-utils /usr/share/doc/nvidia/html/gpunames.html
nvidia-utils /usr/share/doc/nvidia/html/i2c.html
nvidia-utils /usr/share/doc/nvidia/html/index.html
nvidia-utils /usr/share/doc/nvidia/html/installationandconfiguration.html
nvidia-utils /usr/share/doc/nvidia/html/installdriver.html
nvidia-utils /usr/share/doc/nvidia/html/installedcomponents.html
nvidia-utils /usr/share/doc/nvidia/html/introduction.html
nvidia-utils /usr/share/doc/nvidia/html/kms.html
nvidia-utils /usr/share/doc/nvidia/html/knownissues.html
nvidia-utils /usr/share/doc/nvidia/html/minimumrequirements.html
nvidia-utils /usr/share/doc/nvidia/html/newusertips.html
nvidia-utils /usr/share/doc/nvidia/html/nvidia-debugdump.html
nvidia-utils /usr/share/doc/nvidia/html/nvidia-ml.html
nvidia-utils /usr/share/doc/nvidia/html/nvidia-persistenced.html
nvidia-utils /usr/share/doc/nvidia/html/nvidia-smi.html
nvidia-utils /usr/share/doc/nvidia/html/nvidiasettings.html
nvidia-utils /usr/share/doc/nvidia/html/openglenvvariables.html
nvidia-utils /usr/share/doc/nvidia/html/optimus.html
nvidia-utils /usr/share/doc/nvidia/html/powermanagement.html
nvidia-utils /usr/share/doc/nvidia/html/procinterface.html
nvidia-utils /usr/share/doc/nvidia/html/profiles.html
nvidia-utils /usr/share/doc/nvidia/html/programmingmodes.html
nvidia-utils /usr/share/doc/nvidia/html/randr14.html
nvidia-utils /usr/share/doc/nvidia/html/sdi.html
nvidia-utils /usr/share/doc/nvidia/html/selectdriver.html
nvidia-utils /usr/share/doc/nvidia/html/sli.html
nvidia-utils /usr/share/doc/nvidia/html/supportedchips.html
nvidia-utils /usr/share/doc/nvidia/html/vdpausupport.html
nvidia-utils /usr/share/doc/nvidia/html/xcompositeextension.html
nvidia-utils /usr/share/doc/nvidia/html/xconfigoptions.html
nvidia-utils /usr/share/doc/nvidia/html/xineramaglx.html
nvidia-utils /usr/share/doc/nvidia/html/xrandrextension.html
nvidia-utils /usr/share/glvnd/
nvidia-utils /usr/share/glvnd/egl_vendor.d/
nvidia-utils /usr/share/glvnd/egl_vendor.d/10_nvidia.json
nvidia-utils /usr/share/licenses/
nvidia-utils /usr/share/licenses/nvidia-utils
nvidia-utils /usr/share/licenses/nvidia/
nvidia-utils /usr/share/licenses/nvidia/LICENSE
nvidia-utils /usr/share/man/
nvidia-utils /usr/share/man/man1/
nvidia-utils /usr/share/man/man1/nvidia-cuda-mps-control.1.gz
nvidia-utils /usr/share/man/man1/nvidia-modprobe.1.gz
nvidia-utils /usr/share/man/man1/nvidia-persistenced.1.gz
nvidia-utils /usr/share/man/man1/nvidia-settings.1.gz
nvidia-utils /usr/share/man/man1/nvidia-smi.1.gz
nvidia-utils /usr/share/man/man1/nvidia-xconfig.1.gz
nvidia-utils /usr/share/nvidia/
nvidia-utils /usr/share/nvidia/nvidia-application-profiles-375.39-key-documentation
nvidia-utils /usr/share/nvidia/nvidia-application-profiles-375.39-rc
nvidia-utils /usr/share/pixmaps/
nvidia-utils /usr/share/pixmaps/nvidia-settings.png
nvidia-utils /usr/share/vulkan/
nvidia-utils /usr/share/vulkan/icd.d/
nvidia-utils /usr/share/vulkan/icd.d/nvidia_icd.json
[fademind@manjaro ~]$ pacman -Ql lib32-nvidia-utils 
lib32-nvidia-utils /usr/
lib32-nvidia-utils /usr/lib32/
lib32-nvidia-utils /usr/lib32/libEGL_nvidia.so
lib32-nvidia-utils /usr/lib32/libEGL_nvidia.so.0
lib32-nvidia-utils /usr/lib32/libEGL_nvidia.so.375.39
lib32-nvidia-utils /usr/lib32/libGLESv1_CM_nvidia.so
lib32-nvidia-utils /usr/lib32/libGLESv1_CM_nvidia.so.1
lib32-nvidia-utils /usr/lib32/libGLESv1_CM_nvidia.so.375.39
lib32-nvidia-utils /usr/lib32/libGLESv2_nvidia.so
lib32-nvidia-utils /usr/lib32/libGLESv2_nvidia.so.2
lib32-nvidia-utils /usr/lib32/libGLESv2_nvidia.so.375.39
lib32-nvidia-utils /usr/lib32/libGLX_indirect.so.0
lib32-nvidia-utils /usr/lib32/libGLX_nvidia.so
lib32-nvidia-utils /usr/lib32/libGLX_nvidia.so.0
lib32-nvidia-utils /usr/lib32/libGLX_nvidia.so.375.39
lib32-nvidia-utils /usr/lib32/libcuda.so
lib32-nvidia-utils /usr/lib32/libcuda.so.1
lib32-nvidia-utils /usr/lib32/libcuda.so.375.39
lib32-nvidia-utils /usr/lib32/libnvcuvid.so
lib32-nvidia-utils /usr/lib32/libnvcuvid.so.1
lib32-nvidia-utils /usr/lib32/libnvcuvid.so.375.39
lib32-nvidia-utils /usr/lib32/libnvidia-cfg.so
lib32-nvidia-utils /usr/lib32/libnvidia-cfg.so.1
lib32-nvidia-utils /usr/lib32/libnvidia-cfg.so.375.39
lib32-nvidia-utils /usr/lib32/libnvidia-egl-wayland.so
lib32-nvidia-utils /usr/lib32/libnvidia-egl-wayland.so.0
lib32-nvidia-utils /usr/lib32/libnvidia-egl-wayland.so.375.39
lib32-nvidia-utils /usr/lib32/libnvidia-eglcore.so
lib32-nvidia-utils /usr/lib32/libnvidia-eglcore.so.375.39
lib32-nvidia-utils /usr/lib32/libnvidia-encode.so
lib32-nvidia-utils /usr/lib32/libnvidia-encode.so.1
lib32-nvidia-utils /usr/lib32/libnvidia-encode.so.375.39
lib32-nvidia-utils /usr/lib32/libnvidia-fatbinaryloader.so
lib32-nvidia-utils /usr/lib32/libnvidia-fatbinaryloader.so.375.39
lib32-nvidia-utils /usr/lib32/libnvidia-fbc.so
lib32-nvidia-utils /usr/lib32/libnvidia-fbc.so.1
lib32-nvidia-utils /usr/lib32/libnvidia-fbc.so.375.39
lib32-nvidia-utils /usr/lib32/libnvidia-glcore.so
lib32-nvidia-utils /usr/lib32/libnvidia-glcore.so.375.39
lib32-nvidia-utils /usr/lib32/libnvidia-glsi.so
lib32-nvidia-utils /usr/lib32/libnvidia-glsi.so.375.39
lib32-nvidia-utils /usr/lib32/libnvidia-ifr.so
lib32-nvidia-utils /usr/lib32/libnvidia-ifr.so.1
lib32-nvidia-utils /usr/lib32/libnvidia-ifr.so.375.39
lib32-nvidia-utils /usr/lib32/libnvidia-ml.so
lib32-nvidia-utils /usr/lib32/libnvidia-ml.so.1
lib32-nvidia-utils /usr/lib32/libnvidia-ml.so.375.39
lib32-nvidia-utils /usr/lib32/libnvidia-ptxjitcompiler.so
lib32-nvidia-utils /usr/lib32/libnvidia-ptxjitcompiler.so.375.39
lib32-nvidia-utils /usr/lib32/libnvidia-tls.so
lib32-nvidia-utils /usr/lib32/libnvidia-tls.so.375.39
lib32-nvidia-utils /usr/lib32/libnvidia-wfb.so
lib32-nvidia-utils /usr/lib32/libnvidia-wfb.so.1
lib32-nvidia-utils /usr/lib32/libnvidia-wfb.so.375.39
lib32-nvidia-utils /usr/lib32/nvidia/
lib32-nvidia-utils /usr/lib32/nvidia/xorg/
lib32-nvidia-utils /usr/lib32/nvidia/xorg/modules/
lib32-nvidia-utils /usr/lib32/nvidia/xorg/modules/extensions/
lib32-nvidia-utils /usr/lib32/nvidia/xorg/modules/extensions/libglx.so
lib32-nvidia-utils /usr/lib32/nvidia/xorg/modules/extensions/libglx.so.375.39
lib32-nvidia-utils /usr/lib32/tls/
lib32-nvidia-utils /usr/lib32/tls/libnvidia-tls.so
lib32-nvidia-utils /usr/lib32/tls/libnvidia-tls.so.375.39
lib32-nvidia-utils /usr/lib32/vdpau/
lib32-nvidia-utils /usr/lib32/vdpau/libvdpau_nvidia.so
lib32-nvidia-utils /usr/lib32/vdpau/libvdpau_nvidia.so.1
lib32-nvidia-utils /usr/lib32/vdpau/libvdpau_nvidia.so.375.39
lib32-nvidia-utils /usr/share/
lib32-nvidia-utils /usr/share/licenses/
lib32-nvidia-utils /usr/share/licenses/lib32-nvidia-utils
[fademind@manjaro ~]$ 

#19

@Philm it worked. No biggie to re-install a few packages.


#20

@tux and @FadeMind: did you guys checked if the mirror was synced and updated to the latest packages? Also was a system reboot made yet after all packages got installed? Try mirror Netzspielplatz.