Xorg.conf.d monitor modeline conf not being recognized

I have a 144 Hz monitor. By default the 144 Hz option is only made available by the system when using a DisplayPort cable, but doing so comes with major issues I discussed and tried debugging in other threads. Until now I thought it’s a hardware limitation of HDMI, just yesterday however I found out you can in fact get 144 Hz even on the HDMI cable. After some help and digging and fiddling I managed to get it working perfectly and at the intended pixel clocks via xrandr commands:

xrandr --newmode "1920x1080_144"  325.08  1920 1944 1976 2056  1080 1083 1088 1098 +hsync +vsync
xrandr --addmode HDMI-A-0 1920x1080_144
xrandr --output HDMI-A-0 --mode 1920x1080_144

Though it should be an easy fix, I’d rather not automate those parameters in ~/.profile but do this in a more official way. On the other side I’d rather not mess with stuff like EDID information which looks far too complex and messy. So I settled for an Xorg rule as suggested by several articles. Only problem is, it doesn’t want to work for me and I’m not sure what I’m missing.

Section "Monitor"
    Identifier "HDMI"
    Modeline "1920x1080_144"  325.08  1920 1944 1976 2056  1080 1083 1088 1098 +hsync +vsync
    Option "PreferredMode" "1920x1080_144"

I added this to a new file called /etc/X11/xorg.conf.d/50-monitor.conf (highest number used). Unfortunately nothing happens after a restart: Not only is it not using 144 Hz by default as it would on DisplayPort, the 1920x1080_144 mode isn’t even listed by xrandr… I need to run commands manually to get it working again. What is my conf missing please?

Also I’m assuming this only works for an X11 session; Is there an equivalent to etc/X11/xorg.conf.d for Wayland? Or really just a better way to unlock 144 Hz on HDMI everywhere at the right specifications as the system should be doing on its own?

If i was you, i would enable early KMS for the AMD GPU, and probably passing amdgpu.audio=0 to the kernel
command line would clear enough bandwidth, so then you can set the modeline to 144Hz … The thing is, if you are on wayland session you can forget about xrandr and xorg configurations.

I might be wrong, but under X11 this command

should be

xrandr --newmode "1920x1080_144.00"  325.08  1920 1944 1976 2056  1080 1083 1088 1098 +hsync +vsync


xrandr --addmode HDMI-A-0 1920x1080_144.00

AFAIK only some programs have trouble recognizing modes labeled with “_X0.00” so i assume is actually a requirement by default …

For wayland see this

Added the .00 just in case. So wdisplays should be a Wayland alternative to X11’s xrandr… what’s the command to set a modeline with it please so I can note that down? But I’m also wondering about an alternative to the /etc/X11/xorg.conf.d directory so the modeline can be automatically applied system wide: What’s wrong with the one I posted, and how do you suggest either fixing that or using a better way to unlock 144 Hz at top level?

A little update: I used the e key during GRUB to edit the command line and add video=1920x1080@144 then booted with F10. Despite people saying this should work, the parameter appears to have been completely ignored.