Xmodmap corrompe il mio sistema operativo

Ciao a tutti. Ho esposto il mio problema in un altro topic e, su richiesta di un utente, lo sto riportando qui in italiano
Come layout utilizzo quello inglese internazionale, con le lettere morte impostate su altgr: praticamente uso il layout americano, e per scrivere gli accenti premo altgr+e per ottenere é, ad esempio. Dato che l'accento predefinito è quello acuto, e io uso quello grave molto più spesso, volevo modificare questo layout in modo che altgr+e restituisse è invece di é.
Ho usato questo tutorial, in particolare la sezione "Customize keyboard layout" per fare ciò che volevo. Praticamente, ho usato il comando nano .Xmodmap per modificare il layout, cambiando
keycode 26 = e E e E eacute Eacute eacute
in
keycode 26 = e E e E egrave Egrave egrave
Per applicare il layout, digito xmodmap .Xmodmap nel terminale. Dopo qualche secondo, il comando è eseguito e il PC rallenta abbastanza. La cosa più strana è che non posso più interagire con la barra in basso, e non posso cliccare sulle finestre: è come se il tasto alt fosse premuto, e quindi il click sinistro fa spostare le finestre, il destro le fa ridimensionare. L'unica soluzione a questo problema è riavviare il pc tramite il tasto fisico di accensione, per ripristinare il layout predefinito.
Sto sbagliando qualcosa? Esiste un modo diverso/più semplice per fare ciò che devo?
Grazie

Non ho davanti a me il computer desktop su cui ho impostato qualcosa di simile, senza usare nessun software aggiuntivo ma dal file di configurazione di Xorg in /etc.
Sul mio sistema se ricordo bene il "dead key" funziona come compositore di lettere accentate, premendo AltGr+E e poi ' ottengo un accento acuto, prementdo AltGr+E e poi ` ottengo un accento grave.

P.S. c'è un forum tutto italiano all'indirizzo manjaro-it.org

Ti dispiacerebbe aiutarmi a farlo? Non credo proprio di esserne in grado.
Grazie di avermi segnalato il forum in italiano

Ok, sono riuscito a connettermi al desktop da remoto (sono in un altro paese :sweat_smile: ), e ho trovato questo in /etc/X11/xorg.conf.d/00-keyboard.conf

# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "eu"
        Option "XkbModel" "pc104"
EndSection

Deduco di ricordare male, perché qui non vedo grandi personalizzazioni, quindi mi sa che ho usato le impostazioni di KDE, provando a guardare sul mio portatile penso che questa sia la procedura corretta (oppure "Unicode combining with AltGr", insomma una delle varianti dovrebbe andare):


(non posso verificare sul desktop perché non sto usando il server grafico da remoto ma solo la riga di comando)