.xlsx and .docx files are opened as zip file

On Plasma 5 I cannot open the .xlsx and .docx files with wps office. It opens Ark, the Kde archiver. If i open wps office then i can browse and open those files, but not with directly to them. I checked and these types are assigned to wps office.

I think that the problem is that these types are shown as zip files, but they are not zipped! What can be the problem?

6 Likes

It’s because wps office is not the default program.This happens in every distro.For example
Opening a .deb file in ubuntu without having the installer.
Just make it default.
By rightclicking and saying open with.

Of course it is the default program for those types, but when i right click the current files then it shows “application/zip” for xlsx and docx as well. That is why it is opened with ark not with wps.

Weird.Maybe it’s a problem while reading the extension

Try making a system upgrade or reinstalling office.

I think those types are in fact zips or something approximating azip.

If you are in KDE, Open Dolphin
right click one of those documents and select properties
then click the File Type Options button
Then in the Application Preference Order window select the program you want to handle that type, and use Move Up button till that program is at the top.

1 Like

I have tried it, only wps exist for those types.
I think the problem is that it is shown as zip, but it not a zip.

They are a zip - technically. Open them with arc and you will see.

  1. Explain what you mean by “shows as a zip”.
    Screen shots would be nice.
  2. Does the file name have an extension?
  3. Have you rebooted or logged out and in again since installing WPS office?
  4. have you installed LibreOffice from Manjaro repositories (to test with - even if you don’t want to use it)?

Where did you install WPS from? AUR?

Ok, one more: (Sorry, gotta ask)…
How sure of the source of those files are you? Did they come by email?

If you want to check the mimetype info files directly, look at /usr/share/applications/mimeinfo.cache and /home/[user]/.local/share/applications/mimeinfo.cache

The .xlsx and .docx files are among these mimetypes and this should show the applications that will open them (in order of preference):

application/vnd.openxmlformats-officedocument.presentationml.presentation=libreoffice.desktop;
application/vnd.openxmlformats-officedocument.presentationml.slideshow=libreoffice.desktop;
application/vnd.openxmlformats-officedocument.presentationml.template=libreoffice.desktop;
application/vnd.openxmlformats-officedocument.spreadsheetml.sheet=libreoffice.desktop;
application/vnd.openxmlformats-officedocument.spreadsheetml.template=libreoffice.desktop;
application/vnd.openxmlformats-officedocument.wordprocessingml.document=libreoffice.desktop;
application/vnd.openxmlformats-officedocument.wordprocessingml.template=libreoffice.desktop;

I checked these and seems ok. Tried with a new user as well and was the same.

You can see that this happened before.
https://github.com/thoughtbot/paperclip/issues/1530

Seems someting like these but I cannot see the solution. The “file” package has been updated not long ago, maybe it changed the behavior?

This is a pain in the but. Sometimes it happens and it isn’t always easy to solve. Right-click the file, go to properties > file type options. There you can see a list of extensions on the top and a list of applications at the bottom. Set those accordingly (you can also edit the description). Then do the same for zip files. Don’t exclude Ark from opening office files but put it bellow wps or whatever apps you want first.

If you use an independent file manager (like pcmanfm or sunflower) this won’t happen.

Cheers,

Some of the config was messed up somehow, because when I use the backup settings, it is working. I do not know which one, or how, but the backup is working :slight_smile:
It is good to have a backup from the settings :slight_smile:

Thanks for help!

1 Like

it is wrong again with the update from unstable :frowning:

1 Like

I am having the same issue. I think it is somehow related to WPS Office because it doesn’t effect one of my computers that doesn’t have WPS installed. No matter what I change in the file association box in dolphin nothing happens. XDG-Open sees them as zip files too and I can’t figure out how to change that.

Thanks to confirming it, I will link this page to the stable update thread.

I have had 2 updtes of WPS since yesterday but the issue persists.

While not ideal, uninstalling WPS office fixes it.

Hi, same problem here. Contents are recognized as Zip archive

And when I double click the file, it tries to open it with WPS Spreadsheet.

Any solution for this annoying issue?

this doesn’t answer the original query but all msoffice documents .docx .pptx .xlsx (and macro files .docm .xlsm) can each be renamed as .zip (or .gz) and opened as an archive file because they share the same structure. you can then view the file contents as a zip file without opening msoffice.

just fyi - same for epub files … they are a zipped html tree

I came across the issue after saving a .docx file with WPS Office. It was surprising to see the zip icon. However as mentioned in an above post right click and ‘Open with’ does indeed open the file in WPS office.

Could it be an issue with the AUR package?

Forum kindly sponsored by