Xgamma -gamma 0.8 NOT working

xgamma is not setting gamma


xgamma -gamma 0.8 


-> Red  1.000, Green  1.000, Blue  1.000
<- Red  1.000, Green  1.000, Blue  1.000

I’ve tried with sudo and also tried setting individual gamma values with

sudo xgamma -rgamma 0.8 -bgamma 0.8 -ggamma 0.8

but it doesn’t work and gives the same output as above.

Also tried with xrandr but to no avail. This is what I did

xrandr --output XWAYLAND0 --gamma 0.8:0.8:0.8

There is no output in xrandr’s case, but I can’t see any visible difference in contrast

Are you on wayland session? Run from terminal:

It outputted “wayland”

Well, none of the x tools like xgamma and xrandr will work on wayland … Need to use their wayland alternatives, or switch to X11 (Xorg) session.

Thank you. I’ll try to do that

May I ask which are the available alternatives? This is the only motive that still avoid me to change to Wayland. :sweat_smile:

Thank you very much!!

If you have external monitor you probably can use ddcutil – that work with X11 and Wayland :wink:

I tried using gammastep but it gave me an error.


gammastep -v -g 0.7:0.7:0.7 -m wayland


Notice: Solar elevations: > 3.0 (Day), < -6.0 (Night)
Notice: Temperatures: 6500K (Day), 4500K (Night)
Notice: Brightness: 1.00:1.00
Notice: Gamma (Day): 0.700, 0.700, 0.700
Notice: Gamma (Night): 0.700, 0.700, 0.700
Error: Could not control gamma, exiting.
Error: Failed to start adjustment method: wayland

I tried selecting GNOME on XORG at the login screen, but then I wasn’t able to login

As authors described, gammastep not work in Wayland.

I’m on a laptop. I tried ddcutil but it didn’t work :frowning:

You can ask, but i can’t answer :rofl: as i never tested them
xrandr alternative AUR (en) - wdisplays-git

xgamma alternative Arch Linux - gammastep 2.0.7-1 (x86_64) documentation at Chinstrap / gammastep · GitLab

or probably AUR (en) - wlsunset that uses this somehow http://aur.archlinux.org/packages/wlr-gamma-service-git

So, quite not sure. Each wayland test i do ends in less than 2 minutes.

1 Like

Thank you!!!

I’ll try it sometime in the near future… :rofl: :rofl:

1 Like

Issue fixed by changing to X11 session by editing the file /etc/gdm/custom.conf

Uncommented the following line to switch to X11 session

# WaylandEnable=false

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.