xfce4-notifyd does not start on boot

Electron apps freeze when trying to create a notification, realized that notifyd wasn't running to begin with. I started it manually with systemctl --user start xfce4-notifyd which fixes my problem. Whenever I run systemctl --user enable xfce4-notifyd I get this:

The unit files have no installation config (WantedBy=, RequiredBy=, Also=,
Alias= settings in the [Install] section, and DefaultInstance= for template
units). This means they are not meant to be enabled using systemctl.
Possible reasons for having this kind of units are:
• A unit may be statically enabled by being symlinked from another unit's
.wants/ or .requires/ directory.
• A unit's purpose may be to act as a helper for some other unit which has
a requirement dependency on it.
• A unit may be started when needed via activation (socket, path, timer,
D-Bus, udev, scripted systemctl call, ...).
• In case of template units, the unit is meant to be enabled with some
instance name specified.

Any suggestions as to how I can get notifyd to run on boot without having to manually start it every time? I've tried the first solution presented here: https://bbs.archlinux.org/viewtopic.php?id=202812 to no avail.

Downgrade xfce4-notifyd, see here.

This has been occurring even before the update from a couple days ago, but I'll give it a shot anyway and see if it helps.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark