Xfce4-hotcorner-plugin installing, but cmake can't find them

I’m trying to install xfce4-hotcorner-plugin from aur
show error

-- The C compiler identification is GNU 11.1.0
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /usr/bin/cc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
-- Found PkgConfig: /usr/bin/pkg-config (found version "1.7.3") 
-- Found Gettext: /usr/bin/msgmerge (found version "0.21") 
-- Checking for modules 'libxfce4panel-1.0;libxfce4ui-1;libwnck-3.0'
--   Package 'libxfce4panel-1.0', required by 'virtual:world', not found
--   Package 'libxfce4ui-1', required by 'virtual:world', not found
CMake Error at /usr/share/cmake-3.21/Modules/FindPkgConfig.cmake:554 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake-3.21/Modules/FindPkgConfig.cmake:776 (_pkg_check_modules_internal)
  CMakeLists.txt:11 (PKG_CHECK_MODULES)

-- Configuring incomplete, errors occurred!
See also "/var/tmp/pamac-build-$HOME/xfce4-hotcorner-plugin/src/xfce4-hotcorner-plugin-0.0.2/CMakeFiles/CMakeOutput.log".
==> ERROR: A failure occurred in build().

Can you help me fix this issue?
Thanks in advance!

I can only tell you that this was last updated 6 years ago.
Won’t work anymore, too much in xfce has changed since.

1 Like

Is there another way for enable hotcorner(cammand line)?

Not that I know of.
You can replace the window manager (xfwm4) with compiz - and then configure that feature there.

I always accidentally hit the hot corner and it irritates me.
So I just use ALT+TAB to bring up the expose and/or to switch between active windows.

1 Like