Xfce4-gtk3

xfce4-gtk3

#42

xfce4-goodies-gtk3 it is. I’ve fixed it now in git to xfce4-gtk3-goodies


#43

and next bug that i discover. i can`t run thunar with root. i use gksudo and pkexec and the same error:

https://bugzilla.xfce.org/show_bug.cgi?id=13884

if someone know how to fix this i will be glad to share


#44

Why gksudo? Doesn’t sudo do the job?
sudo thunar


#45

gksudo should be used for launching gtk graphical apps, sudo for cli commands.


#46

In Arch it doesn’t matter: https://askubuntu.com/questions/673022/which-are-the-advantages-of-sudo-defaulting-to-keep-home On my Arch machine I get

$ sudo bash -c 'echo $HOME'
/root

Check it out on Manjaro (I’m too lazy to start my laptop). :slight_smile:


#47

I am having the same issue.


#48

For me it´s true, it doesn´t matter sudo or whatever the hell you use but with sudo in my end that happens too(using the xfce-gtk3 that comes from the repos). And why are there xfce-gtk3-goodies and xfce-goodies-gtk3 (or something like that) in the groups?


#49

Try this:
gksu dbus-launch thunar
working for me.


#50

Yeah it works, thanks btw.


#51

Works for me also. Thanks Oberon.


#52

Is it eventually missing dbus-x11 ? In standard xfce I always use it.


#53

I’ve found another weird bug, test this if you can reproduce this in your end(this is for the battery icon in the panel). if you right click it (open it,this should be a bug too as you can’t open it with left click) and near the brightness bar you hold the left mouse click, the circle will move 1 pixel every second i think, instead of skipping big parts of the bar. And this depends on the position of the mouse cursor like if you put the circle in the middle and then reproduce the issue but behind the circle and it will instead of it start moving right, it will start moving left until you reach the end.


#54

yes it also fix this issue :wink: even better i dont need correct “thunar root” shortcut entry in desktop right mouse click

yes i can confirm. left click do nothing. only with right click we can go to settings

i dont have this issue


#55

…and change and store settings in thunar root.


#56

also confirm but philm write that he fixed it ?


#57

I don’t know if i should post here but i have an issue with xfce-gtk3 which is that it forces some icons to be from vertex-maia and enable RGB in the screen which i don’t like because it messes with my fonts, the first one is from normal xfce and the second one from the gtk3 version, you can notice in the top right corner the problem of RGB and the non-uniformity in icons, i notice them a lot when i open the dialog for adding applets which has every single icon changed to vertex maia.



#58

Will it be added? xfce-pulseaudio-plugin ?


#59

An older version is already in (Arch) repos, the package is flagged out of date for over a month now: https://www.archlinux.org/packages/extra/x86_64/xfce4-pulseaudio-plugin/


#60

Just updated to v0.3.1.r8.gabdc05a on the unstable branch.
You can install the latest version directly with

sudo pacman -U https://www.uex.dk/repos/manjaro/pool/overlay/xfce4-pulseaudio-plugin-0.3.1.r8.gabdc05a-1-x86_64.pkg.tar.xz

#61

can xfce-gtk3 handle hidpi ?