Xfce4-gtk3

yes,I described it to xfce github but in short brief:

  • when i change icon theme icons did not change only on one tab xfce-session-logout (power off, reboot, sleep, hibernate)
  • with xfwm4 enable (setting/windows manager tweak/compositor/enable display compositor) i have strange menu blinking/disappearance like on screen`s

https://postimg.org/image/gtjdfq7vp/
https://postimg.org/image/aie5zb6n9/

after i disable xfwm4 windows manager in settings xfce looks ugly but it works - blinking menu stops appear so I start looking another wm and I discovered that when i replace xfwm4 wm to other (i install metacity) my bugs were gone and I did not notice others i use suspend, hibernate, screen lock, vpn, custom theme and everyday normal use so for me it`s quite stable now

https://postimg.org/image/7qvqd15c5/

Thank you.

I was experiencing that, too, until I removed video-intel driver. Running with modesetting now, the issue has disappeared.

1 Like

Could you please share links to your bug reports? I would love to follow-up on those.

of course
menu blinking:
https://bugzilla.xfce.org/show_bug.cgi?id=13872
icons not change:
https://bugzilla.xfce.org/show_bug.cgi?id=13875

ps: i have intel graphics card too

I too quickly praised that everything works xD
so there is the problem with “XFCE notifications service” is not runing with system start-up

cat /usr/lib/systemd/user/xfce4-notifyd.service

[Unit]
Description=XFCE notifications service
[Service]
Type=dbus
BusName=org.freedesktop.Notifications
ExecStart=/usr/lib/xfce4/notifyd/xfce4-notifyd

so… /usr/lib/xfce4/notifyd/xfce4-notifyd show me this error

error while loading shared libraries: libxfconf-0.so.2: cannot open shared object file: No such file or directory

it is related with the same bug https://github.com/manjaro/packages-extra/issues/111 ??? you wrote then that you update xfce4-session, xfce4-settings, xfce4-power-manager, panel, thunar, xfdesktop but you probably forgot about xfce4-notifyd

Installing the right package xfce4-notifyd-gtk3 might help here.

omg xD my mistake you have right!

but after i switch to manajro unstable and install

sudo pacman -S xfce4-gtk3 xfce4-gtk3-goodies

package xfce4-notifyd-gtk3 did not update like other package :confused: some xfce4 group problem?

xfce4-goodies-gtk3 it is. I’ve fixed it now in git to xfce4-gtk3-goodies

and next bug that i discover. i can`t run thunar with root. i use gksudo and pkexec and the same error:

https://bugzilla.xfce.org/show_bug.cgi?id=13884

if someone know how to fix this i will be glad to share

Why gksudo? Doesn’t sudo do the job?
sudo thunar

gksudo should be used for launching gtk graphical apps, sudo for cli commands.

In Arch it doesn’t matter: https://askubuntu.com/questions/673022/which-are-the-advantages-of-sudo-defaulting-to-keep-home On my Arch machine I get

$ sudo bash -c 'echo $HOME'
/root

Check it out on Manjaro (I’m too lazy to start my laptop). :slight_smile:

I am having the same issue.

For me it´s true, it doesn´t matter sudo or whatever the hell you use but with sudo in my end that happens too(using the xfce-gtk3 that comes from the repos). And why are there xfce-gtk3-goodies and xfce-goodies-gtk3 (or something like that) in the groups?

1 Like

Try this:
gksu dbus-launch thunar
working for me.

4 Likes

Yeah it works, thanks btw.

Works for me also. Thanks Oberon.

Is it eventually missing dbus-x11 ? In standard xfce I always use it.

I’ve found another weird bug, test this if you can reproduce this in your end(this is for the battery icon in the panel). if you right click it (open it,this should be a bug too as you can’t open it with left click) and near the brightness bar you hold the left mouse click, the circle will move 1 pixel every second i think, instead of skipping big parts of the bar. And this depends on the position of the mouse cursor like if you put the circle in the middle and then reproduce the issue but behind the circle and it will instead of it start moving right, it will start moving left until you reach the end.

yes it also fix this issue :wink: even better i dont need correct “thunar root” shortcut entry in desktop right mouse click

yes i can confirm. left click do nothing. only with right click we can go to settings

i dont have this issue

Forum kindly sponsored by Bytemark