Xfce: show folder content as menu

(Windows users would call it the “start menu”. What is the correct term for manjaro/xfce/linux users? )

Is there a way to include folder content as a sub menu item in the xfce “start menu”? One example of such folder would be the documents folder. Another example is the ~/myscripts folder. Instead of open the folder content in a filemanager, show each file in the folder as a submenu item.

The “start menu” used in Xfce is called the Whisker menu. :slight_smile:

Regarding your question: Whisker menu doesn’t have this functionality. But there are further plugins for the Xfce panel which do have it.

There is the Directory Menu plugin where you can pick a folder and it shows its contents in a dropdown menu.

Then there is the Places plugin (available from the AUR as xfce4-places-plugin) which shows a menu with bookmarks, removable media etc (what you see in your file manager’s sidebar).


Interesting. Then I learned that the whisker menu is a panel plugin as well.

Is there a way to assign a hotkey to open the directory menu or places menu? And a way to customize which places Places show?

For the directory menu plugin use this command for the keyboard shortcut:


For the places plugin the command to use is:


Most of the displayed menu items are pre-defined as explained here:
Except for the GTK Bookmarks, which can be defined by the user (in ~/.gtk-bookmarks).


Or you can drag them with your mouse into the bookmarks sidebar in Thunar. :slight_smile:


Thanks. The directory plugin looks promising.
But the command xfce4-popup-directorymenu doesn’t do anything - nothing when assigned to a hotkey, nothing when run from whisker menu, nothing when run from terminal

This command only works after adding a directory menu item in your panel.

It is added. It works using touchpad

If I run it as root in terminal, I get "failed to send D-bus message

Du you use several panels? It works for me (without root access).

I’m using quite default manjaro installation. Haven’t done anythnig to panel setting until I started this thread. During this thread I’ve installed xfce4-places-plugin. (Directory was installed by default). Then I added one of each of these to the panel and moved them both next to the whisker menu.

I removed the directory panel item, uninstalled the directory plugin and installed it again. Now the command works from terminal, but not with hotkey… Neither xfce4-popup-directorymenu or /usr/bin/xfce4-popup-directorymenu does anything when assigned to a hotkey.
And then, after being assigned to the hotkey, it no longer works from the terminal!

So, there is no need to uninstall the plugin. If I just remove the directory item from panel, the add it, the xfce4-popup-directorymenu command works from terminal (as the logged in user). Exit code = 0
Then I run xfce4-popup-directorymenu from whisker menu, and it works.
Run from terminal again, it still works. Exit code = 0
Then assign xfce4-popup-directorymenu to hotkey ctrl+alt+z.
When pressing the hotkey, nothing happens.
Now running in terminal, nothing happens. Exit code = 1

more information:
after pressing the hotkey, and the menu not popping up. I’ll have to click on it twice with the mouse to make it pop up. Once that is done, it will again respond to the command from terminal.
It is repeatable:
Press the hotkey, nothing happens
Run xfce4-popup-directorymenu command in terminal, nothing happens
Click on the panel twice with the mouse (not one double click)
close the menu
Run xfce4-popup-directorymenu command in terminal, menu pops up.

Is this a bug with the plugin?

I just realized that directories does not list files, just directories. Guess I’ll should be looking for something else.

I can reproduce the behaviour you’re describing.
Seems to be similar to what is mentioned in this bug report for xfce4-panel:

Possibly similar behaviour is described in these Xfce Forum threads:

If you are fine with using a dock, Cairo Dock has this functionality, but not in a recursive way, it shows all folders and files in a given folder, but if you click a subfolder, it will open the file manager.

Yes, that’s the same bug. Except that it’s another plugin. In one of the forum posts a guy say it’s an issue with all plugins, except for the whisker menu.

I guess I’ll revert to a hotkey that opens a folder in filemanager as a temporary solution. Combined with a launcher script that switches to the same window (rather than starting a new instance) if the window is already open, should serve the same purpose, I guess.

(I don’t like dock)