(XFCE-) Panels gone after update [Solved]

Hi!
Yesterday I had 149 (or was it only 147?) updates and I finished them all. I think there was a few XFCE-stuff among those. All updates finished fine except xfce4-panel-compiz, which didn't want to compile since it complained that /usr/include/dbus/dbus-glib.h was missing. Since I'm a beginner and I found the file at /usr/include/dbus-1.0/dbus/, I just created a link so the file could be found and after that the compilation and installation went through.

Today, when I start up my computer and log in (done it multiple times), there is no panel. I had a top panel with the clock, menu, internet connection status, bluetooth status, logout button and the other usual stuff, and I had a bottom panel with some custom stuff, for instance icons to open certain files and programs, but both of those panels are now gone, and instead there is an empty one that's ”floating” on my desktop. If I add stuff to it, log out and log in, it's empty again.
So it seems like the panel is running, but all my settings are gone and new settings are forgotten as soon as I log out, including all the default settings that there when I first installed Manjaro.

I'm not sure how to proceed from this point. I was thinking of uninstalling xfce4-panel-compiz, but when I tried to , Pamac also wanted to uninstall quite a few other things, so I didn't. Looks like that could cause new problems.

I saw that other's seem to have problems with XFCE4-stuff as well after a recent update, but not exactly like this, as far as I understand.

Where are all my settings stored for the panels? Just thinking that if some settings file was removed during update, I could probably put it back from a backup. I'm not sure that would help though, since nothing that I do with that floating panel I have now seems to be remembered over sessions. It seems like it fails to load properly and puts an empty panel on my desktop just to be able to start at all, or something.

How do I start the panel from a terminal? I tried this, I don't know if it makes any sense:

$ xfce4-panel --quit 
                                                                                                                       
(xfce4-panel:6663): xfce4-panel-CRITICAL **: 16:14:03.661: panel-application.c:1250 (panel_application_save): expression 'XFCONF_IS_CHANNEL (channel)' failed.
$ 
[1]  + done       xfce4-panel
$ xfce4-panel       
xfce4-panel-Message: 16:15:02.357: Not a valid position defined: (null)

Instead of uninstalling it, try to install xfce4-panel. It will replace xfce4-panel-compiz.

1 Like

Thanks, the problem is solved now.
After installing xfce4-panel (which replaced xfce4-panel-compiz), I had no panel at all, xfce4-panel wasn't even loaded in the first place. I loaded it manually and I created a panel and added some applications and stuff in it. After logging out and in, my new panel was loaded properly. Very good. But I want my old ones, the ones I had before this went wrong in the first place.

So I did some searching and found that the settings are stored in ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml, so I restored it from one of my daily backups. However, after logging out and back in again, I still only had my new panel, not the ones I restored from my backup, so I shut down my computer completely and started it up again from scratch. Now my old panels were back, and everything is fine.

Maybe just restarting my computer directly after installing xfce4-panel would have done the trick too, I can't test that at this point.

Thanks for your help. One single sentence some times helps a lot.
What I didn't realise from start was that xfce4-panel-compiz is a replacement for xfce4-panel. I thought both were installed (I didn't even bother to check) and that the compiz version was some kind of ”add-on” or something.

1 Like

Compiz version is compatible with compiz. If you use compiz and your panel doesn't play well with the default panel package, then you can give the compiz version another try.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by