XFCE Panel Status Tray Menu Location

Is there a way to set a default location for where the menu appears when you click an application in the system tray?

What I would like to do, is raise it about 20 pixels. It’s annoying me, for example, that if I click on steam, the menu appears with “exit steam” where the mouse is. I accidentally exit my apps all the time because of this.

I’ve noticed more integrated/default apps like the wifi driver/clipman already have the menu raised, with the first option starting above the mouse. But other apps like discord and steam are anchored to the bottom of the monitor.

Can you illustrate with a screenshot?

1 Like

There are two images here, one is the wifi with the menu raised, the other is discord where the menu gets anchored to the bottom. I’m trying to get all of them raised off the bottom of the screen.

Sorry having issues with the image posting, it won’t let me embed images and complained about posting links, possibly a security issue since I created my account today?


AFAIK the tray menu position is normalized, so there isn’t a user configuration for that. Rather, it would be dependent on the theme.
Do you have the same issue with other themes?

Yes I have the same issue with other themes :frowning:.

Luckily it’s not a big deal, but I don’t remember it happening until recently.
I tried installing KDE a while ago, is it possible a KDE might have have modified something that effects XFCE somehow?

Alright, i managed to reproduce your issue by checking Don’t reserve space on borders in the panel preferences. So unchecking it should solve.

1 Like

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.