XFCE panel issues after 2018-12-02 Update

update
xfce
#1

I had an unexpected reboot during the last update (which I was doing in the desktop environment and not a TTY, I didn’t knew about that before). After rebooting the system and continued the update, I noticed that there was a problem with the XFCE panel: some icons had reverted to another theme, and there was no way to change them back.

Suspecting it was because of the reboot, I opted for a full reinstall with pacman -Qnq | pacman -S - This solved the issue with the theme, but since then I noticed more issues:

  • The launcher icons are wider with a two rows panel:



  • When I minimize/maximize windows, the panels appear to be killed and restarted. If I do it too fast or too many times (I’m not sure which option) the panels stay dead.

I tried another full system reinstall from a TTY, but the problems persist.

After looking a bit more in depth in the update I’m not sure if the problem was caused by the reboot or by the update to XFCE itself. I’m considering just formatting the system (I had just formatted it a few weeks ago), but if it’s an issue with XFCE I fear it may reappear.

My system is:

System:    Host: Host Kernel: 4.19.6-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.13.2git-UNKNOWN Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 20236 v: Lenovo G500 serial: <filter> 
           Mobo: LENOVO model: INVALID v: 31900003WIN8 STD MLT serial: <filter> UEFI: LENOVO v: 78CN23WW(V2.01) 
           date: 09/10/2013 
Battery:   ID-1: BAT1 charge: 44.5 Wh condition: 44.5/40.4 Wh (110%) 
CPU:       Topology: Quad Core model: Intel Core i7-3612QM bits: 64 type: MT MCP L2 cache: 6144 KiB 
           Speed: 1197 MHz min/max: 1200/3100 MHz Core speeds (MHz): 1: 1197 2: 1197 3: 1197 4: 1198 5: 1197 6: 1214 7: 1197 
           8: 1199 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel 
           Device-2: Advanced Micro Devices [AMD/ATI] Sun PRO [Radeon HD 8570A/8570M] driver: radeon v: kernel 
           Display: x11 server: X.Org 1.20.3 driver: ati,intel,radeon unloaded: modesetting resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.2.6 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k4.19.6-1-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA8172 Fast Ethernet driver: alx 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k 
           IF: wlp3s0 state: up mac: <filter> 
           Device-3: Qualcomm Atheros AR3012 Bluetooth 4.0 type: USB driver: btusb 
Drives:    Local Storage: total: 465.76 GiB used: 357.79 GiB (76.8%) 
           ID-1: /dev/sda vendor: Western Digital model: WD5000LPVT-24G33T1 size: 465.76 GiB 
Partition: ID-1: / size: 48.97 GiB used: 19.49 GiB (39.8%) fs: ext4 dev: /dev/sda6 
           ID-2: swap-1 size: 8.00 GiB used: 1.3 MiB (0.0%) fs: swap dev: /dev/sda7 
Sensors:   System Temperatures: cpu: 39.0 C mobo: N/A gpu: radeon temp: 38 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 251 Uptime: 41m Memory: 7.69 GiB used: 1.97 GiB (25.6%) Shell: bash inxi: 3.0.27 

EDIT: I have found this post with a similar issue. The command as stated there doesn’t work for me, but I’m looking for a way to try that downgrade.

0 Likes

#2

Have you installed the package downgrade ?

sudo pacman -S downgrade

0 Likes

#3

Yep, but I’ve encountered issues with not being able to use ALA:

# DOWNGRADE_FROM_ALA=1 downgrade xfce4-panel-gtk3

Downgrading from A.L.A. is disabled on the stable branch. To override this behavior, set DOWNGRADE_FROM_ALA to 1 .
See https://wiki.manjaro.org/index.php?title=Using_Downgrade  for more details.

loading packages...
warning: xfce4-panel-gtk3-4.13.3-14 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) xfce4-panel-gtk3-4.13.3-14

Total Installed Size:  3,86 MiB
Net Upgrade Size:      0,00 MiB

:: Proceed with installation? [Y/n] Y
(1/1) checking keys in keyring                     [######################] 100%
(1/1) checking package integrity                   [######################] 100%
(1/1) loading package files                        [######################] 100%
(1/1) checking for file conflicts                  [######################] 100%
(1/1) checking available disk space                [######################] 100%
:: Processing package changes...
(1/1) reinstalling xfce4-panel-gtk3                [######################] 100%
:: Running post-transaction hooks...
(1/3) Updating icon theme caches...
(2/3) Arming ConditionNeedsUpdate...
(3/3) Updating the desktop file MIME type cache...
add xfce4-panel-gtk3 to IgnorePkg? [y/n] n
0 Likes

#4

I also got the same warning, but I had xfce4-panel-gtk3-4.13.3-11 in my cache, and appeared as option 2, which I selected. Maybe you need to get hold of xfce4-panel-gtk3-4.13.3-11 and install it, but you will need to ask someone more experienced to help with that. Good luck with it.

0 Likes

#5

Maybe try this, swich to testing, downgrade just the one package and switch back to stable.
Obviously, there are risks to breaking your install by doing so… have a backup or plan B. !!

0 Likes

#6

Try

sudo pacman -U xfce4-panel-gtk3-4.13.3-11-x86_64.pkg.tar.xz

0 Likes

#7

Yepp, same issue here. There was just an update to xfce4-panel-gtk3 4.13.3-15 in the testing branch. Seems that one fixes the issue.

1 Like

#8

Sorry for the mess. xfce4-panel-gtk3 4.13.3-15 should fix the issue. Now also pushed to stable branch.

2 Likes

#9

Does that package need to be in the cache for that to work ?

0 Likes

#10

Thanks moson and philm, got it sorted now.

0 Likes

#11

Thanks, this solves the issue with the panels crashing :smiley:

However, the launcher icons occupying extra space when there are extra rows in the panel persists.

Should I open another post to discuss/report that? I thought at first it was only me because of the reboot, but I’m starting to think it may be another bug (haven’t been able to find a way to downgrade it yet).

Furthermore, if this is helpful, I’ve just realized that it gets worse the more rows there are in the panel:


0 Likes

#12

Sounds weird, but you can fix that by going to the launcher properties and toggle the “Show label instead of icon” switch (turn on and off again).

Afterwards the specific launcher should occupy less space. You’d have to do that with all your launchers though.

0 Likes

#13

I did that before the xfce4-panel-gtk3 4.13.3-15 update, but they ended up reverting to the size.

The ones from the example picture were created after the update just to test it. I will still give it a try, I’ll edit this if they revert or stay after a while.

EDIT: They reverted to occupy extra space after a shutdown. :frowning:

0 Likes

#14

Sorry for the dumb question - but how can I upgrade to this version?
I have exactly the described problem (panel restart and crashes) with the installed version xfce4-panel-gtk3 4.13.3.14 and wanted to upgrade to xfce4-panel-gtk3 4.13.3-15 but with sudo pacman -Sy xfce4-panel-gtk3 I am told everything is up to date.

Do I have to change the installation source? Where should I read to learn these basics?
Thanks.

0 Likes

#15

sudo pacman -U https://manjaro.moson.eu/pool/overlay/xfce4-panel-gtk3-4.13.3-15-x86_64.pkg.tar.xz

0 Likes

#16

Thank you very much - I didn’t know about the pool/overlay (amongst many other things).

EDIT: cool, meanwhile this package is also available as an update via pamac

0 Likes

closed #17

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes