[XFCE] Machine not charging

Hey everybody,
I'm using Manjaro 18.04 on a Thinkpad T480s (with an i5-8250U) and the 4.19.36-1 kernel.

After running pacman -Syuthis morning (and updating quite a few packages) my machine does not charge anymore. Visual signs are: little LED next to the USB-C charging slot is not lit, XFCE desktop notifications are 'flickering' between 'Your battery is charging' and 'Your battery is discharging' and so is the little battery symbol in the taskbar.
I am running a dual boot with Windows 10 and there the same problem persists. The laptop also does not charge when turned off.

Here are the relevant entries from pacman.log

pacman.log

Maybe somebody can guess what's going on
Best
Bob

That's got nothing to with the OS. Looks like you might have a hardware failure.

normally yes. but not sure about this since it only happened after updating

I had a similar issue occur with my old 2009 laptop. I would like to assume that it could be an issue with either the battery or the power-pack / cable.
look into

  • The power cable
  • The laptop port
    It could also be that the port may have debris buildup, see if you can dust that out or clean it if it is noticeably
    dirty.

will do, but pretty sure that's not the issue since the issue is with both usb-c ports, with both a dell docking station and the original power cord and the computer is only 1+ years old.
thanks for the tip anyways!

Maybe packages related to charge-over-usb were updated / not included in the new batch of updates passed along. I would not be entirely sure which group that would belong to however.

Yeah if the laptop is only 1 or so years old it should not really be having this issue this soon.
Maybe search around for different packages for charging over USB C specifically? (I have not really looked to see if those exist because I do not have USB C ports)

Good luck on your process, maybe other users have had this problem before on the forum,
look under hardware related questions.

good tip, will search for this stuff and get back here if i find anything!

tl;dr: If you encounter the same problem, unplug your machine and use the little hard-reset button on your device's back. Boot back up and plug in the cable - did the trick for me.

Alright, tried a few things like reverting packages, reverting the kernel, booting to windows and install 'Lenovo Vantage' (don't do the last one - this is really bloated). There is quite a lot of recommendations floating around in forums. In the end the little reset button on the backside did the trick. Idk what the problem was, but it's solved.

Thanks everybody for helping out!