Xfce login wallpaper


Does anyone know how to make the xfce login wallpaper auto change to whatever is currently the wallpaper being shown by variety?

In EndeavourOS, the xfce login wallpaper auto-changes to the same as the variety wallpaper.

Does anyone know how this can be achieved or how EndeavourOS manages it from outset?


I am not sure that i understand the question. Are you referring to LightDM GTK+ Greeter Settings?

Possibly this setting? Not sure whether this works together with variety.

Settings Manager > LightDM GTK+ Greeter settings > Appearance > Background: :ballot_box_with_check: Use user wallpaper if available

1 Like

This “Login Screen Support” option works for me. Have you tried it?

I thought this might be the solution but can see EndeavourOS achieves this without this setting, so it must be something else?

I’ll try this, although do wonder how Endeavour achieves it without any variety adjustment.


As is explained there, lightDM needs to be able to read your desktop background image file to set it as lockscreen bg. If endeavour doesn’t use this option in variety as default config, then they probably have their own script that copies over images to such a public location. Or maybe they take a different approach and provide lightdm access to the required folders. You can ask them in their forums about this.


Tried both above methods and neither worked.

Any other thoughts?


It’s probably just a coincidence - an initial match.
Once the user background is changed - it will no longer be reflected in the login screen.
I know - because I have endeavour here - and I changed the background - and it wasn’t the same in the login screen … until I told it to do so.
They have no special magic - they did … nothing
as far as this is concerned :wink:

one needs to actively tell it via:

endeavour … manjaro … anywhere …

1 Like

not a coincidence. login screen keeps updating when user wallpaper does in variety.

endeavouros forum don’t know why as they’ve not changed anything. they think it must be Variety, but if that was the case it would work in Manjaro too which it doesn’t.

No solution found how to make Manjaro wallpaper change with variety wallpaper, using either lightdm or variety settings.


there is a setting in Variety
5th tab - Customize
where this can be set
as @audialche mentioned

There is also a similar setting in Xfce - not sure if this would work with Variety.

I just checked (fresh installation of EndeavourOS).
Without changing or adapting anything - just the default Xfce in EndeavourOS
and default Variety
this is not true.

… just a fact :wink: :man_shrugging:

This is very strange. I didn’t change anything and works for me in EOS, without the Variety setting.

strange indeed
As I said - I just installed the most recent EndeavourOS Xfce, updated it to make it current, installed variety
and the result was as I said. :man_shrugging: