XFCE Firefox doesn't respect system changed default file browser

When I open the folder of downloaded files from firefox, it opens them with XFCE’s default file browser Thunar. I’ve changed the system default file browser to KDE’s Dolphin, but firefox is the last program to insist on opening thunar.
Steps tried:
Changed :Preferred Applications" file manager to dolphin. (Dolphin wasn’t actually recognised in this menu, only thunar and nautilus, so I put in the command /usr/bin/dolphin "%s" )
I’ve tried this betwen closing and restarting firefox, as well as system reboots.

Please return:

grep 'inode' /usr/share/applications/mimeinfo.cache

And actually this:

xdg-mime query default inode/directory

First result:
inode/directory=org.gnome.Nautilus.desktop;org.kde.dolphin.desktop;org.kde.filelight.desktop;org.kde.gwenview.desktop;org.xfce.Catfish.desktop;thunar.desktop;

Second result
org.kde.dolphin.desktop

I think these might help:
(see the second solution as well)

I’ve tried the first solution with switching back and forth, to both thunar and nautilus and back to dolphin, as well as between system reboots (again, dolphin wasn’t automatically listed in this menu, so i’ve used /usr/bin/dolphin "%s" ).
I’ve then tried the second solution by creating /usr/share/applications/defaults.list and adding the line inode/directory=org.kde.dolphin.desktop without success (again, first checked then rebooted and checked).
Nor did this work with nautilus’s desktop file.

I’ve also tried launching xfce4-mime-settings but this already had the correct inode association of dolphin

Just updating with more info for the results of inxi -Fazy

System:
  Kernel: 5.7.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 
  root=UUID=d74ad029-e562-4fc3-a8e6-e9055c042fd1 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS (WI-FI) v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 1405 date: 11/19/2019 
CPU:
  Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 
  family: 17 (23) model-id: 71 (113) stepping: N/A microcode: 8701013 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 86279 
  Speed: 2723 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 
  1: 2677 2: 2171 3: 2195 4: 2196 5: 2140 6: 2196 7: 2195 8: 2195 9: 2662 
  10: 2175 11: 2172 12: 2196 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] 
  vendor: Tul driver: amdgpu v: kernel bus ID: 0b:00.0 chip ID: 1002:731f 
  Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati 
  unloaded: modesetting,radeon alternate: fbdev,vesa display ID: :0.0 
  screens: 1 
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0") 
  s-diag: 777mm (30.6") 
  Monitor-1: DisplayPort-2 res: 2560x1440 hz: 60 dpi: 107 
  size: 609x355mm (24.0x14.0") diag: 705mm (27.8") 
  OpenGL: renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.37.0 5.7.15-1-MANJARO 
  LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.5 direct render: Yes 
Audio:
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel 
  bus ID: 0b:00.1 chip ID: 1002:ab38 
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 0d:00.4 chip ID: 1022:1487 
  Device-3: C-Media USB2.0 Hub type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 5-1.1:4 chip ID: 0d8c:01c2 
  Sound Server: ALSA v: k5.7.15-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel bus ID: 04:00.0 
  chip ID: 8086:2526 
  IF: wlp4s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: f000 bus ID: 05:00.0 
  chip ID: 10ec:8168 
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-3: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb 
  bus ID: 3-5:2 chip ID: 8087:0025 
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:
  Local Storage: total: 6.39 TiB used: 5.19 TiB (81.3%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: Sabrent model: N/A size: 953.87 GiB block size: 
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> 
  rev: RKT303.1 scheme: GPT 
  ID-2: /dev/sda vendor: Western Digital model: WD60EFAX-68SHWN0 
  size: 5.46 TiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 0A82 scheme: GPT 
Partition:
  ID-1: / raw size: 953.57 GiB size: 937.61 GiB (98.33%) 
  used: 877.77 GiB (93.6%) fs: ext4 dev: /dev/nvme0n1p2 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 46.5 C mobo: N/A gpu: amdgpu temp: 48 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
Info:
  Processes: 347 Uptime: 22h 44m Memory: 31.34 GiB used: 12.40 GiB (39.6%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 alt: 8 Packages: pacman: 1578 
  lib: 415 flatpak: 0 Shell: Bash v: 5.0.18 running in: xfce4-terminal 
  inxi: 3.1.05