XFCE does not honour light-locker setting

System:    Kernel: 5.6.8-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 root=UUID=cdaa598b-3251-44cc-8c09-5abb261f7e76 rw
           resume=UUID=0bd7b663-c7b8-4600-8ad1-2662cc58d1ca udev.log_priority=3
           Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine:   Type: Laptop System: LENOVO product: 3259HJG v: ThinkPad Edge E530 serial: <filter> Chassis: type: 10
           serial: <filter>
           Mobo: LENOVO model: 3259HJG serial: <filter> UEFI: LENOVO v: H0ET95WW (2.55 ) date: 01/20/2014
Battery:   ID-1: BAT0 charge: 20.5 Wh condition: 37.0/38.9 Wh (95%) volts: 11.2/10.8 model: SANYO 45N1043 type: Li-ion
           serial: <filter> status: Charging
           Device-1: hidpp_battery_0 model: Logitech Anywhere MX serial: <filter> charge: 45% rechargeable: yes
           status: Discharging
CPU:       Topology: Dual Core model: Intel Core i5-3210M bits: 64 type: MCP arch: Ivy Bridge family: 6 model-id: 3A (58)
           stepping: 9 microcode: 21 L2 cache: 3072 KiB
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 9981
           Speed: 2893 MHz min/max: 1200/3100 MHz Core speeds (MHz): 1: 2893 2: 2893
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
           Type: mds mitigation: Clear CPU buffers; SMT disabled
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, RSB filling
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0
           chip ID: 8086:0166
           Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting alternate: fbdev,vesa tty: N/A
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 20.0.6 compat-v: 3.0 direct render: Yes
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel
           bus ID: 00:1b.0 chip ID: 8086:1e20
           Sound Server: ALSA v: k5.6.8-1-MANJARO
Network:   Device-1: Intel Centrino Wireless-N 2230 driver: iwlwifi v: kernel port: efa0 bus ID: 03:00.0 chip ID: 8086:0888
           IF: wlp3s0 state: up mac: <filter>
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 2000
           bus ID: 0c:00.0 chip ID: 10ec:8168
           IF: enp12s0 state: down mac: <filter>
Drives:    Local Storage: total: 223.57 GiB used: 11.97 GiB (5.4%)
           ID-1: /dev/sda vendor: Toshiba model: TR150 size: 223.57 GiB block size: physical: 512 B logical: 512 B
           speed: 6.0 Gb/s serial: <filter> rev: 12.3 scheme: GPT
Partition: ID-1: / raw size: 214.47 GiB size: 210.11 GiB (97.96%) used: 11.80 GiB (5.6%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 8.80 GiB used: 180.8 MiB (2.0%) fs: swap swappiness: 60 (default) cache pressure: 100 (default)
           dev: /dev/sda3
Sensors:   System Temperatures: cpu: 64.0 C mobo: N/A
           Fan Speeds (RPM): cpu: 0
Info:      Processes: 196 Uptime: 1d 2h 11m Memory: 7.63 GiB used: 1.84 GiB (24.1%) Init: systemd v: 244 Compilers: gcc: 9.3.0
           Shell: zsh v: 5.8 running in: alacritty inxi: 3.0.37


I've disabled the locking feature in XFCE Power Management, and verified it with the command below

 xfconf-query -c xfce4-power-manager -lv
/xfce4-power-manager/blank-on-ac                        4
/xfce4-power-manager/blank-on-battery                   4
/xfce4-power-manager/brightness-on-ac                   60
/xfce4-power-manager/brightness-on-battery              30
/xfce4-power-manager/brightness-switch                  0
/xfce4-power-manager/brightness-switch-restore-on-exit  0
/xfce4-power-manager/critical-power-action              2
/xfce4-power-manager/dpms-on-ac-off                     0
/xfce4-power-manager/dpms-on-ac-sleep                   10
/xfce4-power-manager/dpms-on-battery-off                30
/xfce4-power-manager/dpms-on-battery-sleep              6
/xfce4-power-manager/inactivity-on-ac                   14
/xfce4-power-manager/inactivity-on-battery              31
/xfce4-power-manager/lid-action-on-ac                   1
/xfce4-power-manager/lid-action-on-battery              2
/xfce4-power-manager/lock-screen-suspend-hibernate      false
/xfce4-power-manager/logind-handle-lid-switch           false
/xfce4-power-manager/power-button-action                3
/xfce4-power-manager/presentation-mode                  false
/xfce4-power-manager/show-tray-icon                     1

but the screen still locks after each suspend/hibernate. Am I doing something wrong, did I forget a setting?

There seems to be another setting in Session and Startup.
https://docs.xfce.org/xfce/xfce4-session/preferences
https://bugzilla.xfce.org/show_bug.cgi?id=16300

Thank you for the answer!

Lock screen before sleep is also not set in the General tab of Session and Startup. xfce4-screensaver is not installed.
Can you disable it in your install?

Yes : disabling it as you showed in your first post does prevent it from locking on suspend on my end.

:thinking:

This has been an issue for one year it seems.

1 Like

Forum kindly sponsored by