Xfce apps see folder symlink as a file

Using manjaro xfce and programs installed by default, like Thunar and mousepad.

Edit by newhere: The above text was added by forum admin. I honestly don’t see why the admins of this forum has this eager to change my threads, add text that is not relevant to the subject, change the subject so that they don’t mention what the issue is, or move the threads to categories where they don’t belong.

End of edit, here is what this thread is about:

I have a folder /shared that I was planning on using as a location to store files shared with other users. The folder is a mountpoint for /dev/nvme1n1p2.
Then I created a symlink in my homefolder to this folder
ln -s /shared
I terminal, I can do
cd /home/myuser/shared
which takes me to the content of /shared.
However, if I use Thunar, mosepad or some other gui programs, double click on shared under my home folder, tries to open the symlink as a file. If I try to save a file and double click on the symlink to browse to /shared, I’m asked if I want to overwrite the file /home/myuser/shared.

I suspect this behavior started in early October. I think this was not an issue before, although I’m not 100% sure if I actually tested it before. Is this some settings I’ve managed to mess up, or is it a result of an automatic update, or has it always been like this?

Try to specify source and destination
ln -s [/path/folder] [/another/path/soft-link-to-folder]

Maybe you have to go to Settings Manager > Mime Type Editor and in the filter box, enter symlink. You should see something like:

inode/symlink     Default     Open folder with Thunar

Also, make sure you do not create the link as root, don’t use sudo. Also you can create the link from Thunar itself


1 Like

Edit mime type, changing it from default to Open with Thunar, did not help.
I have symlinks created by root, and symlinks created by my username, and now I also tried to create a symlink in Thunar as myusername. They all behave the same - behaving like a symlink in terminal, behaving like a file in any other application.

By telling the symlink should be owned by my user you gave me an idea to test… So I tried as root:

mkdir /etc/test
chown myusername:myusername /etc/test

And as myusername (in my home folder)

ln -s /etc/test
echo a > test/a.txt

This symlink worked as a symlink in Thunar. Thunar even gave it the icon of a folder with an arrow. (Those not-working symlinks are given a blue paper with an arrow as icon.)

Next test:
as myusername (in my home folder)

ln -s /etc/alsa

This symlink also worked in thunar.

So I tried, again as myusername in my home folder:

ln -s /vb

This symlink was NOT working. /vb is the mountpoint of one of my zfs disks.
So I unmounted /vb and refreshed Thunar - now the vb symlink worked.
Then I mounted /vb again, and the symlink stopped working.

So, it seems like this is another thunar - zfs bug. It was probably introduced with the update to thunar and glib I installed early october. Another result of that update is that Thunar cannot copy files to any zfs or smb mounted volumes. It could before the update.

Now, how can I revert that systemwide automatic update?

try this: