XF86RFKILL Key Activating Automatically and Disrupting Wireless Services on Manjaro KDE

Hello Manjaro community,

I’m experiencing an issue with my Manjaro KDE laptop where the XF86RFKILL button is activating automatically and causing disruptions to my wireless services, such as Wi-Fi and Bluetooth. This continuous activation and deactivation of wireless services are quite disturbing.

Initially, I suspected it might be due to a problem with my laptop’s keyboard because I had a similar issue with other keys like the volume button and page down button. To address this, I disabled the laptop’s keyboard using the xinput --disable command and started using an external USB keyboard. Surprisingly, this resolved the issues with the other keys, but the XF86RFKILL problem persists.

I’ve also tried running the command xmodmap -e 'keycode 255=' in an attempt to address the issue, but it hasn’t solved the problem.

For reference, I’m using an HP250G7 laptop.

Could you please provide guidance on how to troubleshoot and resolve this XF86RFKILL key issue? I appreciate any help or suggestions you can provide.

Thank you!

Please post the output of xinput.

If memory serves, this may go through another interface. So you may be disabling the wrong one.

Are you using wayland?

This is the output of xinput after running the command xinput --disable 13 :

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SEM USB Keyboard Consumer Control         id=9    [slave  pointer  (2)]
⎜   ↳ USB OPTICAL MOUSE                         id=11   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ SEM USB Keyboard                          id=8    [slave  keyboard (3)]
    ↳ SEM USB Keyboard System Control           id=10   [slave  keyboard (3)]
    ↳ HP TrueVision HD Camera: HP Tru           id=12   [slave  keyboard (3)]
    ↳ HP WMI hotkeys                            id=15   [slave  keyboard (3)]
    ↳ Wireless hotkeys                          id=16   [slave  keyboard (3)]
    ↳ SEM USB Keyboard Consumer Control         id=17   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]

Note that my laptop’s keyboard is currently unresponsive.

Sorry, I don’t know much about ‘Wayland’. After searching on internet, I found echo $XDG_SESSION_TYPE command will show if I’m using it or not, and its output is x11. So I believe I’m not using Wayland.

These look like they might have something to do with that key, you could try disabling them one at a time. I’d start with the wireless.

Thank you so much.

I have disabled the Wireless hotkeys and waited for more than 24 hours, it did not happen again.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.