xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)

When I do startx I get the following error xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
Detailed output on the terminal are here
This happened after I did rmmod pcspkr to remove the annoying pc speaker sound (but the beep didn’t go). And when this error started showing up I did modprobe pcspkr. But that didn’t remove the above error.
My Distro : Manjaro i3 (community spin)
Log : Xorg.0.log

Hi,

have you tried to launch X as root ? (sudo startx)

When I do sudo startx i3 boots (but as root user!! [obviously]).
But the problems are still there.
The problems are

  • feh command is not working now
  • rofi is not starting up

These are present after the bar block.
But compton is also after the bar block but it is being executed.

Here is the i3 config for reference. This used to work before I did rmmod pcspkr.

Try renaming your config file just to rule that out.

EDIT: also try renaming i3status.conf while keeping your config file.

1 Like

Thanks @mbb
Disabling my custom i3config worked.
I also renamed i3blocks.conf (I use i3blocks instead of i3status) and found that this wasn’t the problem.
So now I will have to recreate my custom config line by line and isolate the error.
I will post the solution when I find it.
Thamks again @mbb

1 Like

I finally solved it : thank you @mbb. Your reply lead me to the solution.

The problem was because I used lowercase instead of uppercase in 3 places.
Two of them were in the path of the wallpaper which was the argument of feh

Details
I once did startx > startx.log and the content was

ERROR: Could not translate string to key symbol: "tab"

But at that time I didn’t know what this meant. I googled this and didn’t find anything.
Then I removed my i3 config (as advised by @mbb) and I replaced it with the default config from /etc/i3/config.

The mod key was Mod1 (Alt) but I prefer Mod4 (Super). So I changed all occurrences of Mod1 with mod4 (The case was wrong). Then when I refreshed i3 there were so many ERROR: Could not translate string to key symbol: "mod4 ....". That is when I realized the character case difference. This also provided a clue for the error in the startx.log. The only occurence of tab was in the keybinding of rofi. When I changed tab to Tab for rofi and reloaded i3 rofi worked.

My next problem was the wallpaper by feh and I quickly found 2 errors in the path specified.

So I [hope] solved it.

Thanks again @mbb

2 Likes

Forum kindly sponsored by Bytemark