Xen not showing up in Boot Menu

aur
boot

#1

I installed and configured Xen according to the Xen Arch Wiki page. Here are the steps I took in order:
Installed Xen from the AUR
Generated Grub configuration file with
grub-mkconfig -o /boot/grub/grub.cfg

After running the command, I dont see the Xen option in the boot menu.

Please advise.


#2

You can try
sudo update-grub


#3

tried sudo update-grub, but no change. Its still the same. I cannot see the entries in the boot menu for xen


#4

Can someone please help?


#5

Please correct me if I am wrong - that happens more often than you think :slight_smile:

I am not sure Manjaro supports Zen in the same way Arch does.

I have never experimented with other kernels nor Zen - except for my occational revisit to Qubes.

Zen is to my limited knowledge a bare-metal hypervisor and as such it requires some configuration to boot a zen-image. If you want to be able to boot a zen-image - comparable to other virtual harddrives - the image needs to be present.

I couldn’t quite grasp zen so I did a more thorough lookup and I seem to confuse zen with zen.

The one being the bare-metal hypervisor the other being a kernel. That confusion aside - Manjaro is not Arch and not all Arch is appliable to Manjaro. As stated above I never had the urge to push the kernel thing to the limits but checking on the zen kernel it is not AUR but mainstream Arch which might or might not be your issue here.

One more issue aside - if you check the official Manjaro repositories there’s is no mention of Zen-kernel and support for it.

If you really want you could try to install the AUR package linux-zen-git but that voids your warranty :slight_smile: joke aside - you are on your own there.


#6

I had the same issue and I believe it is related to a difference in how kernels are named between Arch and Manjaro. I was able to solve the issue & get the system to boot into Xen by running these commands:

sudo sed -i 's,/boot/vmlinuz-linux,/boot/vmlinuz-,g' /etc/grub.d/09_xen
sudo grub-mkconfig -o /boot/grub/grub.cfg

Hope this helps you too!


#7

I think the user is meaning that they have installed xen from this AUR package, not the kernel you are referring to. That was the case for me anyway.

I’m sure you’re right about support though - I don’t consider it likely that I would get any support for packages I may install from the AUR.


#8

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.