Xdm crashes

Hi all,

I’ve installed the last testing update for my openrc kde and now I’ve the problem, that I have no desktop. My system starts normally but I only get a terminal, where I can login with my username and password. I typed

and I get the output, that xdm crashed.

What can I do to fix this issue?

Roberto

So what DM do you use?

You need to set it in /etc/conf.d/xdm

I suggest for any openrc user to please read some basic openrc documentation. It will help you. :slight_smile:

The gentoo wiki is usually a good source, since openrc is default on gentoo, and you even learn a bit about kernel settings if you are interested, but this can be skipped on manjaro.

Hi artoo, I use sddm and its set in /etc/conf.d/xdm.
Thanks for your hint to get some openrc basics but I don’t find any helpful tips for my problem. I’m always interestet in learning more about the basics of manjaro and openrc.

I tried to restart xdm with

but I get the warning that xdm is already startet.

You need sddm-elogind package.
But I suspect something is off with your xorg.

The sddm-elogind package is installed too. I switched from consolekit to elogind several weeks ago.

Please post the /var/log/Xorg.0.log

And your ~.local/share/sddm/xorg-session.log

Sorry for my stupid question, but how can I post the output of these files, when I have no graphical interface to save and upload it here?
I’m afraid, that I haven’t read this chapter of the basics.

Ah, I see, it depends on your terminal skills do that.

The cat some_file command will display file contents.
Look at your logs if any obvious errors are logged.

I opened the ~.local/share/sddm/xorg-session.log and there is the following error logged:

It seems, taht there is a problem with the X11 server.

As suspected.

I would need your inxi output and if possible the /var/log/Xorg.0.log

Can I send you 2 screenshots to post it?

1 Like

Start with the log file, its atm more interesting.

Here’s the log file:

Unfortunately, the interesting part is at the beginning of the file, the card and screen initialization.

2nd attempt:

Please try switching to unstable branch, I can guarantee it works there.

Also, your basic error description is insufficient. The pacman.log would be nice too, what updates you did in testing.

1 Like

Switching to unstable was the solution.

Here is the output of the pacman.log from testing branch:

[2017-05-26 20:16] [PACMAN] Running 'pacman -Sy' [2017-05-26 20:16] [PACMAN] synchronizing package lists [2017-05-26 20:17] [PACMAN] Running 'pacman -Syyu' [2017-05-26 20:17] [PACMAN] synchronizing package lists [2017-05-26 20:17] [PACMAN] starting full system upgrade [2017-05-26 20:20] [ALPM] transaction started [2017-05-26 20:20] [ALPM] upgraded alsa-lib (1.1.3-1 -> 1.1.4-1) [2017-05-26 20:20] [ALPM] upgraded alsa-plugins (1.1.1-1 -> 1.1.4-1) [2017-05-26 20:20] [ALPM] upgraded libtiff (4.0.7-3 -> 4.0.8-1) [2017-05-26 20:20] [ALPM] upgraded imagemagick (6.9.8.5-1 -> 6.9.8.6-1) [2017-05-26 20:20] [ALPM] upgraded libelogind (228.3-1 -> 229.3-1) [2017-05-26 20:20] [ALPM] upgraded hwids (20161103-1 -> 20170328-1) [2017-05-26 20:20] [ALPM] upgraded mesa (17.0.6-1 -> 17.1.0-1) [2017-05-26 20:20] [ALPM] upgraded cups-filters (1.13.5-1 -> 1.14.0-1) [2017-05-26 20:20] [ALPM] upgraded dmidecode (3.0-1 -> 3.1-1) [2017-05-26 20:20] [ALPM] upgraded elogind (228.3-1 -> 229.3-1) [2017-05-26 20:20] [ALPM] upgraded libx264 (2:148.20170121-1 -> 2:148.20170121-6) [2017-05-26 20:20] [ALPM] upgraded ffmpeg (1:3.3-5 -> 1:3.3.1-8) [2017-05-26 20:20] [ALPM] upgraded noto-fonts (20170307-2 -> 20170428-1) [2017-05-26 20:20] [ALPM] upgraded pango (1.40.5-1 -> 1.40.6+6+g6f59d0f3-2) [2017-05-26 20:20] [ALPM] upgraded jasper (2.0.12-1 -> 2.0.13-1) [2017-05-26 20:20] [ALPM] upgraded openssl-1.0 (1.0.2.k-3 -> 1.0.2.k-4) [2017-05-26 20:20] [ALPM] upgraded npth (1.3-1 -> 1.4-1) [2017-05-26 20:20] [ALPM] upgraded qt5-declarative (5.8.0-1 -> 5.8.0-2) [2017-05-26 20:20] [ALPM] upgraded firefox-kde (53.0.2-1 -> 53.0.3-1) [2017-05-26 20:20] [ALPM] upgraded firefox-kde-i18n-de (53.0.2-1 -> 53.0.3-1) [2017-05-26 20:20] [ALPM] upgraded kdenlive (17.04.1-1 -> 17.04.1-1.1) [2017-05-26 20:20] [ALPM] upgraded lib32-libdrm (2.4.79-1 -> 2.4.80-1) [2017-05-26 20:20] [ALPM] installed lib32-lm_sensors (3.4.0-1) [2017-05-26 20:20] [ALPM] upgraded lib32-mesa (17.0.6-1 -> 17.1.0-1) [2017-05-26 20:20] [ALPM] upgraded libatomic_ops (7.4.4-1 -> 7.4.6-1) [2017-05-26 20:20] [ALPM] upgraded linux-firmware (20170309.695f2d6-1 -> 20170422.ade8332-1) [2017-05-26 20:20] [ALPM] upgraded linux49 (4.9.28-1 -> 4.9.29-1) [2017-05-26 20:20] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ... [2017-05-26 20:20] [ALPM] upgraded linux49-bbswitch (0.8-23 -> 0.8-24) [2017-05-26 20:20] [ALPM] upgraded linux49-r8168 (8.044.02-3 -> 8.044.02-4) [2017-05-26 20:20] [ALPM] upgraded manjaro-hotfixes (2015.12-2 -> 2015.12-3) [2017-05-26 20:20] [ALPM] upgraded protobuf (3.2.1-1 -> 3.3.1-1) [2017-05-26 20:20] [ALPM] upgraded python2-cairo (1.10.0-2 -> 1.13.1-1) [2017-05-26 20:20] [ALPM] upgraded qca-qt5 (2.1.3-3 -> 2.1.3-4) [2017-05-26 20:21] [ALPM] upgraded qt5-webengine (5.8.0-8 -> 5.8.0-9) [2017-05-26 20:21] [ALPM] upgraded sane (1.0.25-2 -> 1.0.27-1) [2017-05-26 20:21] [ALPM] upgraded xfsprogs (4.10.0-1 -> 4.11.0-1) [2017-05-26 20:21] [ALPM] transaction completed [2017-05-26 20:21] [ALPM] running '90-linux49.hook'... [2017-05-26 20:21] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux49.preset: 'default' [2017-05-26 20:21] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-4.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.9-x86_64.img [2017-05-26 20:21] [ALPM-SCRIPTLET] ==> Starting build: 4.9.29-1-MANJARO [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [base] [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [udev] [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [autodetect] [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [modconf] [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [block] [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [keyboard] [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [keymap] [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [resume] [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [filesystems] [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [fsck] [2017-05-26 20:21] [ALPM-SCRIPTLET] ==> Generating module dependencies [2017-05-26 20:21] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.9-x86_64.img [2017-05-26 20:21] [ALPM-SCRIPTLET] ==> Image generation successful [2017-05-26 20:21] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux49.preset: 'fallback' [2017-05-26 20:21] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-4.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.9-x86_64-fallback.img -S autodetect [2017-05-26 20:21] [ALPM-SCRIPTLET] ==> Starting build: 4.9.29-1-MANJARO [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [base] [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [udev] [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [modconf] [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [block] [2017-05-26 20:21] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x [2017-05-26 20:21] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [keyboard] [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [keymap] [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [resume] [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [filesystems] [2017-05-26 20:21] [ALPM-SCRIPTLET] -> Running build hook: [fsck] [2017-05-26 20:21] [ALPM-SCRIPTLET] ==> Generating module dependencies [2017-05-26 20:21] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.9-x86_64-fallback.img [2017-05-26 20:21] [ALPM-SCRIPTLET] ==> Image generation successful [2017-05-26 20:21] [ALPM] running '99-grub.hook'... [2017-05-26 20:21] [ALPM-SCRIPTLET] GRUB-Konfigurationsdatei wird erstellt … [2017-05-26 20:21] [ALPM-SCRIPTLET] Hintergrund gefunden: /usr/share/grub/background.png [2017-05-26 20:21] [ALPM-SCRIPTLET] Found Intel Microcode image [2017-05-26 20:21] [ALPM-SCRIPTLET] Linux-Abbild gefunden: /boot/vmlinuz-4.9-x86_64 [2017-05-26 20:21] [ALPM-SCRIPTLET] initrd-Abbild gefunden: /boot/initramfs-4.9-x86_64.img [2017-05-26 20:21] [ALPM-SCRIPTLET] Found initrd fallback image: /boot/initramfs-4.9-x86_64-fallback.img [2017-05-26 20:21] [ALPM-SCRIPTLET] WARNING: Failed to connect to lvmetad. Falling back to device scanning. [2017-05-26 20:21] [ALPM-SCRIPTLET] Found memtest86+ image: /boot/memtest86+/memtest.bin [2017-05-26 20:21] [ALPM-SCRIPTLET] erledigt [2017-05-26 20:21] [ALPM] running 'fontconfig.hook'... [2017-05-26 20:21] [ALPM] running 'gtk-update-icon-cache.hook'... [2017-05-26 20:21] [ALPM] running 'update-desktop-database.hook'... [2017-05-26 20:21] [ALPM] running 'update-mime-database.hook'... [2017-05-26 20:21] [ALPM-SCRIPTLET] Unknown media type in type 'all/all' [2017-05-26 20:21] [ALPM-SCRIPTLET] Unknown media type in type 'all/allfiles' [2017-05-26 20:21] [ALPM] running 'xorg-mkfontdir.hook'...

and this the log after switching to unstable:

[2017-05-26 22:50] [PACMAN] Running 'pacman -Syyu' [2017-05-26 22:50] [PACMAN] synchronizing package lists [2017-05-26 22:50] [PACMAN] starting full system upgrade [2017-05-26 22:51] [ALPM] transaction started [2017-05-26 22:51] [ALPM] upgraded confuse (3.0-1 -> 3.1-1) [2017-05-26 22:51] [ALPM] upgraded libdrm (2.4.80-1 -> 2.4.81-1) [2017-05-26 22:51] [ALPM] upgraded lib32-libdrm (2.4.80-1 -> 2.4.81-1) [2017-05-26 22:51] [ALPM] upgraded llvm-libs (4.0.0-2 -> 4.0.0-3) [2017-05-26 22:51] [ALPM] upgraded mesa (17.1.0-1 -> 17.1.1-0) [2017-05-26 22:51] [ALPM] upgraded lib32-mesa (17.1.0-1 -> 17.1.1-0) [2017-05-26 22:51] [ALPM] upgraded openssl (1.1.0.e-1 -> 1.1.0.f-1) [2017-05-26 22:51] [ALPM] upgraded libftdi (1.3-3 -> 1.3-4) [2017-05-26 22:51] [ALPM] upgraded libwbclient (4.5.8-1 -> 4.5.10-0) [2017-05-26 22:52] [ALPM] upgraded linux49 (4.9.29-1 -> 4.9.30-1) [2017-05-26 22:52] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ... [2017-05-26 22:52] [ALPM] upgraded linux49-bbswitch (0.8-24 -> 0.8-25) [2017-05-26 22:52] [ALPM] upgraded linux49-r8168 (8.044.02-4 -> 8.044.02-5) [2017-05-26 22:52] [ALPM] upgraded openssl-1.0 (1.0.2.k-4 -> 1.0.2.l-1) [2017-05-26 22:52] [ALPM] upgraded opus (1.1.4-1 -> 1.1.5-1) [2017-05-26 22:52] [ALPM] upgraded pango (1.40.6+6+g6f59d0f3-2 -> 1.40.6+9+g92cc73c8-1) [2017-05-26 22:52] [ALPM] upgraded qt5-base-nosystemd (5.8.0-3 -> 5.8.0-4) [2017-05-26 22:52] [ALPM] upgraded smbclient (4.5.8-1 -> 4.5.10-0) [2017-05-26 22:52] [ALPM] transaction completed [2017-05-26 22:52] [ALPM] running '90-linux49.hook'... [2017-05-26 22:52] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux49.preset: 'default' [2017-05-26 22:52] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-4.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.9-x86_64.img [2017-05-26 22:52] [ALPM-SCRIPTLET] ==> Starting build: 4.9.30-1-MANJARO [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [base] [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [udev] [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [autodetect] [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [modconf] [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [block] [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [keyboard] [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [keymap] [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [resume] [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [filesystems] [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [fsck] [2017-05-26 22:52] [ALPM-SCRIPTLET] ==> Generating module dependencies [2017-05-26 22:52] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.9-x86_64.img [2017-05-26 22:52] [ALPM-SCRIPTLET] ==> Image generation successful [2017-05-26 22:52] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux49.preset: 'fallback' [2017-05-26 22:52] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-4.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.9-x86_64-fallback.img -S autodetect [2017-05-26 22:52] [ALPM-SCRIPTLET] ==> Starting build: 4.9.30-1-MANJARO [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [base] [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [udev] [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [modconf] [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [block] [2017-05-26 22:52] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x [2017-05-26 22:52] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [keyboard] [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [keymap] [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [resume] [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [filesystems] [2017-05-26 22:52] [ALPM-SCRIPTLET] -> Running build hook: [fsck] [2017-05-26 22:52] [ALPM-SCRIPTLET] ==> Generating module dependencies [2017-05-26 22:52] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.9-x86_64-fallback.img [2017-05-26 22:52] [ALPM-SCRIPTLET] ==> Image generation successful [2017-05-26 22:52] [ALPM] running '99-grub.hook'... [2017-05-26 22:52] [ALPM-SCRIPTLET] GRUB-Konfigurationsdatei wird erstellt … [2017-05-26 22:52] [ALPM-SCRIPTLET] Hintergrund gefunden: /usr/share/grub/background.png [2017-05-26 22:52] [ALPM-SCRIPTLET] Found Intel Microcode image [2017-05-26 22:52] [ALPM-SCRIPTLET] Linux-Abbild gefunden: /boot/vmlinuz-4.9-x86_64 [2017-05-26 22:52] [ALPM-SCRIPTLET] initrd-Abbild gefunden: /boot/initramfs-4.9-x86_64.img [2017-05-26 22:52] [ALPM-SCRIPTLET] Found initrd fallback image: /boot/initramfs-4.9-x86_64-fallback.img [2017-05-26 22:52] [ALPM-SCRIPTLET] WARNING: Failed to connect to lvmetad. Falling back to device scanning. [2017-05-26 22:52] [ALPM-SCRIPTLET] Found memtest86+ image: /boot/memtest86+/memtest.bin [2017-05-26 22:52] [ALPM-SCRIPTLET] erledigt

1 Like

I guess qt5-base-nosystemd update should go in testing too.

The packages, which are updatet twice are:

and

and

Maybe there is a correlation.

And … thank you very very much for your great help :slight_smile: