Xbox360 doesn't work in steam anymore after updating hardcode-fixer

Hello everyone,

I’ve used my Xbox360 gamepad (wireless with the microsoft adapter) in Manjaro as well as an Ipega-9088 in Xbox 360 mode (hold start before plugging the usb cable, then hold the home key for about 5 seconds) and both were recognized as the xbox 360 gamepad and worked pretty good until now.

Today there were 2 updates and, after they were updated, it gamepads work fine in wine and is recognized by the system, but, whenever I open steam, steam recognizes it correctly but they won’t work under steam or any game. If I close steam, then the system (I’m using KDE btw), still recognizes the gamepads but they are stuck, no button or the sticks work. I’ve tried with each one at a time and together and nothing seems to work.

I realized that when I open steam up, a new gamepad for each physical one of the same appears in kde system settings but none of them work.

the ipega 9088 works right if in PS3 mode but not in xbox360 mode and the original xbox360 gamepad doesn’t work either in steam anymore.

There are no more updates. Steam is also up-to-date. I’ve tried turning off steam controller xbox support option but it still doesn’t work (with neither, it on or off).

In order to make the xbox360 work again, I have to turn the gamepad off and on again with steam closed, then it works properly under kde and wine but not in steam again. It happens with the original x360 gamepad and the ipega-9088

here are the updated packages:

[2020-09-07T12:48:08-0300] [ALPM] upgraded manjaro-system (20200723-1 -> 20200906-1)
[2020-09-07T12:48:09-0300] [ALPM] upgraded hardcode-fixer (1:r539.f812186-5 -> 1:r543.0321910-1)

I appreciate any help :slight_smile:

Update: after today’s (2020-09-08) update, if I uninstall steam and install it again, the gamepads work properly again but the issue comes back when I reboot the system. (I’ve tried using steam-manjaro and steam-native packages… both gives the same issue… used both separately and together to test