Xbox Series X Controller Buttons Wrong

Having an issue using an Xbox controller with Manjaro. The controller pairs and works normally except the bindings are always all wrong in games. Right bumper is consistently start for example.

I’ve tried using the xpadneo and xboxdrv but can not get a different result. I have managed temporary solutions messing around with Steam but it doesn’t work for anything outside of it and I have to redo it whenever Steam is closed.

Have you tried the xpadneo package? I use that on my Xbox series x controller via Bluetooth without issue.

I’ve tried using both the xpadneo-dkms-git and xpadneo-dkms aur packages but neither fix the issue.

Edit: I seem to have fixed the issue by installing the linux515-headers package, I’m new to Manjaro (and Linux in general) so did not realize it was something I was missing (or could be missing)

I’m glad you figured it out.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.