XBox like controller recognized, but there is no response to input

Hi everyone,

I have a RedGear Zonik Gamepad(Wired), an XBox type controller. When I plug it into my laptop, it is detected but when I press buttons there is no response.

I used jstests-gtk AUR repo to test the controller.

I tried to install xpad-dkms-git driver from AUR to try to get it to work, but there seems to be some error here.

Error! echo
Your kernel headers for kernel 5.10.53-1-MANJARO cannot be found at
/usr/lib/modules/5.10.53-1-MANJARO/build or /usr/lib/modules/5.10.53-1-MANJARO/source.
You can use the --kernelsourcedir option to tell DKMS where it's located.
error: command failed to execute correctly
:: Running post-transaction hooks...

Please help me to solve this issue.


Do you have linux510-headers installed?

1 Like

Thank you very much for your reply.

This was not installed.

I installed it now and the error has gone.

But there is still no response from the controller. Should I restart my laptop and try again?

I can’t say.

I can only tell you that depending on which game you try to use it on, you may need to enable settings. For instance, i’ve read that some Steam games don’t manage gamepad input themselves, and instead rely on Steam through a setting to activate.

I understand.

Thank you a lot for you help. I really mean it.

I will mark this comment as the answer for now.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.