Xbacklight stopped working after last update

After this update, xbacklight is not working on my laptop: the commands xbacklight -inc 1 and xbacklight -dec 1 no longer change screen brightness, even after rebooting. They had been working for months.

Replacing 1 by 10 in the above commands does not solve the issue.

Changing the brightness with the Cinnamon panel works, just as before the update. (I prefer xbacklight because it allows much more precise control of brightness.)

Workaround: I write to /sys/class/backlight/intel_backlight/brightness, but this requires sudoing.

You can click the command below to see my config.

inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.4.142-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=907cc8ac-d98d-4516-b37b-82a392f7186e ro quiet apparmor=1 
  security=apparmor resume=UUID=4cc3c850-cb81-4dca-bce4-c33916d25a88 
  Desktop: Cinnamon 5.0.5 tk: GTK 3.24.30 vt: 7 dm: LightDM 1.30.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Acer product: Swift SF314-54 v: V1.14 serial: <filter> 
  Mobo: KBL model: Strongbow_KL_S v: V1.14 serial: <filter> UEFI: Insyde 
  v: 1.14 date: 03/15/2019 
  ID-1: BAT0 charge: 15.9 Wh (33.9%) condition: 46.9/50.8 Wh (92.4%) 
  volts: 16.0 min: 15.3 model: SMP-SDI3320 AC14B7K type: Li-ion 
  serial: <filter> status: Charging 
  RAM: total: 3.73 GiB used: 3.11 GiB (83.4%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core i3-7020U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: A (10) 
  microcode: EA cache: L2: 3 MiB bogomips: 18406 
  Speed: 800 MHz min/max: 400/2300 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs intel_pt invpcid invpcid_single lahf_lm lm mca 
  mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe 
  pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand 
  rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 
  ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme 
  vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 620 vendor: Acer Incorporated ALI driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:5916 class-ID: 0300 
  Device-2: Chicony HD WebCam type: USB driver: uvcvideo bus-ID: 1-7:3 
  chip-ID: 04f2:b5c5 class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.13 driver: loaded: modesetting 
  alternate: fbdev,vesa display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 158 size: 309x173mm (12.2x6.8") 
  diag: 354mm (13.9") 
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.2.1 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 
  chip-ID: 8086:9d71 class-ID: 0401 
  Sound Server-1: ALSA v: k5.4.142-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: no 
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: 3040 
  bus-ID: 02:00.0 chip-ID: 8086:095a class-ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 1-5:2 chip-ID: 8087:0a2a class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Message: No logical block device data found. 
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: 3060 bus-ID: 00:17.0 chip-ID: 8086.282a rev: 21 class-ID: 0104 
  Local Storage: total: 119.24 GiB used: 55.41 GiB (46.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: SK Hynix model: HFS128G39TND-N210A 
  size: 119.24 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 1P10 scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 38.08 GiB size: 37.23 GiB (97.77%) used: 29.83 GiB (80.1%) 
  fs: ext4 dev: /dev/sda6 maj-min: 8:6 label: N/A 
  uuid: 907cc8ac-d98d-4516-b37b-82a392f7186e 
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) 
  used: 47.9 MiB (49.9%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: ESP 
  uuid: 9862-60D5 
  ID-3: /home raw-size: 36.28 GiB size: 35.46 GiB (97.74%) 
  used: 25.4 GiB (71.6%) fs: ext4 dev: /dev/sda7 maj-min: 8:7 label: N/A 
  uuid: fbeba692-668d-4f7f-96b5-c43d6f496a20 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 4.7 GiB used: 135.5 MiB (2.8%) 
  priority: -2 dev: /dev/sda5 maj-min: 8:5 label: swap 
  uuid: 4cc3c850-cb81-4dca-bce4-c33916d25a88 
  ID-1: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-2: /dev/sda3 maj-min: 8:3 size: 39.06 GiB fs: ntfs label: Windows 
  uuid: 547A64897A646A26 
  ID-3: /dev/sda4 maj-min: 8:4 size: 1024 MiB fs: ntfs label: Recovery 
  uuid: FCE265B3E26572B6 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-5:2 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 8087:0a2a class-ID: e001 
  Device-2: 1-7:3 info: Chicony HD WebCam type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 04f2:b5c5 
  class-ID: 0e02 serial: <filter> 
  Device-3: 1-9:4 info: LighTuning EgisTec Touch Fingerprint Sensor 
  type: <vendor specific> driver: N/A interfaces: 1 rev: 1.1 speed: 12 Mb/s 
  power: 100mA chip-ID: 1c7a:0570 class-ID: 0000 serial: <filter> 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 43.0 C mobo: 30.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 199 Uptime: 35m wakeups: 1297 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1665 lib: 407 
  flatpak: 0 Shell: Bash v: 5.1.8 running-in: gnome-terminal inxi: 3.3.06 

Is working here: Xfce, Kernel 4.14.
Would be fine if you open a new discussion in the support section, indicating your system specs :+1:
EDIT: has been split by a moderator :slight_smile:

1 Like

As per your request: moved to support category. If you do find a solution, don’t forget to add the solution to the known solutions Wiki please?


P.S. @D.Dave OP has edited his post to show 5.4 kernel on a 03/15/2019 UEFI 1.14 system.

I gave up waiting for a solution to this, so I found a workaround.
I uninstalled xbacklight and installed acpilight. This package has an drop in replacement for the xbacklight command. System had to be rebooted in order to make the new command work.


@Fornost Can you confirm the workaround above works for you too? If yes, don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

Thanks a lot, marli. Below is a detailed description of how I got your solution to work on my PC.

  1. Uninstall xorg-xbacklight.
  2. Install acpilight.
  3. Add yourself to the video group:
    sudo gpasswd -a your_username video
  4. Reboot.

Then xbacklight works again (with minor differences).


You got a :heart: but as @marli’s workaround led you to the solution his answer is the solution… However, if you disagree with my choice, please feel free to revert my opinion: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.