X Server fails / NVIDIA: A GPU exception occurred during X server initialization(EE)

Hi there. This is probably a hardware issue with my NVidia.

I was programming all day, ... all of a sudden both connected monitors spit out weird artifact blocks all over the screens, which freeze. I was able to move the mouse by a few pixels and after a while... total deadlock.

I was/am able to connect via my notebook to that desktop PC (SSH). X keeps crashing, also after reboots. Now X totally fails to boot.

My graphics card:

$ nvidia-smi
Fri Nov 29 21:18:44 2019       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 390.132                Driver Version: 390.132                   |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 560     Off  | 00000000:01:00.0 N/A |                  N/A |
| 30%   33C    P0    N/A /  N/A |      0MiB /   963MiB |     N/A      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0                    Not Supported                                       |
+-----------------------------------------------------------------------------+

less /var/log/Xorg.0.log tells me:

[   109.094] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[   109.094] 
X.Org X Server 1.20.5
X Protocol Version 11, Revision 0
[   109.094] Build Operating System: Linux Arch Linux
[   109.094] Current Operating System: Linux Panther 4.19.85-1-MANJARO #1 SMP PREEMPT Thu Nov 21 10:38:39 UTC 2019 x86_64
[   109.094] Kernel command line: BOOT_IMAGE=/vmlinuz-4.19-x86_64 root=/dev/mapper/ManjaroVG-ManjaroRoot rw cryptdevice=/dev/disk/by-uuid/29f626b8-0623-490a-ba75-d4f7a91d923f:cryptManjaro quiet
[   109.094] Build Date: 27 October 2019  08:49:23AM
[   109.094]  
[   109.094] Current version of pixman: 0.38.4
[   109.094] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   109.094] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   109.094] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Nov 29 20:50:59 2019
[   109.094] (==) Using config file: "/etc/X11/xorg.conf"
[   109.094] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   109.094] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   109.094] (==) ServerLayout "Layout0"
[   109.094] (**) |-->Screen "Screen0" (0)
[   109.094] (**) |   |-->Monitor "Monitor0"
[   109.095] (**) |   |-->Device "Device0"
[   109.095] (**) |   |-->GPUDevice "Device0"
[   109.095] (**) |-->Input Device "Keyboard0"
[   109.095] (**) |-->Input Device "Mouse0"
[   109.095] (==) Automatically adding devices
[   109.095] (==) Automatically enabling devices
[   109.095] (==) Automatically adding GPU devices
[   109.095] (==) Automatically binding GPU devices
[   109.095] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   109.095] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/OTF".
[   109.095] 	Entry deleted from font path.
[   109.095] 	(Run 'mkfontdir' on "/usr/share/fonts/OTF").
[   109.095] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi".
[   109.095] 	Entry deleted from font path.
[   109.095] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi").
[   109.095] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi".
[   109.095] 	Entry deleted from font path.
[   109.095] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi").
[   109.095] (==) FontPath set to:
	/usr/share/fonts/misc,
	/usr/share/fonts/TTF,
	/usr/share/fonts/Type1
[   109.095] (==) ModulePath set to "/usr/lib/xorg/modules"
[   109.095] (**) Extension "Composite" is enabled
[   109.095] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   109.095] (WW) Disabling Keyboard0
[   109.095] (WW) Disabling Mouse0
[   109.095] (II) Module ABI versions:
[   109.095] 	X.Org ANSI C Emulation: 0.4
[   109.095] 	X.Org Video Driver: 24.0
[   109.095] 	X.Org XInput driver : 24.1
[   109.095] 	X.Org Server Extension : 10.0
[   109.095] (++) using VT number 8

[   109.095] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[   109.095] (II) xfree86: Adding drm device (/dev/dri/card0)
[   109.096] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/xorg/modules"
[   109.096] (**) OutputClass "nvidia" setting /dev/dri/card0 as PrimaryGPU
[   109.097] (--) PCI:*(1@0:0:0) 10de:1201:10b0:0801 rev 161, Mem @ 0xf4000000/33554432, 0xe8000000/134217728, 0xf0000000/67108864, I/O @ 0x0000e000/128, BIOS @ 0x????????/131072
[   109.097] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   109.097] (II) LoadModule: "glx"
[   109.097] (II) Loading /usr/lib/nvidia/xorg/libglx.so
[   109.100] (II) Module glx: vendor="NVIDIA Corporation"
[   109.100] 	compiled for 4.0.2, module version = 1.0.0
[   109.100] 	Module class: X.Org Server Extension
[   109.100] (II) NVIDIA GLX Module  390.132  Fri Nov  1 04:00:46 PDT 2019
[   109.100] (II) LoadModule: "nvidia"
[   109.100] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[   109.100] (II) Module nvidia: vendor="NVIDIA Corporation"
[   109.100] 	compiled for 4.0.2, module version = 1.0.0
[   109.100] 	Module class: X.Org Video Driver
[   109.100] (II) NVIDIA dlloader X Driver  390.132  Fri Nov  1 03:36:28 PDT 2019
[   109.100] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   109.110] (II) Loading sub module "fb"
[   109.110] (II) LoadModule: "fb"
[   109.111] (II) Loading /usr/lib/xorg/modules/libfb.so
[   109.111] (II) Module fb: vendor="X.Org Foundation"
[   109.111] 	compiled for 1.20.5, module version = 1.0.0
[   109.111] 	ABI class: X.Org ANSI C Emulation, version 0.4
[   109.111] (II) Loading sub module "wfb"
[   109.111] (II) LoadModule: "wfb"
[   109.111] (II) Loading /usr/lib/xorg/modules/libwfb.so
[   109.111] (II) Module wfb: vendor="X.Org Foundation"
[   109.111] 	compiled for 1.20.5, module version = 1.0.0
[   109.111] 	ABI class: X.Org ANSI C Emulation, version 0.4
[   109.111] (II) Loading sub module "ramdac"
[   109.111] (II) LoadModule: "ramdac"
[   109.111] (II) Module "ramdac" already built-in
[   109.111] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[   109.111] (==) NVIDIA(0): RGB weight 888
[   109.111] (==) NVIDIA(0): Default visual is TrueColor
[   109.111] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   109.111] (II) Applying OutputClass "nvidia" options to /dev/dri/card0
[   109.112] (**) NVIDIA(0): Option "AllowEmptyInitialConfiguration"
[   109.112] (**) NVIDIA(0): Enabling 2D acceleration
[   109.372] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[   109.372] (--) NVIDIA(0):     CRT-0
[   109.372] (--) NVIDIA(0):     CRT-1
[   109.372] (--) NVIDIA(0):     DFP-0 (boot)
[   109.372] (--) NVIDIA(0):     DFP-1
[   109.373] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 560 (GF114) at PCI:1:0:0 (GPU-0)
[   109.373] (--) NVIDIA(0): Memory: 1048576 kBytes
[   109.373] (--) NVIDIA(0): VideoBIOS: 70.24.18.00.00
[   109.373] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[   109.389] (--) NVIDIA(GPU-0): CRT-0: disconnected
[   109.389] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[   109.389] (--) NVIDIA(GPU-0): 
[   109.390] (--) NVIDIA(GPU-0): CRT-1: disconnected
[   109.390] (--) NVIDIA(GPU-0): CRT-1: 400.0 MHz maximum pixel clock
[   109.390] (--) NVIDIA(GPU-0): 
[   109.423] (--) NVIDIA(GPU-0): Acer B223W (DFP-0): connected
[   109.423] (--) NVIDIA(GPU-0): Acer B223W (DFP-0): Internal TMDS
[   109.423] (--) NVIDIA(GPU-0): Acer B223W (DFP-0): 330.0 MHz maximum pixel clock
[   109.423] (--) NVIDIA(GPU-0): 
[   109.423] (--) NVIDIA(GPU-0): DFP-1: disconnected
[   109.423] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[   109.423] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[   109.423] (--) NVIDIA(GPU-0): 
[   109.425] (==) NVIDIA(0): 
[   109.425] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[   109.425] (==) NVIDIA(0):     will be used as the requested mode.
[   109.425] (==) NVIDIA(0): 
[   109.425] (II) NVIDIA(0): Validated MetaModes:
[   109.425] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select"
[   109.425] (II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
[   109.428] (--) NVIDIA(0): DPI set to (90, 88); computed from "UseEdidDpi" X config
[   109.428] (--) NVIDIA(0):     option
[   109.429] (II) NVIDIA: Using 6144.00 MB of virtual memory for indirect memory
[   109.429] (II) NVIDIA:     access.
[   109.933] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[   109.933] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[   109.933] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[   109.933] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[   109.933] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[   109.933] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[   109.933] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[   109.933] (II) NVIDIA(0):     Config Options in the README.
[   109.946] (EE) 
Fatal server error:
[   109.946] (EE) NVIDIA: A GPU exception occurred during X server initialization(EE) 
[   109.946] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[   109.946] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   109.946] (EE) 
[   109.964] (EE) Server terminated with error (1). Closing log file.

Probably more interesting is:

journalctl --since=today

https://gofile.io/?c=Yiwvzw

I removed the graphics card and connected one monitor to the mainboard, but then X server failed to match it's configuration to the device. So I tried to reset that configuration. To no avail..

The current state. Notice the artifacts.

Most likely (from a noob perspective) this would solve the problem: 1) Remove NVidia card 2) Connect to mainboard gc 2) Re-configure X and "all that stuff". But I'm totally clueless. Would appreciate any help.
Thanks!

Nothing really happens all of a sudden.:wink:

Is it possible you had run package update during this failed session and did not reboot?

Study this and do basic troubleshooting.
It is possible that some conf files are changed from an updated package.

Post info as suggested in the tutorial.

BTW, is there an important reason you are using Mint MDM? :exploding_head:

They do with electronics when, there is a static discharge, power surge, or lighting strikes close enough to power lines leading to the house. etc.

2 Likes

Yes, AJStyle, it's 100% a failure of electronics. I removed the graphics card and made use of the onboard one, et voila.... the screens work properly during booting the OS. (Also tried M$-Windows 7 and it deployed the suitable drivers for both monitors, so I was immediately good to go on that stinking OS. So back to Linux...)

So the problem boils down to: How to properly set up your video card drivers and X Server configuration on Manjaro Linux in case you switched your video card.

(This ought to be pretty easy, right?)

I removed the NVidia driver (btw, NEVER will do NVidia again on Linux!) and installed the "most appropriate driver for my system" according to the tutorial provided by AgentS (thanks!) by:

sudo mhwd -r pci video-nvidia-390xx
sudo mhwd -a pci free 0300
mhwd --pci -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI

But then re-booting into Manjaro, X server still complains. So this is status quo. Appropriate driver installed, still blue screen - no X Server. This is /var/log/Xorg.0.log:

[   101.888] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[   101.888] 
X.Org X Server 1.20.5
X Protocol Version 11, Revision 0
[   101.888] Build Operating System: Linux Arch Linux
[   101.888] Current Operating System: Linux Panther 4.19.85-1-MANJARO #1 SMP PREEMPT Thu Nov 21 10:38:39 UTC 2019 x86_64
[   101.888] Kernel command line: BOOT_IMAGE=/vmlinuz-4.19-x86_64 root=/dev/mapper/ManjaroVG-ManjaroRoot rw cryptdevice=/dev/disk/by-uuid/29f626b8-0623-490a-ba75-d4f7a91d923f:cryptManjaro quiet
[   101.888] Build Date: 27 October 2019  08:49:23AM
[   101.888]  
[   101.888] Current version of pixman: 0.38.4
[   101.888] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   101.888] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   101.888] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Dec  2 18:25:38 2019
[   101.889] (==) Using config file: "/etc/X11/xorg.conf"
[   101.889] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   101.889] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   101.889] (==) ServerLayout "Layout0"
[   101.889] (**) |-->Screen "Screen0" (0)
[   101.889] (**) |   |-->Monitor "Monitor0"
[   101.889] (**) |   |-->Device "Device0"
[   101.889] (**) |-->Input Device "Keyboard0"
[   101.889] (**) |-->Input Device "Mouse0"
[   101.889] (==) Automatically adding devices
[   101.889] (==) Automatically enabling devices
[   101.889] (==) Automatically adding GPU devices
[   101.889] (==) Automatically binding GPU devices
[   101.889] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   101.889] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/OTF".
[   101.889] 	Entry deleted from font path.
[   101.889] 	(Run 'mkfontdir' on "/usr/share/fonts/OTF").
[   101.889] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi".
[   101.889] 	Entry deleted from font path.
[   101.889] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi").
[   101.889] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi".
[   101.889] 	Entry deleted from font path.
[   101.889] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi").
[   101.889] (==) FontPath set to:
	/usr/share/fonts/misc,
	/usr/share/fonts/TTF,
	/usr/share/fonts/Type1
[   101.889] (==) ModulePath set to "/usr/lib/xorg/modules"
[   101.889] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   101.889] (WW) Disabling Keyboard0
[   101.889] (WW) Disabling Mouse0
[   101.889] (II) Module ABI versions:
[   101.889] 	X.Org ANSI C Emulation: 0.4
[   101.889] 	X.Org Video Driver: 24.0
[   101.889] 	X.Org XInput driver : 24.1
[   101.889] 	X.Org Server Extension : 10.0
[   101.890] (++) using VT number 7

[   101.890] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[   101.890] (II) xfree86: Adding drm device (/dev/dri/card0)
[   101.902] (--) PCI:*(0@0:2:0) 8086:0412:1849:0412 rev 6, Mem @ 0xf0000000/4194304, 0xe0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[   101.902] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   101.902] (II) LoadModule: "glx"
[   101.902] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   101.904] (II) Module glx: vendor="X.Org Foundation"
[   101.904] 	compiled for 1.20.5, module version = 1.0.0
[   101.904] 	ABI class: X.Org Server Extension, version 10.0
[   101.904] (II) LoadModule: "nvidia"
[   101.904] (WW) Warning, couldn't open module nvidia
[   101.904] (EE) Failed to load module "nvidia" (module does not exist, 0)
[   101.904] (EE) No drivers available.
[   101.904] (EE) 
Fatal server error:
[   101.904] (EE) no screens found(EE) 
[   101.904] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[   101.904] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   101.904] (EE) 
[   101.904] (EE) Server terminated with error (1). Closing log file.

"No screens found." Eerr, what? Where to go next? There is now a basic (non-fancy) monitor via VGA attached to the desktop PC. A pro should handle this like in 5 minutes as it is a pretty standard use case. But I am clueless.

It says:

   101.904] (EE) Failed to load module "nvidia" (module does not exist, 0)

I thought that driver was removed. Module? How to remove that? Sorry for being an admin noob.

Although not particularly helpful, I've had the same issue since Friday's pacman -syyu.

1080 Ti here and my Windows runs just fine still, with no changes in hardware.

As far as I'm concerned something broke but whatever that is, it's not the actual hardware - not in my case anyway.

Couldn't find a solution as of yet and just run an update a day hoping it'll fix itself until I cave and reinstall, should it come down to it.

Derp, I'll try to do an update as well. But I guess, this won't solve configuration issues.

Adding to my post 10 minutes ago, I found (one? of) the culprits: /etc/X11/xorg.conf still tries to load module "nvidia".

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 390.132  (buildmeister@swio-display-x64-rhel04-14)  Fri Nov  1 05:15:46 PDT 2019

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/mouse"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

I don't know in which way to alter this.

And as a final note.

sudo X -configure

X.Org X Server 1.20.5
X Protocol Version 11, Revision 0
Build Operating System: Linux Arch Linux
Current Operating System: Linux Panther 4.19.85-1-MANJARO #1 SMP PREEMPT Thu Nov 21 10:38:39 UTC 2019 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-4.19-x86_64 root=/dev/mapper/ManjaroVG-ManjaroRoot rw cryptdevice=/dev/disk/by-uuid/29f626b8-0623-490a-ba75-d4f7a91d923f:cryptManjaro quiet
Build Date: 27 October 2019  08:49:23AM
 
Current version of pixman: 0.38.4
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Dec  2 19:12:23 2019
List of video drivers:
	amdgpu
	ati
	intel
	nouveau
	qxl
	radeon
	spiceqxl
	modesetting
(++) Using config file: "/root/xorg.conf.new"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"


Xorg detected your mouse at device /dev/input/mice.
Please check your config if the mouse is still not
operational, as by default Xorg tries to autodetect
the protocol.

Your xorg.conf file is /root/xorg.conf.new

To test the server, run 'X -config /root/xorg.conf.new'

(EE) Server terminated with error (2). Closing log file.

SOLVED it by removing the Xorg conf file. (In my case catiously renaming it.):

sudo mv /etc/X11/xorg.conf /etc/X11/OLD-xorg.conf

Now, after booting, X server and mdm come up, I log in, everything is just as it was. One exception though: There is NO new file /etc/X11/xorg.conf. So I GUESS, the needed data is assembled during boot, slowing down the overall process. A decent xorg.conf file is still needed, I guess (as a noob) to orderly boot. I am hesitant to mark this as solved unless this is properly adressed (by me, or even better a pro from the com).

Anyway, hope this thread has some merits and so far I am happy.

As a last step I finally created a new xorg.conf. CAUTION to users in search for answers: I don't have a clue what I actually did here, but it worked for me.

Summary:

The problem: You want to update your video card driver and X server conf file (maybe because your video card stopped working and you revert to the main board).

Solution(?):

  1. Remove your video card. (M$-Windows is fine from this moment. You're done there. Manjaro and all other distros, I guess, need work!)
  2. List all installed video card drivers.
  3. Remove driver of your now removed card.
  4. Install recommended driver (this one is selected automatically for you).
  5. Remove xorg.conf file.
  6. Reboot for testing.
  7. If X server and display manager (Login) come up, log out, stop X server and create a new xorg.conf file.
  8. Reboot for testing.

Things could still be messed up / need fine tuning. But I learned, Arch/Manjaro (or all GNU/Linuxes) to be very forgiving, means I don't catch it at all. I guess, journalctl is your friend now (and then two nights shifts plus a fridge with beer) to properly tidy your system.

The commands (prefixing numbers refer to the list above):

(2) mhwd --pci -li
(3) sudo mhwd -r pci video-nvidia-390xx
(4) sudo mhwd -a pci free 0300
(5) sudo rm /etc/X11/xorg.conf
(7) sudo systemctl stop mdm (ALSO THIS (mdm) WILL MOST LIKELY DIFFER FROM YOUR SETUP)
sudo X -configure (THIS CREATED A NEW xorg.conf.new)
sudo cp /root/xorg.conf.new /etc/X11/xorg.conf

Cheers!

EDIT: I'd like to again mention this excellent tutorial hinted by AgentS -> How to change video drivers or configuration and troubleshoot

1 Like

It's fair. But why give an advise to others when you don't have a clue???????
Keep this a personal secret, it's called experience. But it's not knowledge.
When you read some docs and improve your knowledge, you will succesfuly write Forum Tutorials! :wink:

In Arch/Manjaro we don't use /etc/X11/xorg.conf. When it exists, it may conflict with normal configuration at /etc/X11/xorg.conf.d/*.conf, so we delete it.
Keep the active xorg.conf here /etc/X11/xorg.conf.d/*.conf, when you create it manually.
But... when using mhwd, any required conf file will be auto-created properly.
Of course, it happens to something needs change. Then we modify existing files, so we don't mess thing up.

How do you know the electronics (hardware) failed? Maybe the drivers were mis-configured... all of a sudden :rofl:

Have fun!

@AgentS To close this:

  1. Screen during boot showed distortions, Screen while having M$-Windows booted showed distortions, once switched to mainboard video card - no friction at all: Hence, electronic issue of the video card!

  2. I hereby officially label my summary "experience report". Fine? Good.
    (Btw, I took the liberty to do so, bc the pros were a bit silent on this thread.)

  3. If Manjaro does not make use of

/etc/X11/xorg.conf

as you claim, why does it may conflict the system? Sounds like a very special feature if not outright bug. Secondly, as an overall remark to the maintainers of Manjaro: On the website you kind of sell Manjaro as a distro for the end user (means OS-noobs), but switching the video card is a basic use case and here the handling (DIY) and documentation on it is poor (or hard to find). Period. Aside from this, I love the distro and truly appreciate your work!!

Wish all of you a splendid rest of 2019.
So here comes AgentS once again...

Thanks for this, as this seems to also resolved my issue(s), though I still don't know the details.

This is the variant I had to dial in:

(1) mhwd --pci -li
(2) sudo mhwd -r pci linux-video (or video-linux?)
(3) sudo mhwd -a pci nonfree 0300

Though mhwd --pci -l listed a bunch of item (a total 5 or 6 entries, 4 of which belonged to different Nvidia drivers) I couldn't uninstall any of them with the exception of linux-video. I suspect that maybe Noveau got installed unintentionally in my case?

@AgentS - I, too, referenced your guide but came across one 'mistake'.

Your guide states:

mhwd -a pci non-free 0300

but I actually had to type

mhwd -a pci nonfree 0300

instead before the command executed properly.

Cheers everyone.

You never reported this, although it is critical information.

You've PRO response from the beginning.

Long story... What is certain is that Manjaro has a specific utility to handle video drivers, which is very easy and highly reliable in the majority of cases. This utility (mhwd) and all of the Manjaro installers NEVER install /etc/X11/xorg.conf, which means someone else installed that file, having physical access to your PC, or ... hacked it. :man_shrugging:

Apart from the Manjaro User's Guide, Manjaro Wiki, Manjaro Forum Tutorials and simple forum search, you are absolutely right, it is difficult for you to find Documentation. You might want to open a Feature Request for that.

Forum kindly sponsored by