Wxpython2.8 build problem

Apparently I need to have wxpython2.8 for some software I want to install.
Following yay guidance I typed:
yay -S wxpython2.8
All seemed to be going well until the scrolling stuff in the terminal stopped and the following appeared:

In file included from src/helpers.cpp:16:
include/wx/wxPython/wxPython_int.h:19:10: fatal error: wx/wx.h: No such file or directory
 #include <wx/wx.h>
          ^~~~~~~~~
compilation terminated.
error: command 'gcc' failed with exit status 1
==> ERROR: A failure occurred in build().
    Aborting...
Error making: wxpython2.8

What should I do next? I’ve searched ‘wxpython2.8’ but haven’t found any clues.
Thanks.

yes is in comments and not fixed by maintainer since 2 months :roll_eyes:

It looks like it is missing a dependency. I installed wxgtk2 first and it built successfully.

2 Likes

Many thanks dalto … that’s worked. :slightly_smiling_face:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by