Wrong time in Manjaro XFCE, 2 hours forward, had to work with ntpd

Hello, in the bottom taskbar, tray area is clock, i can set timezone there. First i set UTC+x as it shown wrong time and it adjusted the time, thought some website complains i have wrong time and also there is no such option as UTC+1, UTC+2, only plain UTC. When i set CET as it should be it shown the time 2 hours forward.
I also tried “timedatectl” it shows time zone and city correctly but shows time that is two hours forward :-/

$ systemctl status ntpd
ntpd.service - Network Time Service
Loaded: loaded (/usr/lib/systemd/system/ntpd.service; disabled; vendor preset: disabled)
Active: inactive (dead)

$ systemctl start ntpd
Job for ntpd.service failed because the control process exited with error code.
See “systemctl status ntpd.service” and “journalctl -xe” for details.

$ journalctl -xe

Then it somehow started: $ systemctl start ntpd
After a while i have seen correct time, maybe need to open new terminal window.

So i enabled ntpd at boot (hopefully): systemctl enable ntpd
Maybe it is bad approach and only need to do “timedatectl set-ntp true” i do not know.

I do not know why i need to go through this, i think it should be done and sync. by default so it is user friendly.

Just a question, are you using Dual boot with Windows?

If you are dual-booting Windows / Manjaro - the recommended solution is described in this article.

1 Like

the drive was formatted and created new partition table with /boot and / ext4, both encrypted. So no dual boot…

make sure

timedatectl status

shows the correct timezone. Also your RTC should be configured to use UTC.

I would not recommend to use ntpd. Stop it, disable it, remove it.

You can use systemd-timesyncd. You need to start and enable the service

systemctl enable --now systemd-timesyncd.service


timedatectl set-ntp true

But it is very important that the timedatectl settings are correct (timezone, RTC status).


Please, mark that as solution.

This works. My clock was two minutes ahead and this fixed it.

Suggestion: add an option on the forum to (vote as solution) this would help a lot, there must be some plugin/extension for the current software that runs this forum.