Wrong time after going offline

Every time I go offline or turn off the machine, I get wrong timee on gnome bar, changing my location time fix it, but it’s annoying to do it every time.
I have a starlabs mkiii laptop with coreboot, running manjaro with gnome.

Check BIOS settings for the correct time, so it will not reset. Also you can enable ntpd.srvice


maybe that’s my problem my current firmware the starlabs version 6 has a very basic BIOS and no option about time there, how do I activate the ntpd.srvice?

systemctl enable ntpd.srvice --now

so you will see the effect of it right away.

got this output:
Failed to enable unit: Unit file ntpd.srvice.service does not exist.

Well, try this then

1 Like

I got no error with those commands, I let you know if it worked well on next reboots, thanks!

1 Like

Usually, systemd’s timesyncd is already enabled and running. There is no need to use ntpd in parallel.

1 Like

Solution removed, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.