Wrong PIN on Pinephone

I have the same issue.
I just got my Pinephone with Manjaro Plasma Beta edition stable, and at first it worked well, but then when I did some updates via Discover, (and also changed my user password via user ‘kde’) I cannot login to the phone anymore. When I type the PIN number, it keeps saying ‘Wrong PIN’. I know it is the right PIN number because I set it when I received the phone and I used it for about 2 weeks. I there something I can do?

The PIN you need in the lockscreen is the one belonging to the user you created during the Setup Wizard.

The Setup Wizard creates a new user for you, with that PIN and uses that as login on future boots.

The kde user is no longer used.

thank you Strit,
I understand this, and I had chosen a PIN number (easy to remember) during the setup wizard. But now this PIN number is somewhat not recognized anymore (probably due to a bug), so I’m locked out of my phone.

What did you exactly do here?

You cannot change the PIN for kde user via the GUI.

hi, I changed my user password, not the PIN. The initial problem I had was that I had forgotten my sudo password for the user that I created. So I needed to have superuser privilege in order to change my user password. But I did not want to use ‘su root’ (I learned it is a bad habit), so I think I remember I used the user kde with its password (123456): as su kde . Then I did passwd my_user_name , and su my_user_name . And after that, I got this screen-lock PIN error. I have to mention that I did not install a SIM card in the phone. Other suggestions? Should I try to flash the OS? I’m not familiar with flashing, but I’m learning.

And you are certain your new “password” only contains numbers?

The sudo password for a user, is always that users normal password.

Actually it contains only lowercase letters. Is it not allowed? It is easier to remember. On other Linux distros, I always use letters

Well, you can’t really input letters in the lockscreen on the phone, yet…

So user password has to be numbers only.,

ok, I understand. I thought that the PIN number and the user password were two different things. Any suggestions?

Yeah, change your user password to numbers only, using the same method as you changed it to letters in the first place.

thank you, but can I type my PIN (which is lowercase letters)?, since you say It wont accept letters. So what can I do?

That makes it way more difficult though. But you have 2 options.

  1. Get a USB-C dock + keyboard and do it from TTY
  2. Connect to the phone using SSH, if it has Wifi connection

The second one is less time consuming and easier. So it’s preferred.

thank you Strit, yes it has wifi. Im not familiar with connecting to a phone from another computer, can you please explain it briefly? what is the ip address I should enter in ssh?

You can check this from your routers DHCP settings/lists.

To connect via SSH, you need to know the username (could be the kde user, if thats easier), password of that user and the IP address of the device.

Run this in a terminal on another linux PC to connect to the phone:

ssh <username>@<ip of phone>

Type in the users password when it asks and press enter.
Now you are in the phone’s terminal and can run terminal commands to change your users password.

thank you Strit, I will try it next week, as I don’t have my phone with me now. I appreciate the help

I tried to ssh to the pinephone from a macbook Air (connected to wifi with router adress running Ubuntu in a virtual machine (VirtualBox) with ssh kde@ , and I get an error ssh: connect to host port 22: Connection refused
I searched this error with a web browser, and found this related post (trying to connect to a Rasberry Pi phone): ssh - connect to host port 22: Connection refused - Raspberry Pi Stack Exchange
According to this post, the SD card needs to be written on directly with a ‘reader’ (SD card reader?), but I don’t have an SD card reader.
Other suggestions? maybe option (1) you proposed earlier, I have a USB 3.0 dock , but it is for regular computers, is it different from ‘USB-C dock’? Also, what does ‘TTY’ mean? thank you @Strit

Hey @keith1,

The IP-address of your router is, so when you issue the command ssh kde@ you’re actually trying to connect to your router instead of the Pinephone. That’s probably not what you want :slight_smile:

The phone likely has an IP address starting with 172.30.1. as well, ending in a different number (one between 0 and 253). You can find out which IP address the phone has by logging in to your router. You can probably do this simply by surfing to it at You’ll likely need to enter an (admin) user and password which you can find on the physical router itself or in the documentation that you received with it. Once logged in, search for a list of connected devices and look for a device with the name ‘manjaro-arm’ or similar. The IP address of the phone should be listed there as well.

Once you have obtained the phone’s IP address type ssh kde@<IP address>, as Strit suggested. If it doesn’t work and you’re sure the IP address is correct, the username could also be ‘manjaro’.

Good luck!

Unfortunately sshd isn’t enabled by default in PinePhone. You need to manually start/enable it.

Hey @p1x3l3d and @SameExpert , thanks for the advice. I’ll try, It might not work, but anyway, I’m learning something :slight_smile:


I have set up my Pine Phone for the first time. It prompted me for a password but not a PIN. It produced an error message and went black after I completed set up. I had to restart the phone, and when I did it prompted me for a PIN. I never created a PIN, because I was never prompted to do so, and now I cannot access my phone without one. Any thoughts on this?