WritingSpeed to NTFS Partition decreases

Good evening!

I do have a new lenovo V17 IIL with fresh installed Manjaro XFCE. The Laptop has one SSD and a 1TB HDD.
We installed a WD MyCloud EX2 Ultra in the network.
I’m now trying to copy about 200GB pictures from the NAS to the HDD. It always starts with speeds around 59MiB/s but then decreases to about 5 MiB/s.
When I try to copy to the SSD, this behaviour is not happening.

How can I find out, what is happenign here and why?

Thank You!

Your HDD could be failing. Check SMART data and do benchmark speed on it to see if HDD itself isn’t the bottleneck.

Output of

sudo smartctl -a /dev/sda


smartctl 7.1 2019-12-30 r5022 [x86_64-linux-5.9.11-3-MANJARO] (local build)
Copyright (C) 2002-19, Bruce Allen, Christian Franke, www.smartmontools.org

Device Model:     TOSHIBA MQ04ABF100
Serial Number:    90H1P4EET
LU WWN Device Id: 5 000039 a42188b34
Firmware Version: JU0A0E
User Capacity: bytes [1,00 TB]
Sector Sizes:     512 bytes logical, 4096 bytes physical
Rotation Rate:    5400 rpm
Form Factor:      2.5 inches
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   ACS-3 T13/2161-D revision 5
SATA Version is:  SATA 3.3, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Sun Dec 27 18:32:27 2020 CET
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x80)	Offline data collection activity
					was never started.
					Auto Offline Data Collection: Enabled.
Self-test execution status:      (   0)	The previous self-test routine completed
					without error or no self-test has ever 
					been run.
Total time to complete Offline 
data collection: 		(  120) seconds.
Offline data collection
capabilities: 			 (0x5b) SMART execute Offline immediate.
					Auto Offline data collection on/off support.
					Suspend Offline collection upon new
					Offline surface scan supported.
					Self-test supported.
					No Conveyance Self-test supported.
					Selective Self-test supported.
SMART capabilities:            (0x0003)	Saves SMART data before entering
					power-saving mode.
					Supports SMART auto save timer.
Error logging capability:        (0x01)	Error logging supported.
					General Purpose Logging supported.
Short self-test routine 
recommended polling time: 	 (   2) minutes.
Extended self-test routine
recommended polling time: 	 ( 172) minutes.
SCT capabilities: 	       (0x003d)	SCT Status supported.
					SCT Error Recovery Control supported.
					SCT Feature Control supported.
					SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
  1 Raw_Read_Error_Rate     0x000b   100   100   050    Pre-fail  Always       -       0
  2 Throughput_Performance  0x0005   100   100   050    Pre-fail  Offline      -       0
  3 Spin_Up_Time            0x0027   100   100   001    Pre-fail  Always       -       1282
  4 Start_Stop_Count        0x0032   100   100   000    Old_age   Always       -       74
  5 Reallocated_Sector_Ct   0x0033   100   100   010    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000b   100   100   050    Pre-fail  Always       -       0
  8 Seek_Time_Performance   0x0005   100   100   050    Pre-fail  Offline      -       0
  9 Power_On_Hours          0x0032   100   100   000    Old_age   Always       -       18
 10 Spin_Retry_Count        0x0033   101   100   030    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   100   100   000    Old_age   Always       -       71
191 G-Sense_Error_Rate      0x0032   100   100   000    Old_age   Always       -       3
192 Power-Off_Retract_Count 0x0032   100   100   000    Old_age   Always       -       11
193 Load_Cycle_Count        0x0032   100   100   000    Old_age   Always       -       248
194 Temperature_Celsius     0x0022   100   100   000    Old_age   Always       -       38 (Min/Max 18/40)
196 Reallocated_Event_Count 0x0032   100   100   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0032   100   100   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0030   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x0032   200   253   000    Old_age   Always       -       0
206 Flying_Height           0x0020   100   100   000    Old_age   Offline      -       17043
220 Disk_Shift              0x0002   100   100   000    Old_age   Always       -       0
222 Loaded_Hours            0x0032   100   100   000    Old_age   Always       -       8
223 Load_Retry_Count        0x0032   100   100   000    Old_age   Always       -       0
224 Load_Friction           0x0022   100   100   000    Old_age   Always       -       0
226 Load-in_Time            0x0026   100   100   000    Old_age   Always       -       175
240 Head_Flying_Hours       0x0001   100   100   001    Pre-fail  Offline      -       0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
No self-tests have been logged.  [To run self-tests, use: smartctl -t]

SMART Selective self-test log data structure revision number 1
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

I will do the benchmark right now.

But I experienced some other errors now… The Laptop doesn’t have a Ethernet port so I bought a USB to Ethernet Adapter which works out of the box. But from time to time it seems that I loose Internet connection, so I cant open any websites and also ping google.com fails. But the Internet Icon in the manjaro bar says that I am connected. I then entered the Wifi and unplugged the ethernet from the adapter but this freezes everything but the mouse. Only 5sec shutdown helped…
I have no Idea if all this has to do with the same problem but because it is also something about ethernet i thought it could be interesting.

Here is the result of a KDiskMark run:


Again some news:

I tried to copy the data while not being connected via ethernet but wifi.
The speed kept up for about 12Gigabytes. Then I opened firefox and after coming back to the status window after a few seconds the speed started to slowly decrease. I don’t know, if this had anything to do with each other or was just random.
I than wanted to reboot, but the laptop didn’t shut down completely. I just stuck at a display showing “lenovo-logo” and stuck there.
Now after a hard shut down and a new boot manjaro doesn’t want to mount the partition anymore. In Gparted I get this information:

I did the

chkdsk D: /f

in Windows, but it says, that there are no Problems and it will not do any actions.
But I can now mount the partition again. The Copy problem is still there

NTFS is an (old) Windows filesystem and not a great choice performance wise. It’s also not native on linux.
Try using exFat if you want to have a partition readable both from windows and linux.

Same issue with exFat.

I Think it has something to do with the usb to ethernet. There is a topic about issues very similar to mine right now

I now tried to copy a folder with 80GB of data in it from hdd to ssd and then the other way round. Here the speed-drop also happens, so it should be a problem with the laptop, not the Ethernet adapter.

What’s the average speed of copying of 80GB data back and forth?
You gave us results of HDD SMART and benchmark data, can you repeat the same with SSD?
Also I’d try to use Linux native filesystem, NTFS in Linux in its current state is bottlenecked by CPU, have a look at CPU usage when you are copying files it’s pinning one core of your CPU and that’swhy performance is so poor.