WPS Office nie chce się zaktualizować

#1

Witam,
mam problem przy próbie aktualizacji WPS Office otrzymuję taki komunikat:
Synchronizacja baz danych pakietów...
Rozpoczęcie pełnej aktualizacji systemu...
Kopiowanie wps-office plików kompilacji...
Sprawdzanie wps-office zależności...
Budowanie wps-office...
==> Tworzenie pakietu: wps-office 11.1.0.8392-1 (śro, 17 kwi 2019, 22:42:08)
==> Sprawdzanie zależności potrzebnych do uruchomienia...
==> Sprawdzanie zależności potrzebnych do budowy...
==> Pobieranie źródeł...
-> Znaleziono wps-office_11.1.0.8392_amd64.deb
-> Znaleziono add_no_kdialog_variable.patch
==> Sprawdzanie plików source_x86_64 za pomocą sha1sums...
wps-office_11.1.0.8392_amd64.deb ... NIE ZGADZA SIĘ
add_no_kdialog_variable.patch ... Zgadza się
==> BŁĄD: Przynajmniej jeden plik nie jest poprawny!

Co z tym zrobić?

#2

To pakiet AUR? Pewnie źle zaktualizowany PKGBUILD.

Możesz:

  1. Zgłosić na stronie pakietu ten problem i czekać aż package maintainer to poprawi
  2. Sprawdzić na stronie źródła plik i jego sumę i zaktualizować sobie w PKGBUILD
  3. Na ryzyk-fizyk podmienić sumę słówek "skip" bez cudzysłowów i wtedy ominie sprawdzanie sumy.

W praktyce jak nie jesteś obeznany z PKGBUILD to możesz mieć problem, żeby zmienić PKGBUILD, żeby instalacja przebiegła poprawnie (mimo że idea jest prosta, ale czasem trzeba to wpisać w odpowiednim miejscu, formacie, z odpowiednimi znakami...), możesz nie mieć konta na AUR (trzeba się zarejestrować), albo możesz nie wiedzieć jak sprawdzić poprawną sumę, albo nie wiesz jak się edytuje PKGBUILD lub instaluje za jego pomocą bez pomocnika AUR.

Każdy z tych tematów to na dłuższą pogawędkę, ale w sumie można to obczaić wyszukując informacje w sieci lub czytając arch wiki.

Ja zwykle poszedłbym na łatwiznę i sprawdził czy link prowadzi do dobrego pliku i jeśli tak, dodałbym ten parametr SKIP... nie powinno się tak robić, ale w praktyce dużo osób tego używa :wink: .