Workspace Menu Items not quite right

How can I fix this issue, when I hit the super key, the workspaces up the top don’t line up how they are supposed to?

The issue is fixed with gnome-shell-extensions 41.1-1 which is available in the testing and unstable branches. You can either switch branches or disable the Native Window Placement extension for now.

I just installed the unstable branch and it didn’t seem to fix it

Did you restart GNOME Shell or log out / login after?