Workplace wifi connects but doesnt have any internet, can only open its own login page

Whenever I connect to my workplace’s wifi, it connects but doesn;t have any internet, and it can only open the organizations login page, and even after I login, it doesn’t work. Google chrome shows err_name_not_resolved , I tried changing DNS servers, it doesnt work. I tried same thing in Windows 10, and it worked.

Also I can use internet, if I connect my wifi to mobile hotspot.


Try this:

$ ping -c 4
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=118 time=10.7 ms
64 bytes from icmp_seq=2 ttl=118 time=15.2 ms
64 bytes from icmp_seq=3 ttl=118 time=10.7 ms
64 bytes from icmp_seq=4 ttl=118 time=10.1 ms

--- ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3006ms
rtt min/avg/max/mdev = 10.141/11.686/15.202/2.042 ms

No DNS lookup is required for this test to work. If it fails, you have no working routing to the internet, and the problem is with how your workplace configures their network. If the test works, you may be able to use a work-around for specific internet destinations by using the hosts file.

It is working, so please tell the workaround

1 packet received of 4 sent is a very bad result, but the sample size was small. Try ping -c 1000 for a larger sample size. If you have a high packet loss then there is a serious hardware or network issue that you must fix before you can work with internet resources.

The DNS work around is to resolve specific domain names to IP addresses.using entries in the /etchosts file. If you need help with that you can find many resources on the internet.This solution is good if you can get by with only a small number of internet destinations. Fixing how DNS resolves domain names is a much better solution.

1 Like

Can you please elaborate on this line, how to do that since above u mentioned fixing to resolve specific domain names, and I want in general all domain names.

If you do not have a good connection as per the test I described, nothing else matters: you will not have a good experience with the internet even if you get DNS working. If you are using NetworkManager, the command nmcli will list your DNS configuration. If the server(s) listed are your company servers, then your company is probably blocking DNS resolution outside your company network. If you “fix” your RPi to use a DNS server outside your company network, such as 8,8,8,8, you will probably lose access to your company DNS assignments. A configuration to use servers assigned via /etc/resolv.conf will not work unless you also prevent NetworkManager from overwriting /etc/resolv.conf. I don’t have the exact commands handy to do that, you will have to research it. Or perhaps someone else can add to this thread.

I did cleared all the entries in the etc/hosts file, and it worked! Thanks!

For other users reading this, please take a backup of your hosts file before deleting its contents. Since this solution may work or not for you.

You should leave the localhost localhost.localdomain line in the file.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.