With multiple monitors Plasma sorts desktops wrong (sometimes)

i have a minor bug, but very annoying. I use three screens, Full HD resolution

After a coldboot my screen sorting order is “often” wrong. Center screen is left, left is center etc.
But it can be ok sometimes, so thats …
To fix that i restart plasma, that works every time.
Can anyone plz tell me, what i have to check|change to stop that ?

System:    Host: akela Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.20.4 Distro: Manjaro Linux 
Graphics:  Device-1: NVIDIA TU106 [GeForce RTX 2070] driver: nvidia v: 450.80.02 
Display: x11 server: X.Org 1.20.10 driver: nvidia resolution: 1: 1920x1080~60Hz 2: 1920x1080~60Hz 3: 1920x1080~60Hz 
 OpenGL: renderer: GeForce RTX 2070/PCIe/SSE2 v: 4.6.0 NVIDIA 450.80.02


Create a fixed layout from Nvidia X Server Settings and append the modified lines in /etc/X11/mhwd.d/nvidia.conf file. Make use of the Preview of the file to copy that content. Make sure to create a backup of the original file. Next reboot should respect that layout and then you can compare and change also in System Settings > Display … to match the nvidia.conf layout.

If unsure, share the original and the one you created from Preview and we start from there.
Use ``` above and bellow each output, so we have proper formatting text.

Will edit your inxi part on your comment, so you will have an example.

Thx for answering. I am a bit lost.
Do you mean i have to overwrite the nvidia.conf file with the file/values generated by nvidiasettings ?

Systemsettings is matching already

By default the nvidia.conf is using configs for dynamic layout. What i said is that YOU make a fixed one manually with nvidiasettings. That indeed supposes to overwrite the nvidia.conf.

No … Please start with the nvidia.conf then check the match … because if was ok already, then you would not have at all

Ok, Christmas is over, i made what you suggested. First try with overwriting the whole file nvidia.conf was ending up in a black screen, so i expanded the file with the additional or changed lines from nvidiasettings-preview.
That is working, at the first boot the screen order is correct. I do some reboots before i consider this as solved :wink:
The display systemsettings is and was matching the nvidia settings (screen order, resolution) , so i do not really understand what to check there

Thx :crossed_fingers:

Is this problem only happening if nvidia driver is used ? because from a user standpoint, this shouldn’t happen at all

From BIOS post to GRUB the dGPU aka PEG aka PCIE will have a order to activate the ports like this VGA>DVI-I>DVI-D>HDMI>Displayport
You can’t change that from BIOS.

Once the Kernel loads at boot, the xorg.conf (and in Manjaro case is /etc/X11/mhwd.d/nvidia.conf ) kicks in. In a dynamic layout, aka the default config, it will respect the priority set by BIOS, but sometimes a port is activated first, hence the order will not be consistent and that can happen random due to xorg. In a static layout it will overwrite to what is specified in "nvidiaXineramaInfoOrder" so it will stick to it.

The next one is xrandr that establishes the order and layout.

The last is the DE Display Settings that establishes the layout and priority, aka primary display.
Only a fixed layout gives always the same order and arrangement.

In a perfect world maybe … :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.