Wireless driver not found

Recently I occurred a problem in manjaro. I’ve two hard disk in my pc, one has manjaro and the second has windows 10. Every time i use windows for playing and then, i reboot on manjaro, my wireless device stop working because of absence of driver. If i reboot manjaro at least three times drivers start to work.

How can i fix that? Can be a problem of the new kernel 5.9.1? (With kernel 5.6 i think there wasn’t this problem)

I tried to reinstall driver iwlwifi-8265 but didn’t work

Hi akeMattu - welcome to the forum
If a previous kernel is more reliable, there’s nothing wrong to use it.
Though, be careful not to use on that is already EOL.
Rather stick to the latest LTS e.g. 5.4.

That sounds like my experience, too, akeMattu

Flawless Intel wifi performance for many kernels right up until 5.8 when it broke.
I don’t boot to Windows much anymore, so that is not an issue.
I have kernel 5.9 installed … 5.9.1 did not work … I have not tried 5.9.3 yet.
I will try your tactic of rebooting three times and see if I can get it to work.

5.4 LTS is an option, but there have been so many updates to AMD Ryzen CPUs I hate to be locked out of 5.9 plus.

Good luck to you.