Wireless adapter not detected

Hello, I’m trying to dual boot manjaro and windows on my laptop. But the live environment is not detecting wifi adapter.
Wifi is working properly on Windows but not on Linux.

I also tried arch linux but iwctl list does not contain wifi adapter.

checked rfkill but it is neither hard nor soft blocked.

How do I fix this?

  1. Check the chipID (e.g. 10ec:8168): inxi -Nazy
  2. Search the chipID: Find parts
    explanation: vendorID:deviceID
  3. Check the AUR if it is available: AUR (en) - Packages
  4. Install it: pamac build aur-pkg-git
  5. Keep sure the headers are installed. For linux 5.10 for example: pamac install linux510-headers

Anything unclear?

Also, if you are dual booting Windows, make sure Windows is always completely shutdown. Disable fastboot, hybrid sleep and hibernation on Windows side.


Thanks for the reply.
I tried searching with the chip ID. But I’m a bit confused. What type should I select. And there is no name on the inxi -Nazy output

  Device-1: Broadcom BCM43142 802.11b/g/n
  vendor: Dell Wireless 1704 802.11n + BT 4.0 driver: bcma-pci-bridge v: N/A
  modules: bcma bus-ID: 06:00.0 chip-ID: 14e4:4365 class-ID: 0280
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
  driver: r8169 v: kernel port: e000 bus-ID: 07:00.0 chip-ID: 10ec:8136
  class-ID: 0200

Here is the output if it helps

Ah well Broadcom is another story… as you see here Broadcom BCM43142 802.11b/g/n there are free, but reversed-engineered drivers in the kernel included, but they do not work very well on modern chips. You need the wl module.

sudo mhwd --install pci network-broadcom-wl

If the live reload of the module does not work properly, then do a restart and check again which driver you are running and if it works.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.