Wireguard won't connect from one machine but will from another

I’ve set up a wireguard peer to connect to my raspberry pi at home, but it can’t ping any machine on my local network, not even the wireguard peer. It may not even be connected, when it claims it is. I have a second client that has absolutely no issues.

Here is my interface configuration, which is the same as the config file my client install script spit out:

Here is my interface configuration

This closely corresponds to the configuration used on my other client, other than the private and preshared key being different.

The client is, as far as I can tell, correctly set up on the server side, as seen in my /etc/wireguard/wg0.conf file.

Whenever I enable tun0, I’m unable to ping any local address, including the other end of the wireguard tunnel.

What could possibly be going on here?

I’m still having this issue. Can anyone help me?

You could try swapping the configuration of the two clients

I tried that. Unfortunately it doesn’t work. The non-working machine still doesn’t work.

So the “bad” configuration is suddenly working when copied to the “good” computer ? :man_shrugging:
Then there has to be something on the “bad” computer that prevents it from working.

  • special firewall ?
  • special routing ?
  • special programs regulating network traffic ?