Wireguard - No connection possible on Manjaro


I have installed a Wireguard server on my Raspberry Pi 4 using PiVPN. I can connect to it from my Android phone and my Windows notebook without any problems. At the moment it doesn’t work on Manjaro at all, although it worked some time ago. I have tried importing it in the KDE network manager, by importing it with nmcli and by setting it up with wg-quick.
According to KDE it connects to the VPN, because the VPN appears below the connected wifi and there is also a lock at the wifi symbol.
When I run pivpn -c on the wireguard server after “connecting” to it, I can see that there has been no connection set up to the VPN server.
I have also installed new kernels, updated the system, reinstalled wireguard-tools couple of times but nothing could solve the problem. I have tried lots of solutions from the internet and NONE of them worked!

Next week I won’t be home for some days and want to connect to my VPN. So does anybody know what might cause the problem?

Go over these search results to learn how to configure wireguard on Manjaro

It seems like my mistake was to connect to the VPN from inside my LAN. When I’m connecting to it from another wifi, it works.
But thank you anyway!