Wire shark issues after install(Fixed)


#1

Super noob here I finished my install but when i try to run wire shark i get these errors. I not sure how to fix these. Any info would be appreciated!


https://imgur.com/a/1DFGp1


#2

You’ll need to add your user in the “wireshark” group in order to use it as a normal user.

You may do it within a GUI user configuration tool (Manjaro Settings Manager may be used to add a user to a group) or with the following command: sudo gpasswd -a USERNAME wireshark . You’ll need to log out and log in again if you’re adding the current user to the “wireshark” group.

The required group should be automatically created at installation.

https://wiki.archlinux.org/index.php/Wireshark#Capturing_as_normal_user


#3

When you launch wireshark, does it ask for your password? I believe you need root access to put the network card into promiscuous mode. If it doesn’t ask for a password, from a terminal try running:

gksu wireshark

or

gksu wireshark-gtk

#4

I ran the command and added my user but I still get the same 2 errors popping up. Ill keep hunting around see if i cant for some more info. Thanks you for the help


#5

The gksu commands don’t seem to work for me. I’m running Manjaro if that helps any.
Thanks for the help aswell :slight_smile:


#6

Did you log off after adding your user to the group? The system will only take your new group into account at next login.

I forgot to add this pretty important detail when I first wrote my answer and maybe added it too late. My bad.


#7

You’re solid I will give that a try to and come back ^^ !!


#8

It works all I needed was that reset!! Thanks a ton!!!


#9

i would hope so