Wine Submenu Missing or Empty

I was missing my wine submenu in the whisker menu. I was able to sort’ve get it using the wine-installer package from AUR, but it doesn’t actually retrieve my installed wine programs, so I’m just left with having to manually go to my installed software to use it which is annoying. I had installed wine the same time I got lutris, and am wondering if maybe lutris messed me up. Can’t seem to find a solution to this problem. I don’t want to have to manually create menu entries every time I install something either.

Hello @AlbertHamik :wink:

Normally the desktop files for wine should be located here: ~/.local/share/applications/ Are there any?

Don’t think so because lutris uses wine bottles sandboxed.

the location you mentioned ( ~/.local/share/applications/) has wine-extension-*.desktop files only, it seems. That and two .desktop files with userapp-wine something in the filename.

Do you have it hidden in Menu Libre (menu editor)?

I have the wine submenu in whatever menu editor I have, and I was able to put in that wine submenu into the whisker menu. The problem with it, and the reason I titled this thread the way I did, is that that Wine submenu is basically empty:


This might be the wine submenu I got from installing wine-installer from AUR.

No idea what you did before… If there should be applications listed, then wine usually creates desktop files at ~/.local/share/applications/wine/ when installing them.

When you install AUR packages, then have a look what they do.

I don’t have a ~/.local/share/applications/wine/, there’s only the individual .desktop files I had mentioned prior that don’t seem to correspond to what you’re talking about.


If so, then no shortcuts of installed windows applications will be displayed in the menu.

No “*.desktop”-files → No menu shortcuts

Anything or anyone have removed them or they were not there, if they ever were there.

So basically, I don’t know why they never generated. And I only just recently tried out the AUR stuff. Ever since I installed Wine, there’s been no menu shortcuts for anything I’ve installed for wine. I also tried using the winemenubuilder to see if that could help me but it throws back tons of errors whenever I try using it. If it’s even what I need to use.


Lets try a custom test:

Create folder:

mkdir -p ~/ffs/prefix

Download freefilesync:

wget "" -O ~/ffs/setup.exe

Run the setup:

WINEPREFIX=~/ffs/prefix WINEARCH=win64 WINEPATH=~/ffs wine setup.exe

Check the desktop files:

ls ~/.local/share/applications/wine/Programs/

I tested it and it works.

Ok i guess it downloaded the file somewhere else… so your working dir was not $HOME. However look above, i have corrected -O ffs/setup.exe-O ~/ffs/setup.exe

Okay, now it works and it did create shortcuts in my wine submenu finally. Only question is, how can I create all the missing start menu stuff for the software I’ve already installed in my real prefix? And can I safely delete this test stuff to not mess me up?

Reinstall them or create the desktop files yourself. There is no “recreate desktop files” function.

yes you can.

There needs to be such a thing, as wine uninstaller and the prefix at least has all the installed application info intact.

Okay I tried installing something again from scratch, by running it directly with wine, and it hasn’t made a menu. Is there a custom command I can put in that can be opened by my browser or whatever? As in whatever you told me above.

Just don’t delete them in your home folder. And over all, it is a good habit to have each app in its own wine bottle (prefix).

I only use the main prefix for a handful of default applications I always use.

No, wine just translates what the setup says. Can you give me an example which app?

I tried installing irfanview again, using whatever wine launcher I have bound in my firefox download options (or systemwide, not sure how that functions in wherever, bit tired atm lol).

Realizing there’s a small chance I’m maybe using the wrong wine maybe? I have lutris on this system after all, maybe I accidentally picked the wrong wine to launch and that’s why it doesn’t generate submenu stuff.

Which version?

wine --version

Will try that…