Wine not working


#1

since latest update wine is not working, including the applications… it constantly says bad format


#2

Wine itself says that, or linux does? Try opening wine explorer and open an application from there.


#3

No problem here.
Please be more specific: applications not working, version of wine, etc.


#4

wine Version 2.18-1. the previous version worked, i could run windows games to be specific need for speed. i have tried running the games by executing the exe file through wine explorer but response is the same it says bad format.,


#5

Did you try downgrading wine or freetype2 and try again?


#6

I have a couple of installations bugging on the subject.

I have been backtracking to see if I could pinpoint the issue but with no luck.

In one case it is a missing libncurses.so.5 which really do not make sense. The compat library was up-to-date and my libncurses was v6

Another case was a basic test bottle with no apps and it fail the simple task of opening the wine notepad.

I have no idea what it is but I am grateful I am not depending on running windows apps under wine.

That said never expect wine to replace windows - ever - period


#7

Since I’m using crossover linux regulary and it doesn’t work with certain apps anymore since the freetype2 update I think this could be related to that maybe?

https://aur.archlinux.org/packages/crossover/

Some apps from crossover stopped working
I had many mistakes like this:

wine: Unhandled page fault on read access to 0x00000004 at address 0x7ea48dde (thread 0028), starting debugger…
winedbg: Internal crash at 0x7e72bdde

TO solve the problem I downgraded lib32-freetype2 to lib32-freetype2-2.7.1-2 and it resumed working


#8

how to i downgrade a package


#9

locate the package in question in the folder

/var/cache/pacman/pkg

For example do

ls /var/cache/pacman/pkg/lib32-freetype2*

Then (replace <version> and <pkgrel> with the actual values)

sudo pacman -U /var/cache/pacman/pkg/lib32-freetype2-<version>-<pkgrel>.pkg.tar.xz

#10

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.