Wine broken, hangs on launching any program, hogs all the memory and makes PC unresponsive


I’ve been using Manjaro for a year now, but I’m still kind of a newbie, as I mostly use the PC for gaming or entertainment, and I’m not very knowledgeable of the inner workings of Linux.

After originally going through a hassle to get Manjaro installed and properly working with my hardware configuration, everything ran great for a long time, I got Steam Proton working without hassle and could also run games outside of steam most of the time with Wine. A couple months ago I updated Manjaro (which I had mostly not done for a while) and after that Wine broke. At first I thought it was related to one particular game (of which an earlier version had worked just fine) so I guessed the latest version was just not compatible, didn’t really try again and went back to my steam games, hoping the next release would work. However, a couple days ago I tried using Wine for some other games and nothing seemed to run. Launching any game or program via Wine would just do nothing for a while and then the PC would become completely unresponsive. When I open KSysGuard, it just shows the memory usage going up until it reaches the max, after which the only thing that helps is a hard reset.

I’ve usually updated via the Add/Remove Software app since I’m not great with the terminal, so my original thought was to just go and update anything wine-related already installed on my machine. Somehow doing that also updated my Kernel version, which for a while made me boot into a black screen (apparently cause the nvidia drivers dont work?), until I googled how to get to the GRUB menu at boot and select my old Kernel (any help on how to revert that update and automatically boot to 5.8 would be also appreciated :frowning: ). Anyhow, the whole update process didn’t solve the issue either. I’m out of ideas of what to type into Google at this point.

The rules forum said that I should include this in my post, let me know if there’s any other command outputs I need to provide.

  Kernel: 5.8.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=67f3ecf5-6ada-41e5-955d-62f4c47b6bd6 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.20.3 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: Gigabyte model: B450 AORUS M v: x.x serial: <filter> 
  UEFI [Legacy]: American Megatrends v: F42a date: 07/31/2019 
  Info: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+ 
  family: 17 (23) model-id: 8 stepping: 2 microcode: 800820D 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 86259 
  Speed: 2750 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 
  1: 3302 2: 1952 3: 2028 4: 1939 5: 1981 6: 2004 7: 1899 8: 1886 9: 3670 
  10: 1906 11: 2673 12: 2191 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA TU116 [GeForce GTX 1660] vendor: Micro-Star MSI 
  driver: nvidia v: 435.21 alternate: nouveau,nvidia_drm bus ID: 06:00.0 
  chip ID: 10de:2184 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nvidia 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 94 s-size: 519x292mm (20.4x11.5") 
  s-diag: 596mm (23.4") 
  Monitor-1: DP-2 res: 1920x1080 hz: 60 dpi: 96 size: 509x286mm (20.0x11.3") 
  diag: 584mm (23") 
  OpenGL: renderer: GeForce GTX 1660/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21 
  direct render: Yes 
  Device-1: NVIDIA TU116 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 06:00.1 chip ID: 10de:1aeb 
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus ID: 08:00.3 chip ID: 1022:1457 
  Sound Server: ALSA v: k5.8.18-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: f000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 931.51 GiB used: 782.58 GiB (84.0%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC43 scheme: MBR 
  ID-1: / raw size: 931.51 GiB size: 915.89 GiB (98.32%) 
  used: 782.58 GiB (85.4%) fs: ext4 dev: /dev/sda1 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 44.5 C mobo: N/A gpu: nvidia temp: 33 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 44% 
  Processes: 269 Uptime: 12h 41m Memory: 15.65 GiB used: 2.74 GiB (17.5%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 11.0.0 Packages: 
  pacman: 1472 lib: 403 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.08