Wine 6.7 broken

Ive been using all the previous verisions of Wine but now Ive updated to Wine 6.7 it no longer works. I have removed all my wine prefixes and create new prefix by using “winecfg” where it gets stuck updating the wine configuration.
Looking in the prefix itself, it appears that the “syswow64” folder is empty and the other folders like “system32” folders are full with files.
If I try and run a program or winecfg I get a “wine: could not load kernel32.dll, status c0000135” (becuase there is no kernal32.dll because syswow64 folder is empty).

Tested on all manjaro branches
Tested on 5.12.0-1 and 5.11.16-2 kernals
Tested on wine-6.7 and wine-staging-6.7
Gtx 1080ti 460 proprietary

Have you tried deleting the .wine config folder and remove and reinstall wine?

1 Like

Hi, thanks for the reply.
Ive already tried deleting the prefix and reinstalling wine.

This fixed an issue with 6.5. It might be worth a try here as well

cp -a ~/.wine/drive_c/windows/command/start.exe ~/.wine/drive_c/windows/

1 Like

Did you create a 64 bits prefix?

//EDIT: I ran winecfg and my prefix has a proper syswow64 folder full of stuff.

1 Like

Thanks for the help guys, I tired the solutions but they didnt work so I reverted to an old backup and updated and now it works. Thanks

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.