Windows not booting after dual boot installation of manjaro

Hello. I installed manjaro KDE Plasma to dual boot with windows 10 and I made two seperate partition as home and root. I also used the efi partition that was already present my marking it as /boot/efi during the installation. Previously I has ubuntu dual boot, which I deleted by clearing the ubuntu partition and removing the ubuntu folder from the efi partition. Now, Manjaro is installed successfully and opens fine via its OS selection menu but when I select windows option, Windows rolling ball animation is shown but then laptop will just restart and bring me back to OS selection menu. Also after few such attempts windows recovery menu is opened which shows automatic troubleshooting but it also fails. I have been trying to solve this for days now. Thank You for help in advance.

Here are some info which could help:

sudo parted -l


Model: ATA TOSHIBA MQ04ABF1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  263MB   262MB   fat32        EFI system partition          boot, esp
 2      263MB   397MB   134MB                Microsoft reserved partition  msftres
 3      397MB   376GB   375GB   ntfs         Basic data partition          msftdata
 9      376GB   418GB   42.4GB  ext4
10      418GB   506GB   88.1GB  ext4                                       legacy_boot
 4      506GB   746GB   240GB   ntfs         Basic data partition          msftdata
 5      746GB   984GB   238GB   ntfs         Basic data partition          msftdata
 6      984GB   985GB   1038MB  ntfs                                       hidden, diag
 7      985GB   999GB   13.7GB  ntfs                                       hidden, diag
 8      999GB   1000GB  1526MB  ntfs                                       hidden, diag
sudo ntfsfix /dev/sda3


Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sda3 was processed successfully.
sudo ntfsinfo -m /dev/sda3


Volume is scheduled for check.
Please boot into Windows TWICE, or use the 'force' option.
NOTE: If you had not scheduled check and last time accessed this volume
using ntfsmount and shutdown system properly, then init scripts in your
distribution are broken. Please report to your distribution developers
(NOT to us!) that init scripts kill ntfsmount or mount.ntfs-fuse during
shutdown instead of proper umount.
Failed to open '/dev/sda3'.

Maybe your EFI config for Windows is broken. Try This link

How does it come that legacy_boot flag for partition 10 is set? This is normally for BIOS boot. Are you sure you installed Manjaro in UEFI mode? Check by

test -d /sys/firmware/efi && echo efi || echo bios

To start Windoze from grub’s selection menu both OS must be installed in the same mode, i.e. either both in UEFI or both in BIOS mode.

The Windows still won’t boot, although its not restarting like previously but now it gives an blue screen error with code 0xc0000001.

test -d /sys/firmware/efi && echo efi || echo bios

This returns


Also before installing manjaro, when I checkdd through windows it showed uefi. And by looking from the size of this partition I am supposing it to be my /home partition which I set during installation. Although I have not set legacy boot flag during the installation.

have you tried basic fixmbr and fixrec commands by going to cmd prompt in recovery? Or tried something to fix broken windows installation by doing web search of “windows installation broken”

No I have not tried fixmbr or fixrec . I have only tried ntfsfix and bcdboot . Should I try using fixmbr and fixrec? And If yes, How should I use fixmbr and fixrec?

I don’t want to be rude, just want to help… isn’t it better to look for help in a Windows forum?

From your description of the problem it seems that Manjaro has nothing to do with the Windows problem (Windows starts to boot at least and no Windows partition was redimensioned/touched)

Probably in a Windows forum they have better knowledge and understanding of troubleshooting tools…

Yeah, It seems You are right and I should ask there too. Actually I don’t where the problem is :sweat_smile: so I asked here. Anyway thanks for the help :+1: