Windows does not start after fresh Manjaro installation

Hello,
I have a HP notebook on which I had previously installed Windows 11 and Kubuntu. Secure boot was activated in the BIOS. When booting, I was able to select the OS via Grub. Since I use Manjaro KDE on my main computer and had problems with Ubuntu, I would like to switch the notebook to Manjaro as well.

So I created a USB stick with a Manjaro image. The starting situation is (unfortunately) as follows:

The notebook could not boot from the Manjaro-USB stick because of Secure boot (it showed an error message). So I switched off Secure boot for the installation. (Maybe the first mistake?)

I was then able to boot Manjaro from the USB stick. I installed Manjaro as follows:

Formatted existing / (root) and mounted as /
Keep existing SWAP
Existing /boot/efi FAT32 (260 MB in size) formatted and mounted as /boot/efi (presumably this was a mistake …?)
Existing Windows OS not formatted and mounted as /winos
Existing Windows data not formatted and mounted as /windata
Existing /home kept (not formatted) and mounted as /home

Manjaro is installed and running stable. But when I boot, I do not see a grub screen, but Manjaro boots immediately. a sudo update-grub worked, but does not find Windows.

The Windows partitions are there and intact. But I can’t boot it. What a bummer!

Can someone please help me with the above situation? Thank you!

Secure boot is still off. If I switch it on now, I cannot boot anything …

Cheers
Eriol

You seem to have spent much time troubleshooting possible causes.

The simple fact is that Manjaro does not support Secure Boot; at least, not by default. This is why Manjaro isn’t booting: Secure Boot is preventing it. Disable Secure Boot and magic will happen.

If you are able to negotiate the required hoops to self-sign a certificate and manually sign the required files, it is however possible, but there is no ready made instruction manual for it. You might need to do your own research.

I’ll try to attract a few suggestions for you. @linux-aarhus

Otherwise, if you’re happy to run without Secure Boot on Windows 11, this might help:

If Secure Boot is enabled due to a Microsoft requirement (Windows 11), a workaround must be employed to allow Windows to boot without Secure Boot.

The following Windows registry modification may be useful. Naturally, it should be applied and verified to be working with Secure Boot disabled, before you attempt to boot Manjaro again.

BypassSecureBootCheck.reg:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\Setup\LabConfig]
"BypassSecureBootCheck"=dword:00000001

Cheers.

1 Like

Hello @Eriol,

if you follow @soundofthunder advice you can boot manjaro again.

Then you can open the following file in a text editor:

/etc/default/grub

There change the line:

GRUB_TIMEOUT_STYLE=hidden

to:

GRUB_TIMEOUT_STYLE=menu

And take a look for this line:

GRUB_DISABLE_OS_PROBER=true

Change this to:

GRUB_DISABLE_OS_PROBER=false

If the line isnt there you can add it.

The first option will activate showing the grub-menu and the second will activat os_prober which will look after windows installations.

After that you need to update grub:

sudo update-grub

Good luck … :slightly_smiling_face:

1 Like

Not necessarily.

What @kisun said.

os-prober needs to be enabled, as well as RAID turned off in the BIOS/UEFI.

To enable os-prober, open the file /etc/defasult/grub with your favourite text editor. I’ll use nano for this:

sudo nano /etc/default/grub

Change the line containing:

GRUB_DISABLE_OS_PROBER=true

…to be:

GRUB_DISABLE_OS_PROBER=false

Save, Ctrl + o, and exit, Ctrl + X

Now rebuilt the initramfs:

sudo mkinitcpio -P

And that should help when you reboot.

There are couple of different common mistakes that can lead to this. Assuming Secure boot is now off (has to be):

  • once again check the UEFI situation. In the firmware settings, turn off CSM. Is the flash drive created in uefi or bios mode? Is the system booting in efi mode after install.
    If the machine is relative new, probably everything is uefi by default and that is not the reason.
    You can easily check from the installed manjaro
[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
  • secondly, the grub menu may be just hidden…hit esc or shift while booting to show (i have forgotten which key)

  • thirdly, which is very probable, the default config was changed some time ago and the detection of other oses is turned off by default (and thus makes sense that the menu is hidden, if it is with only one item)

Here is a simple config from my grub file, to unhide the menu and activate os prober, and to save the last booted entry (you have to edit with sudo micro /etc/default/grub , assuming you have micro installed , the default editor is vim or nano, not very user friendly)

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Manjaro"
.....................

# Set to 'countdown' or 'menu' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT_STYLE=menu

........................





# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.
GRUB_SAVEDEFAULT=true

.........

# Uncomment this option to enable os-prober execution in the grub-mkconfig command
GRUB_DISABLE_OS_PROBER=false

.........

after you make the changes, you execute sudo update-grub

Sorry, but that’s incorrect;

The one and only correct string is GRUB_DISABLE_OS_PROBER=false, which must be either:

  • Commented (to disable os-prober), or
  • UNcommented (to enable os-prober)

I know it seems counter-intuitive, but it’s been this since the GRUB decision to disable it by default was made.

And, err… in recent KDE ISO’s, os-prober is actually enabled again by default; though I’m uncertain about the other distributions.

Cheers.

2 Likes

Damn, i type slow :slight_smile:
But i guess that is high quality support, when you receive the same answer from 4 people.

p.s. a very good point from Soundofthunder. I have heard that in SOME cases the secure boot may be needed as requirement for windows 11. Me personally have not seen this (my 11 boots without sec boot and patches), maybe it is valid for some editions of windows. So in that case you will need to apply the registry patch.

2 Likes

Hello,
The current situation is: secure boot is off. Manjaro boots fine. No problem with Manjaro.
Windows does not boot at all. Neither with secure boot off (current status) nor if I turn it on in BIOS.
I booted into Manjaro and tried a update-grub.

I would like to follow your advise, but how can I change Windows registry from Manjaro? Is there a tool that I can use?

After I did this I will then do the other settings recommended for grub in Manjaro.

Honestly, I do not really care for secure boot. It only creates trouble for me. But ubuntu had no problems with it apparently.

BR
Bogislav

Windows 11 will not boot without Secure Boot enabled, unless you by bypass the check, as described.

No, There is not.

Enable Secure Boot (in BIOS), and boot into Windows to appy the registry modification. Reboot, disable Secure Boot (in BIOS), and boot Windows again to confirm Windows will boot without it enabled. From that point you should have a better base to work with.

This, I didn’t notice initially.
Are both of these newly installed (Manjaro and Windows 11)?
Are you trying to install both on the same disk or are they on separate disks?

First fix the OS-Prober and the menu. You will see if it is detected after you execute update-grub.
A sample output (the 2 errors are normal and just warnings and minor bugs)

[teo@teo-lenovo-v15 ~]$ sudo update-grub 
[sudo] password for teo: 
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-6.6-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-6.6-x86_64.img
Found initrd fallback image: /boot/initramfs-6.6-x86_64-fallback.img
Found linux image: /boot/vmlinuz-6.1-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-6.1-x86_64.img
Found initrd fallback image: /boot/initramfs-6.1-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Windows Boot Manager on /dev/nvme0n1p1@/efi/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for UEFI Firmware Settings ...
Root filesystem isn't btrfs
If you think an error has occurred, please file a bug report at "https://github.com/Antynea/grub-btrfs"
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
Found memtest86+ EFI image: /boot/memtest86+/memtest.efi
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
done

1 Like

Hi,

I activated Grub menu and it shows me the Manjaro options, but no Windows.

I post some output below:

bogislav@MobileMessiah:~$ [ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
UEFI
bogislav@MobileMessiah:~$ sudo update-grub
GRUB-Konfigurationsdatei wird erstellt …
Thema gefunden: /usr/share/grub/themes/manjaro/theme.txt
Linux-Abbild gefunden: /boot/vmlinuz-6.6-x86_64
Initrd-Abbild gefunden: /boot/intel-ucode.img /boot/initramfs-6.6-x86_64.img
Found initrd fallback image: /boot/initramfs-6.6-x86_64-fallback.img
Warnung: Zur Erkennung anderer bootfähiger Partitionen wird os-prober ausgeführt.
Dessen Ausgabe wird zur Erkennung bootfähiger Programmdateien und Erzeugen neuer Boot-Einträge verwendet.
Bootmenü-Eintrag für UEFI-Firmware-Einstellungen wird hinzugefügt …
Root filesystem isn't btrfs
If you think an error has occurred, please file a bug report at "https://github.com/Antynea/grub-btrfs"
Found memtest86+ image: /boot/memtest86+/memtest.bin
Found memtest86+ EFI image: /boot/memtest86+/memtest.efi
abgeschlossen

Grub does not (!!!) find a windows installed. If I enable secure boot in BIOS (UEFI) and reboot, I get an error message that no boot device was found (or something like this). I cannot bot into Windows. When secure boot is enabled, nothing (!) works.

What I could try now is:
Enable secure boot and install Kubuntu again and hope that Kubuntu installer fixes my issues, finds Windows and adds it into the grub menu. Sigh … I was hoping that I could use Manjaro on this notebook in a dual boot with Windows 11.

I rarely boot Windows, but for some use cases I do. Any hint to reactivate the possibility to boot into the existing Windows 11 would be great.

One again: the /boot/efi was formatted during Manjaro installation. Maybe something is missing now in /boot/efi that Manjaro cannot find? I am completely puzzled …

Are both of these newly installed (Manjaro and Windows 11)?
Are you trying to install both on the same disk or are they on separate disks?

Indeed.

1 Like

Thus the windows efi loader is missing

Yes. Windows efi loader is missing. That is the problem. Is there a way to solve this?

I had purchased the notebook with Windows 11 pre-installed. Then I had re-partitioned the harddisks and installed Kubuntu next to Windows 11. This worked as a dual boot under grub, Kubuntu had recognized Windows 11 installation and just added both to the grub list.

The partition table is:

sda1 - /windows data
sda2 - /home
sda3 - swap

sdb1 /boot/efi
sdb2 windows reserved
sdb3 /windows os
sdb4 / (linux root)
sdb6 windows

Notebook came with Windows 11
I had installed Kubuntu next to it, years ago.
Secure boot was on, all worked, dual boot, grub.

Now, I intended to change from Kubuntu to Manjaro, clean install over Kubuntu root (/) partition. See my first post and my last post where I tried to explain the situation.

The partitioning was partially due to HP pre-setup.

sda is a HDD, sdb is a SDD.

Eriol

… not really with linux tools I guess. Best solution should be a windows-usb stick to rebuilt the windows efi.

I never did this but there are enough sites on the net for “rebuilt windows.efi”.

:slightly_smiling_face:

Yes, google it. Or ask in some Windows forum.

I did so already. I will have to create a WinPE bootable USB stick, rebuild the win efi partition, …

That’s it then with Manjaro for me on this notebook I fear. Kubuntu has never made any trouble with dual boot, secure boot, etc.

Thanks for your quick responses to everybody here. Problem is not solved, but I have a plan now.

1 Like

Problem is you nuking EFI partition. You can install any linux distro now and Windows still won’t work. And you can use secure boot with Manjaro, you’ll just have to read some archwiki pages and figure it yourself.