Windows does not appear to boot - SSD UEFI Dual boot

Hi guys! Can you all please help me?

I use manjaro a lot but now i’ve bought a new notebook, and all i wanted to do is the same again, a dual boot system, but this time i tried to do it with UEFI (in my old notebook i used Legacy mode for Manjaro and UEFi for WIndows 10)

I have now an Acer Nitro 5 AN515-43-R4C3, with 128GB SSD and 1TB HD.

I installed manjaro creating the root, swap and boot/efi partition on the SSD (windows was already installed), i done this resizing the unique partition (was the windows partition only), and i resized too the HD partition and i set /home in the one partition of HD.

So… When i was installing manjaro, the installer stopped to keep working (not crashed and neither freezed), but the percentage didn’t increased). So… I stopped this install and tried again, but this time manjaro was warning that i didn’t set the ESP FLAG on the /boot/efi partition, and due to this, the system would not boot. So, okay, i tried to set the flag, but there was no option for that (this flag never appeared no matter what i was trying). So… i accepted the circumstances and forward.

Okay… Now the system didn’t boot, but i could open the live usb manjaro, and using gparted i put the ESP FLAG on the /boot/efi partition and restart the system and install again. Aaand finally the installer didn’t warned me of anything, and the installation was successful again!

After that, i realized that i can only boot with manjaro (The GRUB for select boot DOES NOT APPEAR), and the name of the boot (in the boot list of BIOS) it’s blank, in the first moment was “null string” haha, and after some reboots, it’s just blank…

I lost my windows 10 boot :frowning:

Here i will show you all how it’s my boot configuration, and i will show a print of gparted partitions too

I can run commands, print outputs and i still having the windows boot USB, if needed :slight_smile:

Where it’s blank, should be the manjaro grub or something, in this place was my SSD :frowning:
Or… Waaait… The Storage that have 128GB it’s my SSD! I don’t understand nothing more! Where it’s my HDD?!

My SSD with root, swap and /boot/efi with boot and esp tag

My HD with /home and other partition that i will use in windows (forget about the other partition)

PS: I also tried sudo update-grub and sudo os-prober

Thank you all!

Seems like you messed up and lost your Win10 partition…
Could you for completeness paste output of sudo efibootmgr -v? (Inside ``` on (separate lines))
And also sudo tree /boot/efi?

1 Like

Hi! Thank you! Okay, i will run it here, but… maybe if i run the windows 10 startup repairer through the pendrive, would it fix this problem?

Or maybe i should set grub flag for the boot partition?

sudo efibootmgr -v:

BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000,2001,2002,2003
Boot0000* Manjaro       HD(2,GPT,e652867f-ca58-314f-bd67-3e6c5f5cbd22,0x6400800,0x96000)/File(\EFI\Manjaro\grubx64.efi)
Boot0001* HDD2: IM2P33F8BR1-128GB       PciRoot(0x0)/Pci(0x1,0x2)/Pci(0x0,0x0)/NVMe(0x1,00-00-00-00-00-00-00-01)/HD(2,GPT,e652867f-ca58-314f-bd67-3e6c5f5cbd22,0x6400800,0x96000)RC
Boot2001* EFI USB Device        RC
Boot2003* EFI Network   RC

sudo tree /boot/efi:

└── EFI
    ├── boot
    │   └── bootx64.efi
    └── Manjaro
        └── grubx64.efi

You don’t have any Win10 left to repair…

1 Like

have you tried mounting the windows boot partition and running sudo grub-update
and for that matter do you even have a windows boot partition left

1 Like

So… Guys, i decided to format my ssd installing windows again, and so, was working okay!

After installing Windows, i immediately installed manjaro and apparently everything was working fine! I did everything just like the previous installation, but this time I already had the 3 windows partitions and instead of creating a new /boot/efi partition, I used the windows /boot/efi partition, putting the /boot/efi flag on it when installing the manjaro, which i think is more correct.

After restarting, i can choose between windows or manjaro normally as planned!

Windows now works perfectly, but manjaro crashes when loading (keeps loading infinitely after the “Started TLP system startup / shudown” log)

I tried to disable fast boot, and i already tried too boot with my usb pendrive, and tried with the non free driver too, but… Nothing. Sometimes it works and starts manjaro, but my keyboard and mouse does not work! It’s very strange.

I already tried to press E in grub and edit modprobe.nomodeset setting the 0 value, and nothing (tried this only with live usb)

Do you guys know something that i can do now?
1 - Maybe this issue it’s because of my graphic card… A conflict with the CPU integrated GPU (Ryzen 7 3750H has an vega GPU integrated) :frowning:

2 - Maybe it’s because my home it’s on HDD and not SSD. I saw in a topic that the user solved this issue switching HD SATA to AHCI on BIOS…

3 - Maybe it’s because of my kernel version? That maybe doesn’t support amd integrated gpu + nvidia dedicated gpu

PS: I can login with tty :slight_smile:

Tried to add blacklists lines to /etc/modprobe.d/blacklist.conf ( i created this file)
blacklist nouveau
blacklist nvidiafb
blacklist rivafb

And the same problem…

When i run mhwd -li, show me that i have only the video-linux driver installed

Do i have to do that? :
1 - sudo mhwd -r pci video-linux

then install video-nvidia or another driver? Like video-hybrid-intel-nvidia-440xx-prime? But… My CPU it’s an AMD Ryzen 7 3750H and my GPU Nvidia GTX 1650… I use this driver in my older notebook with manjaro, intel i5 and nvidia

2 - sudo mhwd -a nonfree 0300

Result of commands:

1 - sudo dmesg | grep gpu:

[    4.063597] [drm] amdgpu kernel modesetting enabled.
[    4.064005] amdgpu 0000:05:00.0: remove_conflicting_pci_framebuffers: bar 0: 0xb0000000 -> 0xbfffffff
[    4.064006] amdgpu 0000:05:00.0: remove_conflicting_pci_framebuffers: bar 2: 0xc0000000 -> 0xc01fffff
[    4.064008] amdgpu 0000:05:00.0: remove_conflicting_pci_framebuffers: bar 5: 0xc2600000 -> 0xc267ffff
[    4.064011] fb0: switching to amdgpudrmfb from EFI VGA
[    4.064087] amdgpu 0000:05:00.0: vgaarb: deactivate vga console
[    4.066663] amdgpu 0000:05:00.0: VRAM: 2048M 0x000000F400000000 - 0x000000F47FFFFFFF (2048M used)
[    4.066665] amdgpu 0000:05:00.0: GART: 1024M 0x0000000000000000 - 0x000000003FFFFFFF
[    4.066667] amdgpu 0000:05:00.0: AGP: 267419648M 0x000000F800000000 - 0x0000FFFFFFFFFFFF
[    4.068322] [drm] amdgpu: 2048M of VRAM memory ready
[    4.068325] [drm] amdgpu: 3072M of GTT memory ready.
[    4.068348] [drm] GART: num cpu pages 262144, num gpu pages 262144
[    4.074805] amdgpu: [powerplay] hwmgr_sw_init smu backed is smu10_smu
[    4.353514] snd_hda_intel 0000:05:00.1: bound 0000:05:00.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])
[    4.373021] fbcon: amdgpudrmfb (fb0) is primary device
[    4.373029] amdgpu 0000:05:00.0: fb0: amdgpudrmfb frame buffer device
[    4.392656] amdgpu 0000:05:00.0: ring gfx uses VM inv eng 0 on hub 0
[    4.392659] amdgpu 0000:05:00.0: ring comp_1.0.0 uses VM inv eng 1 on hub 0
[    4.392661] amdgpu 0000:05:00.0: ring comp_1.1.0 uses VM inv eng 4 on hub 0
[    4.392663] amdgpu 0000:05:00.0: ring comp_1.2.0 uses VM inv eng 5 on hub 0
[    4.392664] amdgpu 0000:05:00.0: ring comp_1.3.0 uses VM inv eng 6 on hub 0
[    4.392666] amdgpu 0000:05:00.0: ring comp_1.0.1 uses VM inv eng 7 on hub 0
[    4.392667] amdgpu 0000:05:00.0: ring comp_1.1.1 uses VM inv eng 8 on hub 0
[    4.392668] amdgpu 0000:05:00.0: ring comp_1.2.1 uses VM inv eng 9 on hub 0
[    4.392670] amdgpu 0000:05:00.0: ring comp_1.3.1 uses VM inv eng 10 on hub 0
[    4.392672] amdgpu 0000:05:00.0: ring kiq_2.1.0 uses VM inv eng 11 on hub 0
[    4.392674] amdgpu 0000:05:00.0: ring sdma0 uses VM inv eng 0 on hub 1
[    4.392675] amdgpu 0000:05:00.0: ring vcn_dec uses VM inv eng 1 on hub 1
[    4.392677] amdgpu 0000:05:00.0: ring vcn_enc0 uses VM inv eng 4 on hub 1
[    4.392679] amdgpu 0000:05:00.0: ring vcn_enc1 uses VM inv eng 5 on hub 1
[    4.392680] amdgpu 0000:05:00.0: ring vcn_jpeg uses VM inv eng 6 on hub 1
[    4.405591] [drm] Initialized amdgpu 3.35.0 20150101 for 0000:05:00.0 on minor 0

2 - sudo dmesg | grep sd:

[    1.888098] sd 0:0:0:0: [sda] 1953525168 512-byte logical blocks: (1.00 TB/932 GiB)
[    1.888100] sd 0:0:0:0: [sda] 4096-byte physical blocks
[    1.888113] sd 0:0:0:0: [sda] Write Protect is off
[    1.888115] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    1.888133] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    2.028409]  sda: sda1 sda2 sda4
[    2.029419] sd 0:0:0:0: [sda] Attached SCSI disk
[    2.781747] sd 0:0:0:0: Attached scsi generic sg0 type 0
[    3.689610] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)
[    4.065578] [drm] add ip block number 5 <sdma_v4_0>
[    4.392674] amdgpu 0000:05:00.0: ring sdma0 uses VM inv eng 0 on hub 1

I will create a new topic for that, since it’s another problem now. Thank you all :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.