Windows cannot update after manjaro dual boot installation

After I installed manjaro as on my xxxxx computer, Windows 10 fails to update. When you try and update it, it tries to update for a few minutes, restarts, keeps on trying to update and then eventually says “failed to update, undoing changes”. After logging into the Windows system and going to the about “Windows Update” section in settings, it gives this error code:


According to this Microsoft Answers page:


, the error is caused by the system reserved partition having less than 500mb.

Could this have been caused by Manjaro’s formatting during the installation in some way? If so, how can I fix it? (If it requires resizing the partition, which one do I need to resize and how?)

Here is a screenshot of the windows disk management tool:


Here is manjaro gnome’s disk management tool (gparted):


1 Like

For some reason the forum won’t let me post links or images, so here are the images, simply replace (dot) with the full stop character:

Windows disk management tool:




1 Like

Hello, is there any way to fix this? It keeps destroying the windows
partition the longer I don’t let this be fixed. After it failed to update, windows cannot shutdown. You can only press the “restart button”

Furthermore, due to it failing updates, it keeps downloading them for some reason and the windows installation takes up more than 40 gigabites of space.


Is there some way to fix this partition?

I tried to take some space from the windows partition and give it to /dev/sda1 in gparted. This was the only partition that was less than 500mb in space.

Obviously, this broke windows, it failed to boot.

Then I ran the bootrec commands that were listed on gparted’s FAQ page.

Obviously, that broke manjaro and grub as well, leaving me with a completely broken computer.

I think followed manjaro’s wiki on trying to restore the grub bootloader. That then booted me into grub’s command line.

I ran these commands (hd0,msdos4 is where linux was located):

set prefix=(hd0,msdos4)/boot/grub
set root=(hd0,msdos4)
insmod linux
insmod normal

It worked, I could boot into manjaro. From there in manjaro I ran sudo update-grub and rebooted to see if that worked.

Sadly, it was back in the terminal.
However, this time the commands didn’t work properly. Instead of taking me to the grub menu, it took me directly to the memory-tester.

So I tried reinstalling grub again. I booted again from a USB, and deleted the /grub & /boot/grub folders from my linux installation. Then I followed the steps from the wiki again.

This time, there was no command line when rebooting, however instaed of the grub menu showing up, again it booted directly into the memory tester.

Is there any way to fix this? Please help.

Also, why does the dual boot issue happen? I have tried dual booting manjaro with windows twice, and it the partition being less than 500mb error showed up twice. Why doesn’t manjaro installation just work out of the box?

plz show attached in this forum picture of your partitions2021-03-15_171822 2021-03-15_171917

you reinstall GRUB correct? with wiki solution?:

I used manjaro’s page.

Seems that some of the settings were retained somehow. I had set the default grub option to “2” (i.e. the third option). Before my computer broke that was windows. Now after reinstalling grub windows is no longer detected so option “2” was the memory tester. However, for some reason the menu does not show up and it automatically goes to option “2”.

Somehow I managed to open the menu before it booted into memory tester by MASHING all the keys on the keyboard.

Then when I did login in I did sudo nano /etc/default/grub and found the culprit:


According to GNU’s documentation, here is why mashing the keys worked:

If this option is set to ‘countdown’ or ‘hidden’, then, before displaying the menu, GRUB will wait for the timeout set by ‘GRUB_TIMEOUT’ to expire. If ESC is pressed during that time, it will display the menu and wait for input

I have absolutely no clue as to why this option was selected. But hey, atleast I can boot into manjaro now. Windows still isn’t detected by grub.

As for attaching images, for some reason this forum doesn’t let me have links or images in my post, so I can’t do that.

I am somewhat technically competant, but how on earth is someone with much less computer related skills able to solve bugs like grub breaking & windows failing to update?

Seems like grub can’t detect windows due to a security patch?


I found out about this here:

You can easily fix this by adding GRUB_DISABLE_OS_PROBER="false" to the grub config file, but surely this makes it even more complex for newer users? Surely, if you are going to disable a feature that is required to allow dual-booting for a “security patch”, you need to add functionality to make dual-booting work first?

By adding the GRUB_DISABLE_OS_PROBER line to my grub file, I think windows should be detected

if windows loader not broken, add the line “GRUB_DISABLE_OS_PROBER=false” to “/etc/default/grub” then run “sudo update-grub”
(chande line “GRUB_TIMEOUT_STYLE” = to “menu” if menu dont want to wait for timer )
if windows loader are broken, restore windows loader - type in safe mode in windows Bootrec.exe /FixMbr ( Bootrec.exe /FixMbr /FixBoot), load in windows to verify correct loading, then reload system, then restore grub from restore grub tool in live-usb installer of linux

Yup. Windows was detected. I found out about that command (GRUB_DISABLE_OS_PROBER) from another reddit post. I just was mentioning how I think it is stupid to just “disable” it due to “security reasons” and provide no alternative to detect windows partitions other than to enable it manually.

As for windows, just tried to boot into it, and I got a “your PC/Device needs to be repaired” with error code 0xc0000225, and it is telling me \Windows\system32\winload.exe is missing.

As for bootrec commands, I am really, really worried about having to do those again…

It literally deleted grub last time.

And now I booted into windows again, I am having the same issue when I moved the partition using gparted. I am presented with a black screen with a few dashed white lines going through the middle, and nothing goes on from there…

I don’t want to run bootrec commands because that will lead me back to square one by destroying GRUB

hard disc naming error? change it from safe mode in windows and windows was run

This isn’t really that clear. I booted from the windows recovery usb stick I have, and ran automatic start-up repair, this didn’t fix anything. It is suggesting to get a Windows VM to run on your USB stick? And the other solution is bcd related commands, which I am worried will delete grub.

link was for example. i writed above:

in link was text of 1 of fixing examples - how to change active partition in problem in partition activiti status, for example

hard disc naming error? change it from safe mode in windows and windows was run

What exactly do you mean?

I tried doing bootrec commands again. Firstly, bootrec /fixmbr worked. (This broke grub). Then, bootrec /fixboot didn’t work, it says volume does not contain a recognized file system, so that does look like a “hard disk naming error”.

EDIT: Grub booted into grub rescue, where I could just did this:

set prefix=(hd0,msdos4)/boot/grub
set root=(hd0,msdos4)
insmod linux
insmod normal

and it worked

EDIT 2: The bootrec /scanOS command (or rebuildBCD command) finds windows on E:/ drive instead of C:/. I am not going to run those commands again (because they break grub), but when I did it before, it did show WIndows on E:/

for me too long and hard translate text and variants, try find in microsoft page all details of xxxx225 error, or find in google text of this error in “How to fix error code 0xC0000225 on Windows 10” 3 variants: activiti chandes, autofix, or repair bcd. you say that repair not work. i say that you can check active status. next you can check bcd fix

The Windows partition is stored on the E: drive for some reason, so I had to run the command chkdsk E: /f /r. However, this command seems stuck at 6% of files scanned (it has made no progress for like a minute now). So that command doesn’t seem to work.