Windows 10 32 bit Installation loop in Virtualbox


#1

I use Manjaro Gnome with the latest update.

I can’t install Windows 10 on my Virtualbox now. After selecting various Windows settings during the installation, like password, Cortana, privacy etc, Windows settings just come back again and the installation won’t proceed further. I have tried it for many times with new downloaded ISO.

Strangely, the Windows 10 installation on Virtualbox ran fine several days ago but I removed that virtual machine. I’m not sure my problem is caused by the recent update or Virtualbox bugs.

My system output:

System:
  Host: js_f Kernel: 4.19.6-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
  Desktop: Gnome 3.30.2 wm: gnome-shell dm: GDM 3.30.2 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: Latitude 5250 v: N/A serial: <filter> 
  Chassis: type: 9 serial: <filter> 
  Mobo: Dell model: 0HMFMD v: A00 serial: <filter> UEFI: Dell v: A14 
  date: 12/26/2016 
Battery:
  ID-1: BAT0 charge: 23.4 Wh condition: 26.2/38.8 Wh (68%) volts: 12.0/11.4 
  model: Samsung SDI DELL R5MD0D9 type: Li-poly serial: <filter> 
  status: Discharging 
CPU:
  Topology: Dual Core model: Intel Core i3-5010U bits: 64 type: MT MCP 
  arch: Broadwell rev: 4 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 16766 
  Speed: 798 MHz min/max: 500/2000 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
Graphics:
  Device-1: Intel HD Graphics 5500 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:1616 
  Display: x11 server: X.org 1.20.3 driver: i915 compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) 
  v: 4.5 Mesa 18.2.6 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Broadwell-U Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:03.0 chip ID: 8086:160c 
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:9ca0 
  Sound Server: ALSA v: k4.19.6-1-MANJARO 
Network:
  Device-1: Intel Ethernet I218-LM vendor: Dell driver: e1000e v: 3.2.6-k 
  port: f080 bus ID: 00:19.0 chip ID: 8086:15a2 
  IF: eno1 state: down mac: <filter> 
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: f040 
  bus ID: 02:00.0 chip ID: 8086:095a 
  IF: wlp2s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 119.24 GiB used: 29.78 GiB (25.0%) 
  ID-1: /dev/sda vendor: Samsung model: SSD PM851 2.5 7mm 128GB 
  size: 119.24 GiB speed: 6.0 Gb/s serial: <filter> rev: 8D0Q scheme: GPT 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: f060 bus ID: 00:1f.2 chip ID: 8086.282a rev: 03 
Partition:
  ID-1: / size: 108.46 GiB used: 28.43 GiB (26.2%) fs: ext4 dev: /dev/sda2 
  ID-2: swap-1 size: 8.25 GiB used: 1.34 GiB (16.3%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 45.0 C mobo: 37.0 C sodimm: 34.0 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 270 Uptime: 15h 46m Memory: 3.75 GiB used: 2.61 GiB (69.6%) 
  Init: systemd v: 239 Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 
  running in: gnome-terminal inxi: 3.0.27 

#2

Hi. Please post the output of the following so we know important information like what hardware you’re doing this on, and what drivers are handling said hardware (don’t forget to put ``` above and below the output for proper formatting):

inxi -Fzxxx

In addition, do you know what filesystem you have the virtual machine stored on? (ext4, xfs, btrfs, etc)


#3

And you did remove the ISO from the virtual machine?


#4

I had that problem also. I could install an older build I had lying around, but not the new one available from MS. Even worse, after upgrading the build, it stopped booting. I then tried to install the LTSB version, but it only booted if I chose Windows 2016 for the VM OS type. My desktop is old, so i don’t know if this is somehow related with some CPU extension or not.

I still haven’t left my Windows 7 VM for heavy work. I even use XP for light work. Much better and much faster than W10. Too bad support will end soon.


#5

Thanks! Yes, I removed the virtual machine by removing the ISO.


#6

Thank you. I’ve updated the system output in the original post.

Sorry, I’m not familiar with filesystem. How do I know that?


#7

You can see the filesystem(s) by running the following command:

df -Th

What build of Windows 10 are you trying to install in the VM? Have you tried older builds? If it’s the newest there’s been quite a few driver and system issues with it that may be the cause.

In addition, did you select “Windows 10 (32 bit)” when creating the VM? Did you change any of the VM settings before installing it?

I’ve only ever run into the infinite first run wizard twice before: once when I was attempting to relocate the Users folder to a Btrfs partition (as an experiment), and once when I forgot to check “Use Host I/O Cache” under Settings -> Storage -> Controller: SATA on the VM (the filesystem I use requires this for VMs).

In both cases, it was a problem with reading and/or writing the virtual hard drive. I suspect the issue you’re experiencing may be caused by something similar.


#8

I’m not sure which filesystem is for the VM. Is it /dev/sda2? Here is the filesystem output:

Dateisystem    Typ      Größe Benutzt Verf. Verw% Eingehängt auf
dev            devtmpfs  1,9G       0  1,9G    0% /dev
run            tmpfs     1,9G    1,8M  1,9G    1% /run
/dev/sda2      ext4      109G     29G   75G   28% /
tmpfs          tmpfs     1,9G    129M  1,8G    7% /dev/shm
tmpfs          tmpfs     1,9G       0  1,9G    0% /sys/fs/cgroup
tmpfs          tmpfs     1,9G    8,8M  1,9G    1% /tmp
/dev/sda1      vfat      300M    264K  300M    1% /boot/efi
tmpfs          tmpfs     385M     12K  385M    1% /run/user/120
tmpfs          tmpfs     385M    104K  384M    1% /run/user/1000

I used Windows 10 October build. Yes, I’ve selected select “Windows 10 (32 bit)” when creating the VM and I din’t change anything else before installing the VM.


#9

Likely not a filesystem issue (you are using ext4 for your primary partition).

SSDs (In my experience) don’t have the best longevity. Your SSD could be going out (not the best place to store a VM IMHO).

You can see if it’s going out by checking the S.M.A.R.T. attributes

  • Install and run gsmartcontrol
  • Double-click the SSD, then go to the Attributes tab
  • Expand the window as necessary, then post a screenshot of it

#10


#11

SSD looks fine. When you boot the VM, when it brings you to the first run wizard, can you press Ctrl Shift F3 and see if it successfully logs in as Administrator? (This should take you to an “audit” / “sysprep” mode)


#12

I pressed it but nothing happened. I’m not sure if I did it correctly.


#13

Make sure you use the Left Ctrl (the Right Ctrl will be reserved by Virtualbox as the “Host” key by default)


#14

Still won’t do anything unfortunately.


#15

Did you say you already tried deleting the VM, re-creating it, and trying the install again?


#16

Yes. So at this moment I don’t have a fully installed VM.


#17

Was the previous (working) VM installed with the same ISO?


#18

Yes it is.


#19

What size are you making the virtual hard drive? Are you using a VDI, VHD, or VMDK for the disk file type?


#20

It’s VDI.